Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

Report Bugs, Issues and non- pacakage Requests
Message
Author
User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16624
Joined: Fri Dec 15, 2006 8:07 pm

Re: [SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

#21 Post by Stevo » Sat Apr 14, 2018 8:23 pm

Now i have to wonder if the bug affects upstream Debian users, or just us on the Stretch platform. It should be fixed by the Debian maintainer if it affects all users. Can any antiX-Buster users check that out?

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: [SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

#22 Post by fehlix » Sun Apr 15, 2018 7:13 am

Stevo wrote:Now i have to wonder if the bug affects upstream Debian users...
Indeed the deb-package spacefm (1.0.6-1) in debian-sid shows the same
symptom regarding the missing remove-tag within the postrm
helper-script, which I have only checked for amd64- and i386 architectures.
So yes this would affect all Debian users if not fixed upstream.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5753
Joined: Sat Jul 15, 2006 10:40 am

Re: [SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

#23 Post by anticapitalista » Sun Apr 15, 2018 7:20 am

Confirmed error on my sid box.

Bug has already been reported.

https://bugs.debian.org/cgi-bin/bugrepo ... bug=893237
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16624
Joined: Fri Dec 15, 2006 8:07 pm

Re: [SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

#24 Post by Stevo » Sun Apr 15, 2018 6:29 pm

anticapitalista wrote:Confirmed error on my sid box.

Bug has already been reported.

https://bugs.debian.org/cgi-bin/bugrepo ... bug=893237
I'm glad that such a simple bug to fix was squished in a timely manner...wait, what? :confused:

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#25 Post by fehlix » Sat Oct 27, 2018 11:27 am

Stevo wrote:
Thu Apr 12, 2018 2:01 pm
I'm building a MX package that will be seen as higher than the antiX one. If anti builds 1.0.6-1~antix for the antiX repo, that should not be seen as higher than our repo version, but will still be available to the antiX users.
It seems to me I just had a Déjà vu with unmet dependencies:
antix spacefm 1.0.6-1.1 versions appears to be preferred by apt instead of 1.0.6-1.1~mx17+2,
but cannot be installed due to libeudev1 dependency:
This happend after yesterday upgrade of spacefm-common to antix version 1.0.6-1.1:

Code: Select all

sudo apt install spacefm spacefm-common
The following packages have unmet dependencies:
 spacefm : Depends: libeudev1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Code: Select all

apt policy spacefm spacefm-common
spacefm:
  Installed: (none)
  Candidate: 1.0.6-1.1
  Version table:
     1.0.6-1.1 500
        500 https://ftp.nluug.nl/os/Linux/distr/mxlinux/antix/stretch stretch/main amd64 Packages
     1.0.6-1.1~mx17+2 500
        500 https://ftp.nluug.nl/os/Linux/distr/mxlinux/mx/repo stretch/main amd64 Packages
        100 /var/lib/dpkg/status
spacefm-common:
  Installed: 1.0.6-1.1
  Candidate: 1.0.6-1.1
  Version table:
 *** 1.0.6-1.1 500
        500 https://ftp.nluug.nl/os/Linux/distr/mxlinux/antix/stretch stretch/main amd64 Packages
        500 https://ftp.nluug.nl/os/Linux/distr/mxlinux/antix/stretch stretch/main i386 Packages
        100 /var/lib/dpkg/status
     1.0.6-1.1~mx17+2 500
        500 https://ftp.nluug.nl/os/Linux/distr/mxlinux/mx/repo stretch/main amd64 Packages
        500 https://ftp.nluug.nl/os/Linux/distr/mxlinux/mx/repo stretch/main i386 Packages
Dependency:

Code: Select all

$ apt show spacefm=1.0.6-1.1~mx17+2   | grep -A1 ^Depends

Depends: libc6 (>= 2.14), libcairo2 (>= 1.2.4), libffmpegthumbnailer4v5, libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.41.1), libgtk2.0-0 (>= 2.24.0), libpango-1.0-0 (>= 1.18.0), libpangocairo-1.0-0 (>= 1.14.0), libstartup-notification0 (>= 0.4), libudev1 (>= 183), libx11-6, spacefm-common (= 1.0.6-1.1~mx17+2), desktop-file-utils, shared-mime-info, e2fsprogs
Recommends: udisks2
fehlix@mx171:~/Desktop
$ apt show spacefm=1.0.6-1.1   | grep -A1 ^Depends

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Depends: libc6 (>= 2.14), libcairo2 (>= 1.2.4), libeudev1, libffmpegthumbnailer4v5, libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.41.1), libgtk2.0-0 (>= 2.24.0), libpango-1.0-0 (>= 1.18.0), libpangocairo-1.0-0 (>= 1.14.0), libstartup-notification0 (>= 0.4), libx11-6, spacefm-common (= 1.0.6-1.1), desktop-file-utils, shared-mime-info, e2fsprogs
Recommends: udisks2
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5753
Joined: Sat Jul 15, 2006 10:40 am

Re: [SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

#26 Post by anticapitalista » Sat Oct 27, 2018 12:27 pm

I uploaded this version of spacefm to the antiX repo thinking and hoping that it would not trump the existing (for MX users) spacefm in the MX repo. It would be better for me and antiX if the MX version can be rebuilt to make sure it will be higher than the antiX version.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16624
Joined: Fri Dec 15, 2006 8:07 pm

Re: [SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

#27 Post by Stevo » Sat Oct 27, 2018 7:31 pm

It stems from our addition of "~mx17" to the version, which makes it seen by apt as lower than any version without the addition, so antiX's -1.1 is higher than -1.1~mx17+1. This the same method used by the backports repo to allow a smooth upgrade in place to the next Debian release, which we are hoping will also hold true for the next Buster-based MX.

Buster now has has a -3 version of spacefm, so we could do a -3~mx17+1 version to again go ahead of antiX, but this is just a bandaid. Things that could fix the problem:

antiX adopts the same scheme for their backports, so spacefm_1.0.6-3~antix17 will be seen as lower than spacefm_1.0.6-3~mx17.

MX adopts a higher pinning, such as 600, in the repo's Release file...though I'm not really sure how this would work out. This needs discussion.

Edit: did a 1.0.6-3~mxXX version for a temporary fix of this problem.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: [SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

#28 Post by fehlix » Sat Oct 27, 2018 8:30 pm

Thanks, Stevo.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Bugs and Non-Package Requests Forum”