Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

Report Bugs, Issues and non- pacakage Requests
Message
Author
User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2030
Joined: Wed Apr 11, 2018 5:09 pm

[SOLVED] spacefm 1.0.6 upgrade-error in MX-17.1

#1 Post by fehlix » Wed Apr 11, 2018 6:12 pm

Moin,
last weeks upgrade made the file manager spacefm to disappear within my
MX-17.1 installation due to a dependency issue. :confused:
Changing (patching) manually the dependency from libeudev1 to libudev1
within spacefm_1.0.6-1_amd64.deb fixed it. :number1:
Upgrading from spacefm-1.0.5 will result in un-installing spacefm.
As a very long time spacefm-user and a very long-time MX-user
unbelievable - my first post!!
Last edited by fehlix on Sat Apr 14, 2018 7:47 pm, edited 1 time in total.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16568
Joined: Fri Dec 15, 2006 8:07 pm

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#2 Post by Stevo » Wed Apr 11, 2018 6:47 pm

Is the new spacefm coming from the antiX repository?

It would seem that allowing for both udev and eudev as alternative dependencies in the deb package would also work. Or we may have to build an MX version which will be seen as newer by apt.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9575
Joined: Sun Dec 16, 2007 1:17 pm

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#3 Post by dolphin_oracle » Wed Apr 11, 2018 7:24 pm

[Stevo wrote:Is the new spacefm coming from the antiX repository?

It would seem that allowing for both udev and eudev as alternative dependencies in the deb package would also work. Or we may have to build an MX version which will be seen as newer by apt.
yeah, we need to fix that deb. the depend needs to be either udev or eudev. BTW, udev should be provided by eudev.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2030
Joined: Wed Apr 11, 2018 5:09 pm

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#4 Post by fehlix » Wed Apr 11, 2018 7:34 pm

Stevo wrote:Is the new spacefm coming from the antiX repository?
Yes, exactly - this is from the antix-repository (antix.list). As MX uses udev and antiX eudev having bothe alternativ dependencies (libeudev1|libudev1) for spacefm would satisfy both linux environments.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
malspa
Forum Guide
Forum Guide
Posts: 1958
Joined: Thu Jul 13, 2006 7:21 am

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#5 Post by malspa » Wed Apr 11, 2018 9:20 pm

Wow, I thought the project was dead. I missed this announcement: http://ignorantguru.github.io/spacefm/news.html#1.0.6

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16568
Joined: Fri Dec 15, 2006 8:07 pm

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#6 Post by Stevo » Wed Apr 11, 2018 9:43 pm

It depends on whether the package creates the dependency automatically with the ${shlibs:Depends} variable if the maintainer could make it have the alternate Depends, though I guess it's worth a try to see if putting them in manually will work...I think doing that overrides the automatic one.

Does anyone know where the source for the antiX version is...oh, wait, it's in Sid. Is there any way we can talk antiX packagers into using an "-antix" suffix to their packages to allow for a possible smooth upgrade to ~mx versions and even a Buster-based MX, like the debian backports do?

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5737
Joined: Sat Jul 15, 2006 10:40 am

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#7 Post by anticapitalista » Thu Apr 12, 2018 8:56 am

Sorry about that - I will remove the latest version 1.0.6 from the antiX repository for now.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

skidoo
Forum Regular
Forum Regular
Posts: 890
Joined: Tue Sep 22, 2015 6:56 pm

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#8 Post by skidoo » Thu Apr 12, 2018 1:40 pm

yeah, we need to fix that deb. the depend needs to be either udev or eudev. BTW, udev should be provided by eudev.
Wait, amending "that deb" (spacefm package) would amount to treating the symptom, not the problem, yes?
AFAICT, the solution would be to amend both the libeudev1 and eudev packages, as follows:

Package: libeudev1
Provides: libudev1
Replaces: libudev1 (and do not state a version)

Package: eudev
Provides: udev
Replaces: udev (and do not state a version)

ref: https://debian-handbook.info/browse/sta ... ation.html

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16568
Joined: Fri Dec 15, 2006 8:07 pm

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#9 Post by Stevo » Thu Apr 12, 2018 2:01 pm

I'm building a MX package that will be seen as higher than the antiX one. If anti builds 1.0.6-1~antix for the antiX repo, that should not be seen as higher than our repo version, but will still be available to the antiX users.

The libeudev1 dependency was added automatically by shlibs, but I'm trying the alternate build-depends and depends method to see what comes out the other end...though just the alternate build-depends method should also work if the antiX eudev build stays in its own repo. I'm assuming that the package is libeudev-dev for antiX, since I don't know for sure.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2030
Joined: Wed Apr 11, 2018 5:09 pm

Re: spacefm 1.0.6 upgrade-error in MX-17.1

#10 Post by fehlix » Thu Apr 12, 2018 2:54 pm

Stevo wrote:I'm building a MX package that will be seen as higher than the antiX one. If anti builds 1.0.6-1~antix for the antiX repo, that should not be seen as higher than our repo version, but will still be available to the antiX users.
.
As I have now the deb version 1.0.6 (manually patched) installed I'm quite happy with it
as spacefm is extremly useful and powerfull. I do have spacefm on all my different linux instillations in addition to the default file manager.
Actually their is another issue within that deb-package (1.0.6) as within the postrm-file the remove-tag is missing which results in dpkg-error during remove: "postrm called with unknown argument'remove' " within in MX-17.1 and antiX-17.1!
Manualy patching this postrm by using the postrm from version 1.0.5 made dpkg happy again.
I've tested successively this patched install/remove on both MX-17.1 and antix-17.1. :bagoverhead:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Bugs and Non-Package Requests Forum”