Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Package installer improvement

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
User avatar
chrispop99
Forum Guide
Forum Guide
Posts: 2426
Joined: Tue Jan 27, 2009 3:07 pm

Package installer improvement

#1 Post by chrispop99 » Sun Feb 11, 2018 5:23 pm

Having read that a new version of VLC was in the testing repos, I tried to install it last night from the PI. To a novice it might seem like the process had completed, but I still had the old version. I realised that the repo I was using hadn't updated, so tried again this evening, with success.

What happens if the package is not yet available is that a terminal appears very briefly on the screen, then disappears. I'm guessing the terminal would contain a 'package not found' error message. Is there any way under those circumstances that the terminal could remain on screen until the user dismisses it, in order that the reason for the failure might be seen?

Chris
Test machines:
32-bit non-PAE - Thinkpad T41, 1.6GHz Pentium M, 1GB RAM.
32-bit PAE - DELL Latitude D610, 1.73GHz Pentium M, 2GB RAM.
64-bit - Lenovo T61, 2GHz Core 2 Duo, 2GB RAM
64-bit - Gigabyte Z77P-D3, Intel i3-3220, GeForce 8400 GS, 4GB PC3-12800.

User avatar
richb
Administrator
Posts: 17206
Joined: Wed Jul 12, 2006 2:17 pm

Re: Package installer improvement

#2 Post by richb » Sun Feb 11, 2018 6:04 pm

I had the same experience and the same thought of leaving the terminal open. You beat me too it.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
Paul..
Forum Guide
Forum Guide
Posts: 2277
Joined: Sun Mar 18, 2007 6:34 pm

Re: Package installer improvement

#3 Post by Paul.. » Sun Feb 11, 2018 6:07 pm

Perhaps steal some code from the MX Updater, then? That's how it behaves...

Daily: MSI 890FXA-GD70 | AMD Phenom II X6 1055T | GeForce GTX 750 Ti | 8G
Test: Thinkpad T431s | Intel i5-3437U | Intel 3rd gen Graphics | 4G

Post Reply

Return to “Bugs and Non-Package Requests Forum”