Welcome!

Please read this important information about Spectre and Meltdown vulnerabilities.
Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 Final release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

Bluetooth Adapter can not be activated

Report Bugs, Issues and non- pacakage Requests
Message
Author
mistr
Forum Novice
Forum  Novice
Posts: 3
Joined: Wed Jan 24, 2018 10:48 am

Bluetooth Adapter can not be activated

#1 Postby mistr » Wed Jan 31, 2018 2:06 pm

I own a Laptop with following Sytem::

xini -F:

CPU: Dual core Intel Core i7-7500U (-MT-MCP-) cache: 4096 KB
clock speeds: max: 3500 MHz 1: 2900 MHz 2: 2900 MHz 3: 2900 MHz 4: 2900 MHz
Graphics: Card-1: Intel Device 5916
Card-2: Advanced Micro Devices [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445]
Display Server: x11 (X.Org 1.19.2 )
drivers: modesetting,ati,amdgpu (unloaded: fbdev,vesa,radeon)
Resolution: 1920x1080@60.01hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2)
version: 4.5 Mesa 13.0.6
Audio: Card Intel Device 9d71 driver: snd_hda_intel Sound: ALSA v: k4.13.0-1-amd64
Network: Card-1: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller driver: r8169
IF: eth0 state: down mac: 3c:52:82:8d:45:4a
Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be
IF: wlan0 state: up mac: 3c:a0:67:c5:7f:e3
Drives: HDD Total Size: 2000.4GB (1.1% used)
ID-1: /dev/sda model: ST2000LM007 size: 2000.4GB
Partition: ID-1: / size: 150G used: 5.1G (4%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 253G used: 223M (1%) fs: ext4 dev: /dev/sda8
ID-3: swap-1 size: 16.78GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
Sensors: System Temperatures: cpu: 30.0C mobo: 29.8C gpu: 32.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 208 Uptime: 2:51 Memory: 788.3/7903.4MB
Client: Shell (quick-system-in) inxi: 2.3.54

When i try to aktivate the blootooth-adapter, i get the following message in dmesg:

Bluetooth: hci0 urb ffff8b10d2f2f780 failed to resubmit (113)

On startup the following messages appear in dmesg related to bluetooth:

Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_config.bin (-2)
bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
bluetooth hci0: firmware: direct-loading firmware rtl_bt/rtl8723b_fw.bin
Bluetooth: hci0: rom_version status=0 version=1
Bluetooth: cfg_sz 0, total size 22496
Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Bluetooth: BNEP filters: protocol multicast
Bluetooth: BNEP socket layer initialized
Bluetooth: hci0 urb ffff8b10e0a43b40 failed to resubmit (113)
rtl8723be: error H2C cmd because of Fw download fail!!!

Have i to download some firmware or how can bluetoot be aktivated?

Thank you
Michael

User avatar
mw1649
Forum Novice
Forum  Novice
Posts: 47
Joined: Fri Jan 02, 2015 3:17 am

Re: Bluetooth Adapter can not be activated

#2 Postby mw1649 » Thu Feb 01, 2018 4:42 am

I also cannot turn on Bluetooth.
$ inxi -F
System: Host: mx17 Kernel: 4.13.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17_x64 Horizon December 15, 2017
Machine: Device: laptop System: TOSHIBA product: Satellite Pro C850-F41K v: PSKC9F-00K00WF3 serial: N/A
Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 v: Type2 - Board Version serial: N/A
UEFI [Legacy]: Insyde v: 1.10 date: 02/29/2012
Battery BAT0: charge: 52.9 Wh 97.9% condition: 54.0/55.0 Wh (98%)
CPU: Dual core Intel Core i3-2350M (-MT-MCP-) cache: 3072 KB
clock speeds: max: 2300 MHz 1: 2294 MHz 2: 2294 MHz 3: 2294 MHz 4: 2294 MHz
Graphics: Card: Intel 2nd Generation Core Integrated Graphics Controller
Display Server: x11 (X.Org 1.19.2 ) drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile version: 3.3 Mesa 13.0.6
Audio: Card Intel 7 Series/C216 Family High Def. Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.13.0-1-amd64
Network: Card-1: Realtek RTL8723AE PCIe Wireless Network Adapter driver: rtl8723ae
IF: wlan0 state: up mac: 9c:b7:0d:f2:d6:2a
Card-2: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller driver: r8169
IF: eth0 state: up speed: 100 Mbps duplex: full mac: e8:40:f2:6e:ef:19
Drives: HDD Total Size: 1000.2GB (10.5% used)
ID-1: /dev/sda model: WDC_WD10JPCX size: 1000.2GB
Partition: ID-1: / size: 96G used: 8.0G (9%) fs: ext4 dev: /dev/sda3
ID-2: /home size: 583G used: 86G (16%) fs: ext4 dev: /dev/sda4
ID-3: swap-1 size: 4.40GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 52.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 198 Uptime: 13 min Memory: 1088.2/3844.3MB Client: Shell (bash) inxi: 2.3.54
$


dmesg output for my Bluetooth.

dmesg | grep Blue
[ 4.797536] usb 3-3: Product: RT Bluetooth Radio
[ 10.396590] toshiba_bluetooth: Toshiba ACPI Bluetooth device driver
[ 13.928826] Bluetooth: Core ver 2.22
[ 13.928850] Bluetooth: HCI device and connection manager initialized
[ 13.928855] Bluetooth: HCI socket layer initialized
[ 13.928858] Bluetooth: L2CAP socket layer initialized
[ 13.928871] Bluetooth: SCO socket layer initialized
[ 14.094205] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=1200
[ 14.094209] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723a_fw.bin
[ 24.541888] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 24.541889] Bluetooth: BNEP filters: protocol multicast
[ 24.541892] Bluetooth: BNEP socket layer initialized
[ 27.767111] Bluetooth: hci0 urb ffff893c040b3900 failed to resubmit (113)
[ 40.473112] Bluetooth: RFCOMM TTY layer initialized
[ 40.473123] Bluetooth: RFCOMM socket layer initialized
[ 40.473145] Bluetooth: RFCOMM ver 1.11
[ 62.774163] Bluetooth: hci0 urb ffff893be9351900 failed to resubmit (113)
[ 62.774176] Bluetooth: hci0 urb ffff893c09049300 failed to resubmit (113)
[ 253.745117] Bluetooth: hci0 urb ffff893c0576e480 failed to resubmit (113)
[ 253.745134] Bluetooth: hci0 urb ffff893c0576e600 failed to resubmit (113)
[ 405.740326] Bluetooth: hci0 urb ffff893c09049a80 failed to resubmit (113)
[ 405.740342] Bluetooth: hci0 urb ffff893c09049c00 failed to resubmit (113)


Will try my new bluetooth speaker on my daughters pc which has MX-16 or 15 on it when I get to visit her

MikeW
TOSHIBA Satellite Pro C850
Distro: MX-15_x64 Fusion 24 December 2015
Dual core Intel Core i3-2350M
Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Intel 7 Series/C210 Series Family High Definition Audio Controller

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 20647
Joined: Wed Jul 19, 2006 6:13 am

Re: Bluetooth Adapter can not be activated

#3 Postby Jerry3904 » Thu Feb 01, 2018 5:42 am

We found during the development of MX-17 that certain BT adapters would not work. I will take a look back at those threads to see the details, and return later today.
Production: 4.13.0-1-amd64, MX-17, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.13.0-1-386. MX-17, AMD C-60 APU, 4 GB

User avatar
lizard
Forum Novice
Forum  Novice
Posts: 4
Joined: Sat Jan 27, 2018 4:09 pm

Re: Bluetooth Adapter can not be activated

#4 Postby lizard » Thu Feb 01, 2018 6:29 am

I get to activate the bluetooth after manually sending the notebook to the standby mode, after lifting the lid the bluetooth starts, funny and wrong, but at least that's it!)))
inxi -F
System: Host: mx1 Kernel: 4.14.0-3-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17_x64 Horizon December 15, 2017
Machine: Device: laptop System: TOSHIBA product: Satellite C870-DNW v: PSCBCR-01C001RU serial: N/A
Mobo: Intel model: PLCSF8 v: Type2 - Board Version serial: N/A
UEFI: Insyde v: 6.80 date: 10/01/2013
Battery BAT0: charge: 28.9 Wh 100.2% condition: 28.9/48.4 Wh (60%)
CPU: Dual core Intel Pentium B980 (-MCP-) cache: 2048 KB
clock speeds: max: 2400 MHz 1: 2394 MHz 2: 2394 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Whistler LE [Radeon HD 6610M/7610M]
Display Server: x11 (X.Org 1.19.2 )
drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
Resolution: 1600x900@60.06hz
OpenGL: renderer: Gallium 0.4 on AMD TURKS (DRM 2.50.0 / 4.14.0-3-amd64, LLVM 3.9.1)
version: 3.3 Mesa 13.0.6
Audio: Card-1 Advanced Micro Devices [AMD/ATI] Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series]
driver: snd_hda_intel
Card-2 Intel 7 Series/C216 Family High Def. Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.14.0-3-amd64
Network: Card: Realtek RTL8723AE PCIe Wireless Network Adapter driver: rtl8723ae
IF: wlan0 state: up mac: 24:ec:99:c3:10:d1
Drives: HDD Total Size: 500.1GB (4.2% used)
ID-1: /dev/sda model: TOSHIBA_MK5075GS size: 500.1GB
Partition: ID-1: / size: 9.6G used: 5.8G (64%) fs: ext4 dev: /dev/sda7
ID-2: /home size: 213G used: 12G (6%) fs: ext4 dev: /dev/sda9
ID-3: swap-1 size: 2.64GB used: 0.00GB (0%) fs: swap dev: /dev/sda8
Sensors: System Temperatures: cpu: 49.0C mobo: N/A gpu: 45.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 188 Uptime: 2:55 Memory: 1396.0/3899.1MB Client: Shell (bash) inxi: 2.3.54

User avatar
lizard
Forum Novice
Forum  Novice
Posts: 4
Joined: Sat Jan 27, 2018 4:09 pm

Re: Bluetooth Adapter can not be activated

#5 Postby lizard » Thu Feb 01, 2018 6:33 am

that's what happens after exit the standby mode
dmesg | grep Blue
[ 8.468771] toshiba_bluetooth: Toshiba ACPI Bluetooth device driver
[ 8.783165] usb 2-1.3: Product: RT Bluetooth Radio
[ 12.906649] Bluetooth: Core ver 2.22
[ 12.906666] Bluetooth: HCI device and connection manager initialized
[ 12.906669] Bluetooth: HCI socket layer initialized
[ 12.906671] Bluetooth: L2CAP socket layer initialized
[ 12.906676] Bluetooth: SCO socket layer initialized
[ 13.203582] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=1200
[ 13.203586] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723a_fw.bin
[ 23.937704] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 23.937705] Bluetooth: BNEP filters: protocol multicast
[ 23.937709] Bluetooth: BNEP socket layer initialized
[ 26.731345] Bluetooth: hci0 urb ffff9f25c8a40540 failed to resubmit (113)
[ 26.733095] Bluetooth: hci0 urb ffff9f25c8a40000 failed to resubmit (113)
[ 67.428644] Bluetooth: RFCOMM TTY layer initialized
[ 67.428650] Bluetooth: RFCOMM socket layer initialized
[ 67.428654] Bluetooth: RFCOMM ver 1.11
[ 76.713934] Bluetooth: hci0 urb ffff9f25b1a25c00 failed to resubmit (113)
[ 76.714305] Bluetooth: hci0 urb ffff9f259ff11840 failed to resubmit (113)
[ 93.737537] Bluetooth: hci0 urb ffff9f2599197000 failed to resubmit (113)
[ 93.737883] Bluetooth: hci0 urb ffff9f2599197d80 failed to resubmit (113)
[ 2480.218487] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=1200
[ 2480.218491] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723a_fw.bin
[ 2778.138953] Bluetooth: hci0 ACL packet for unknown connection handle 1
[ 2778.138965] Bluetooth: hci0 ACL packet for unknown connection handle 1
[ 4111.973523] usb 2-1.3: Product: RT Bluetooth Radio
[ 4112.587530] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=1200
[ 4112.587535] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723a_fw.bin

mistr
Forum Novice
Forum  Novice
Posts: 3
Joined: Wed Jan 24, 2018 10:48 am

Re: Bluetooth Adapter can not be activated

#6 Postby mistr » Mon Feb 05, 2018 6:09 am

I tried the trick with the standby-mod too. The bluetoothadapter could now be activated, but it could not find any devices. After aktivating bluetooth, the following appears in dmesg:

[ 845.814120] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[ 845.814196] acpi LNXPOWER:01: Turning OFF
[ 845.814271] PM: Finishing wakeup.
[ 845.814272] OOM killer enabled.
[ 845.814273] Restarting tasks ...
[ 845.815560] Bluetooth: hci0: rom_version status=0 version=1
[ 845.815569] Bluetooth: cfg_sz 0, total size 22496
[ 845.828936] done.
[ 845.830413] [drm] RC6 on
[ 845.954925] rtl8723be: error H2C cmd because of Fw download fail!!!
[ 845.954950] ------------[ cut here ]------------
[ 845.954958] WARNING: CPU: 0 PID: 4659 at /build/linux-4.13.13/drivers/net/wireless/realtek/rtlwifi/rtl8723be/fw.c:227 rtl8723be_fill_h2c_cmd+0x3ed/0x400 [rtl8723be]
[ 845.954959] Modules linked in: fuse rfcomm ctr ccm cpufreq_conservative cpufreq_powersave cpufreq_userspace bnep uinput nfsd auth_rpcgss nfs_acl nfs lockd grace fscache sunrpc ecryptfs nls_ascii loop nls_cp437 parport_pc vfat fat ppdev lp parport dm_crypt dm_mod uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core videodev btusb btrtl media intel_rapl x86_pkg_temp_thermal intel_powerclamp snd_hda_codec_hdmi snd_hda_codec_realtek wl(PO) coretemp snd_hda_codec_generic wmi_bmof kvm hp_wmi snd_soc_skl snd_soc_skl_ipc snd_soc_sst_ipc snd_soc_sst_dsp irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_ext_core snd_soc_sst_match arc4 amdkfd hci_uart btbcm btqca intel_cstate btintel rtl8723be btcoexist rtl8723_common rtl_pci intel_uncore intel_rapl_perf amdgpu evdev joydev
[ 845.954997] bluetooth serio_raw efi_pstore rtlwifi drbg ansi_cprng snd_soc_core snd_compress snd_hda_intel efivars ecdh_generic ttm snd_hda_codec mac80211 iTCO_wdt wmi ucsi_acpi i915 typec_ucsi drm_kms_helper snd_hda_core intel_lpss_acpi cfg80211 rfkill snd_hwdep snd_pcm snd_timer iTCO_vendor_support typec sg ac shpchp intel_lpss intel_vbtn acpi_pad mfd_core drm i2c_algo_bit battery int3403_thermal soc_button_array intel_hid sparse_keymap processor_thermal_device int3406_thermal video button hp_wireless kxcjk_1013 industrialio_triggered_buffer kfifo_buf industrialio snd int340x_thermal_zone intel_soc_dts_iosf int3400_thermal intel_pch_thermal acpi_thermal_rel dptf_power mei_me tpm_crb mei soundcore ext4 crc16 mbcache jbd2 fscrypto ecb btrfs crc32c_generic xor raid6_pq sr_mod cdrom sd_mod hid_logitech_hidpp
[ 845.955039] hid_logitech_dj usbhid crc32c_intel aesni_intel aes_x86_64 crypto_simd cryptd glue_helper psmouse i2c_i801 ahci libahci xhci_pci xhci_hcd libata r8169 mii usbcore scsi_mod usb_common thermal fan i2c_hid hid zsmalloc
[ 845.955055] CPU: 0 PID: 4659 Comm: kworker/0:4 Tainted: P W O 4.13.0-1-amd64 #1 Debian 4.13.13-1mx17
[ 845.955056] Hardware name: HP HP Notebook/81EE, BIOS F.24 01/20/2017
[ 845.955061] Workqueue: rtl8723be_pci rtl_c2hcmd_wq_callback [rtlwifi]
[ 845.955063] task: ffff929cae1b0040 task.stack: ffffa2c6845b4000
[ 845.955066] RIP: 0010:rtl8723be_fill_h2c_cmd+0x3ed/0x400 [rtl8723be]
[ 845.955067] RSP: 0018:ffffa2c6845b7d60 EFLAGS: 00010286
[ 845.955069] RAX: 0000000000000037 RBX: ffff929ce1f21540 RCX: 0000000000000000
[ 845.955070] RDX: 0000000000000000 RSI: ffff929ceec0de98 RDI: ffff929ceec0de98
[ 845.955071] RBP: 0000000000000000 R08: 0000000000000001 R09: 00000000000004c6
[ 845.955071] R10: ffffa2c6845b7db8 R11: 00000000000004c6 R12: 0000000000000000
[ 845.955072] R13: 0000000000000000 R14: dead000000000200 R15: dead000000000100
[ 845.955074] FS: 0000000000000000(0000) GS:ffff929ceec00000(0000) knlGS:0000000000000000
[ 845.955075] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 845.955076] CR2: 00005606ddcd9d60 CR3: 0000000043809000 CR4: 00000000003406f0
[ 845.955077] Call Trace:
[ 845.955085] ? halbtc_set_bt_reg+0xd1/0xe0 [btcoexist]
[ 845.955089] ? ex_btc8723b1ant_bt_info_notify+0x66a/0x6b0 [btcoexist]
[ 845.955093] ? rtl_c2hcmd_launcher+0xc4/0x120 [rtlwifi]
[ 845.955096] ? process_one_work+0x181/0x370
[ 845.955098] ? worker_thread+0x4d/0x3c0
[ 845.955101] ? kthread+0xfc/0x130
[ 845.955102] ? process_one_work+0x370/0x370
[ 845.955104] ? kthread_create_on_node+0x70/0x70
[ 845.955107] ? ret_from_fork+0x25/0x30
[ 845.955109] Code: e8 d4 00 aa f0 31 c9 31 f6 66 89 4c 24 16 66 89 74 24 14 e9 6b fd ff ff 48 c7 c7 18 e1 e3 c0 c6 05 90 0e 01 00 01 e8 ae 00 aa f0 <0f> ff e9 52 fc ff ff e8 77 41 a4 f0 0f 1f 80 00 00 00 00 0f 1f
[ 845.955139] ---[ end trace 614409033f4aa861 ]---

User avatar
mw1649
Forum Novice
Forum  Novice
Posts: 47
Joined: Fri Jan 02, 2015 3:17 am

Re: Bluetooth Adapter can not be activated

#7 Postby mw1649 » Sat Feb 10, 2018 7:55 am

Doing the "Suspend" thing my Bluetooth App is now active and shows that Bluetooth is turned on. Front pane led is also lit.
However cannot see any devices and vice versa - the laptop is not seen by other bluetooth device!

dmesg output:
mike@mx17:~
$ dmesg |grep Blue
[ 4.788423] usb 3-3: Product: RT Bluetooth Radio
[ 17.770767] toshiba_bluetooth: Toshiba ACPI Bluetooth device driver
[ 21.513341] Bluetooth: Core ver 2.22
[ 21.513356] Bluetooth: HCI device and connection manager initialized
[ 21.513359] Bluetooth: HCI socket layer initialized
[ 21.513360] Bluetooth: L2CAP socket layer initialized
[ 21.513365] Bluetooth: SCO socket layer initialized
[ 21.683165] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=1200
[ 21.683169] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723a_fw.bin
[ 41.247968] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 41.247972] Bluetooth: BNEP filters: protocol multicast
[ 41.247980] Bluetooth: BNEP socket layer initialized
[ 43.767116] Bluetooth: hci0 urb ffff9117c8656840 failed to resubmit (113)
[ 43.770621] Bluetooth: hci0 urb ffff9117c76ff6c0 failed to resubmit (113)
[ 58.252432] Bluetooth: RFCOMM TTY layer initialized
[ 58.252441] Bluetooth: RFCOMM socket layer initialized
[ 58.252448] Bluetooth: RFCOMM ver 1.11
[ 82.742012] Bluetooth: hci0 urb ffff9117c0c3a6c0 failed to resubmit (113)
[27717.981521] Bluetooth: hci0 urb ffff9116e6f0e3c0 failed to resubmit (113)
[27717.981536] Bluetooth: hci0 urb ffff9117c1be3480 failed to resubmit (113)
[27744.924860] Bluetooth: hci0 urb ffff9117c03b2d80 failed to resubmit (113)
[27752.980469] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=1200
[27752.980472] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723a_fw.bin
[27880.258640] Bluetooth: hci0 command 0x2005 tx timeout
[27882.306581] Bluetooth: hci0 command 0x200b tx timeout
[27884.354496] Bluetooth: hci0 command 0x200c tx timeout
[27927.297339] Bluetooth: hci0 command 0x2005 tx timeout
[27929.345291] Bluetooth: hci0 command 0x200b tx timeout
[27931.393198] Bluetooth: hci0 command 0x200c tx timeout
[27949.184693] Bluetooth: hci0 command 0x0c1a tx timeout
[27951.232668] Bluetooth: hci0 command 0x0c3a tx timeout
[27953.280579] Bluetooth: hci0 command 0x0c1a tx timeout
[27955.328554] Bluetooth: hci0 command 0x0c1a tx timeout
[27957.376482] Bluetooth: hci0 command 0x0c1a tx timeout
[27959.432037] Bluetooth: hci0 command 0x0c1a tx timeout
[27979.711828] Bluetooth: hci0 command 0x0c1a tx timeout
[27981.759807] Bluetooth: hci0 command 0x0c3a tx timeout
[27983.807717] Bluetooth: hci0 command 0x0c1a tx timeout
[28005.247149] Bluetooth: hci0 command 0x2005 tx timeout
[28007.295082] Bluetooth: hci0 command 0x200b tx timeout
[28009.342982] Bluetooth: hci0 command 0x200c tx timeout
[28044.222002] Bluetooth: hci0 command 0x2005 tx timeout
[28046.269979] Bluetooth: hci0 command 0x200b tx timeout
[28048.317850] Bluetooth: hci0 command 0x200c tx timeout
mike@mx17:~
$
TOSHIBA Satellite Pro C850
Distro: MX-15_x64 Fusion 24 December 2015
Dual core Intel Core i3-2350M
Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Intel 7 Series/C210 Series Family High Definition Audio Controller

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 20647
Joined: Wed Jul 19, 2006 6:13 am

Re: Bluetooth Adapter can not be activated

#8 Postby Jerry3904 » Wed Feb 14, 2018 11:18 am

Adding this post here as potentially part of the same problem:

viewtopic.php?f=12&t=44107

I have not yet dug into this, but it is on my list...
Production: 4.13.0-1-amd64, MX-17, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.13.0-1-386. MX-17, AMD C-60 APU, 4 GB

User avatar
Gerson
Forum Novice
Forum  Novice
Posts: 59
Age: 63
Joined: Sun Nov 12, 2017 10:58 am

Re: Bluetooth Adapter can not be activated

#9 Postby Gerson » Wed Feb 14, 2018 4:54 pm

The computer is an HP Pavilion X360 2 in 1 (year 2014) came with W8.1 then I placed W10 x64 all the hardware works in this operating system.
Now I only use MX17 and it does not recognize the bluetooh, in other distributions Mint-KDE, OpenSUSE and Deepin with some settings it worked but it does not work with MX17
When executing the command I get this:

$ dmesg | grep Blue
[ 22.830706] Bluetooth: Core ver 2.22
[ 22.830738] Bluetooth: HCI device and connection manager initialized
[ 22.830744] Bluetooth: HCI socket layer initialized
[ 22.830747] Bluetooth: L2CAP socket layer initialized
[ 22.830756] Bluetooth: SCO socket layer initialized
[ 23.636854] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 23.636860] Bluetooth: BNEP filters: protocol multicast
[ 23.636873] Bluetooth: BNEP socket layer initialized

What can be done?
No todos ignoramos las mismas cosas. :confused:

User avatar
Gerson
Forum Novice
Forum  Novice
Posts: 59
Age: 63
Joined: Sun Nov 12, 2017 10:58 am

Re: Bluetooth Adapter can not be activated

#10 Postby Gerson » Fri Feb 16, 2018 8:59 am

Yesterday I installed MX17 (January 2018) on a Compaq Presario Verk 21 laptop (2016) and I immediately recognized the bluetooth adapter and was able to pair it with headphones and the two cell phones without any problem.
On my other laptop an HP Pavilion I have not succeeded, and consulting seems that HP put problem with bluetooth on GNU / Linux

$ sudo rfkill list
[sudo] password for ghermain:
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

This is the result with the command:

$ dmesg | grep Blue
[ 6.999425] Bluetooth: Core ver 2.22
[ 6.999464] Bluetooth: HCI device and connection manager initialized
[ 6.999472] Bluetooth: HCI socket layer initialized
[ 6.999478] Bluetooth: L2CAP socket layer initialized
[ 6.999490] Bluetooth: SCO socket layer initialized
[ 7.125431] Bluetooth: HCI UART driver ver 2.3
[ 7.125433] Bluetooth: HCI UART protocol H4 registered
[ 7.125435] Bluetooth: HCI UART protocol BCSP registered
[ 7.125436] Bluetooth: HCI UART protocol ATH3K registered
[ 7.125437] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 7.125479] Bluetooth: HCI UART protocol Intel registered
[ 7.125480] Bluetooth: HCI UART protocol QCA registered
[ 7.125481] Bluetooth: HCI UART protocol AG6XX registered
[ 7.125482] Bluetooth: HCI UART protocol Marvell registered
[ 9.641994] Bluetooth: hci0: read Intel version: 3707100100012d0d00
[ 9.748410] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.0.1.2d.d.bseq
[ 9.936004] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated
[ 19.176880] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 19.176884] Bluetooth: BNEP filters: protocol multicast
[ 19.176894] Bluetooth: BNEP socket layer initialized
[ 97.541390] Bluetooth: RFCOMM TTY layer initialized
[ 97.541412] Bluetooth: RFCOMM socket layer initialized
[ 97.541430] Bluetooth: RFCOMM ver 1.11
You do not have the required permissions to view the files attached to this post.
No todos ignoramos las mismas cosas. :confused:


Return to “Bugs and Non-Package Requests Forum”

Who is online

Users browsing this forum: No registered users and 2 guests