Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX17: Possible bug - loss of archive functionality and a workaround

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
User avatar
ghostwalker
Forum Novice
Forum  Novice
Posts: 1
Joined: Tue Jan 09, 2018 6:06 pm

MX17: Possible bug - loss of archive functionality and a workaround

#1 Post by ghostwalker » Tue Jan 09, 2018 10:25 pm

Hello Everyone
After struggling for more years with various flavors of virtualized *nix* than i care to say, i was so elated with MX-16 i physically dual booted it with Win 7 on my ASUSPRO laptop. Upgraded it to MX-17 and have noticed a loss of archive functionality possibly by design. Have been collecting important Firefox add-ons since the v57 exodus to WebExtensions. A lot of us have been porting and working them for other gecko browsers and for me especially Pale Moon. (Thanks for the Pale Moon folks!) The add-ons are in .xpi format which is interchangeable with .zip files. Breaking them down and building them back up has been daily work for a lot of us in which MX-16's Archive Manager v3.14.1 had no problem decompressing them as the .zip files that they are. MX-17's Archive Manager v3.22.3 will not do it any longer. Tried it on an MX-17 virtual vmware machine on the PowerSpec as well as MX-17 installed in the ASUSPRO laptop. Did not want to give up on the MX-17 and even tried an unsuccessful downgrade to v3.14.1. Here is my workaround for anyone who might be into this process. The gui of peazip for linux is incredible and has a quick little sub-gui that will allow you to just drag and drop an .xpi file into it's small window and check the radio box to unzip it into it's own folder - done. You can make a launcher of just it and add a new empty item then give it the command:
/usr/local/share/PeaZip/res/pealauncher %F
The peazip_6.5.0.LINUX.GTK2-2_i386.deb file at the top right of the page plays nice with Xfce.
http://www.peazip.org/peazip-linux.html
Happy New Year - Hope this helps
PowerSpec B718 i5-3570K - 32GB Ram - 3.40GHz - Intel HD 4000
ASUSPRO P2710J i5-4210M - 8GB Ram - 2.60GHz - Intel HD 4600

Post Reply

Return to “Bugs and Non-Package Requests Forum”