Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Newer version of HPLIP?

Report Bugs, Issues and non- package Requests
Post Reply
User avatar
Paul..
Global Moderator
Posts: 2674
Joined: Sun Mar 18, 2007 6:34 pm

Newer version of HPLIP?

#1

Post by Paul.. » Wed Dec 16, 2015 2:54 pm

[Moved post from MX-15 beta2 feedback]
I just bought a new fax, scanner, printer combo job (HP Laser Jet Pro MFP M127fn) and it refuses to work on MX-15b2...

...BUT it turns out to be a bug in HPLIP 3.15.7-1mx150+1. Yay!! :p

Here is my filter error...consistent with the known bug:
From /var/log/cups/error_log: "PID 4964 (/usr/lib/cups/filter/hpcups) crashed on signal 6."

Here is the the bug report and the code that fixes it from the HPLIP site. https://bugs.launchpad.net/hplip/+bug/1476920.

Apparently the bug fix is already in the next version (3.15.9). Any chance we can get this fix put into our 3.15.7? Or can we move to HPLIP 3.15.9 or 3.15.11?

Asus Prime X470-Pro | AMD Ryzen 5 1400 (8 threads)
16 Gig DDR4 3000 | nVidia - GeForce GTX 750 Ti
Samsung 970 NVMe SSD | 860 500GB SSD

User avatar
Stevo
Developer
Posts: 20096
Joined: Fri Dec 15, 2006 8:07 pm

Re: Newer version of HPLIP?

#2

Post by Stevo » Wed Dec 16, 2015 4:16 pm

3.15.11 should be portable over from Ubuntu, I'm on it.

User avatar
Paul..
Global Moderator
Posts: 2674
Joined: Sun Mar 18, 2007 6:34 pm

Re: Newer version of HPLIP?

#3

Post by Paul.. » Mon Dec 21, 2015 7:07 pm

Stevo wrote:3.15.11 should be portable over from Ubuntu, I'm on it.
Any update on this?

Asus Prime X470-Pro | AMD Ryzen 5 1400 (8 threads)
16 Gig DDR4 3000 | nVidia - GeForce GTX 750 Ti
Samsung 970 NVMe SSD | 860 500GB SSD

User avatar
mmikeinsantarosa
Developer
Posts: 2989
Joined: Thu May 01, 2014 10:12 am

Re: Newer version of HPLIP?

#4

Post by mmikeinsantarosa » Mon Dec 21, 2015 10:31 pm

pcallahan80 wrote:
Stevo wrote:3.15.11 should be portable over from Ubuntu, I'm on it.
Any update on this?
Looks like steveo & tim got 3.15.11 into the MX-15 test repo http://main.mepis-deb.org/mx/testrepo/p ... t/h/hplip/ - mike
LT: MX18.2 Quad Core model: Intel Core i7-6820HQ Kernel: 5.0.0-7.1-liquorix-amd64 x86_64

User avatar
Paul..
Global Moderator
Posts: 2674
Joined: Sun Mar 18, 2007 6:34 pm

Re: Newer version of HPLIP?

#5

Post by Paul.. » Mon Dec 21, 2015 10:47 pm

mmikeinsantarosa wrote:
pcallahan80 wrote:
Stevo wrote:3.15.11 should be portable over from Ubuntu, I'm on it.
Any update on this?
Looks like steveo & tim got 3.15.11 into the MX-15 test repo http://main.mepis-deb.org/mx/testrepo/p ... t/h/hplip/ - mike
Woohooo!! Many thanks, Stevo, Tim, & Mike...works like a champ!!

Asus Prime X470-Pro | AMD Ryzen 5 1400 (8 threads)
16 Gig DDR4 3000 | nVidia - GeForce GTX 750 Ti
Samsung 970 NVMe SSD | 860 500GB SSD

Post Reply

Return to “Bugs and Non-Package Requests Forum”