Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX-15 (64bit) - gfxboot.c32 : Not a COM32R image

Report Bugs, Issues and non- package Requests
Post Reply
User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 630
Joined: Sun May 03, 2009 2:34 pm

MX-15 (64bit) - gfxboot.c32 : Not a COM32R image

#1

Post by TenderFoot » Fri Nov 20, 2015 1:49 pm

MX-14 went "walkabout" on my Tosh so thought I'd use the opportunity to take MX-15-b1_x64-mx for a spin.

Downloaded, MD5 checked and burned using Unebootin. At the end of the process a message about gfxboot.c32 existing and would I like to replace it or not. Either way, the same message arises (as in title). Tried on a handy notebook with same result.

A little googling (for COM32R) took me to a ubuntu forum where the advice was to press tab at the boot: prompt and then type live (or one of the other options). Success - live session booted!

If this is not a feature is it a bug (perhaps confined to 64bit version) and, if so is it "genuine" or "upstream" as it's not listed in tracker - or is a more likely explanation that it's me ?!

[PS on the notebook, which has broadcom wifi, (ok in MX-14) my n/w is seen but attempts to connect result in a pop-up "Failed to add/activate connection". Also the Shutdown process is glitched. But these will be separate posts if the above is resolved.]

User avatar
anticapitalista
Developer
Posts: 6302
Joined: Sat Jul 15, 2006 10:40 am

Re: MX-15 (64bit) - gfxboot.c32 : Not a COM32R image

#2

Post by anticapitalista » Fri Nov 20, 2015 2:20 pm

anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 630
Joined: Sun May 03, 2009 2:34 pm

Re: MX-15 (64bit) - gfxboot.c32 : Not a COM32R image

#3

Post by TenderFoot » Fri Nov 20, 2015 2:43 pm

Thanks. I actually used Unebootin from Win. Since MX-14 was fine is it due to changes in MX-15 and/or it being 64bit version?

Since it can actually be booted would it be safe to install or would the anomaly carry through - unless that also caused the wifi issue? If so it would be no big deal to reburn using Rufus.

User avatar
dolphin_oracle
Developer
Posts: 12567
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX-15 (64bit) - gfxboot.c32 : Not a COM32R image

#4

Post by dolphin_oracle » Fri Nov 20, 2015 2:58 pm

TenderFoot wrote:Thanks. I actually used Unebootin from Win. Since MX-14 was fine is it due to changes in MX-15 and/or it being 64bit version?

Since it can actually be booted would it be safe to install or would the anomaly carry through - unless that also caused the wifi issue? If so it would be no big deal to reburn using Rufus.

its the syslinux upgrade. the version 6 in jessie/mx-15 is not compatible with the version packaged with the windows unetbootin. rufus can detect the difference and makes an accommodation to make things work.

I can't say about your other issues (wifi and shutdown). I suggest a separate thread and the inxi -F to start with. We did have a report of one particular broadcom chip that didn't like the kernel on the 64bit. moving down to the failback kernel (see mx-packageinstaller kernel area) solved his issue.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 630
Joined: Sun May 03, 2009 2:34 pm

Re: MX-15 (64bit) - gfxboot.c32 : Not a COM32R image

#5

Post by TenderFoot » Fri Nov 20, 2015 3:12 pm

Yes I (now) understand, from my earlier search, the syslinux conflict - though strangely Rufus now warns that v 6.0.3 is required but it only has v 6.0.3!

Anyway, I'll proceed with the rest step by step by step.

User avatar
dolphin_oracle
Developer
Posts: 12567
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX-15 (64bit) - gfxboot.c32 : Not a COM32R image

#6

Post by dolphin_oracle » Fri Nov 20, 2015 3:14 pm

TenderFoot wrote:Yes I (now) understand, from my earlier search, the syslinux conflict - though strangely Rufus now warns that v 6.0.3 is required but it only has v 6.0.3!

Anyway, I'll proceed with the rest step by step by step.
it's message is a little weird but it downloads the piece it's missing.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
anticapitalista
Developer
Posts: 6302
Joined: Sat Jul 15, 2006 10:40 am

Re: MX-15 (64bit) - gfxboot.c32 : Not a COM32R image

#7

Post by anticapitalista » Fri Nov 20, 2015 3:22 pm

Just to add that if you have no intention of running live with persistence, then what you already have with the live boot will install just fine.
If you want to run live with all our live features (F menu etc), then you will need to use rufus from windows.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 630
Joined: Sun May 03, 2009 2:34 pm

Re: MX-15 (64bit) - gfxboot.c32 : Not a COM32R image

#8

Post by TenderFoot » Fri Nov 20, 2015 3:35 pm

The Rufus version boots fine and the other issues have disappeared too!

Post Reply

Return to “Bugs and Non-Package Requests Forum”