Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

How to get Devede installed on mx15b1-64 (now 15rc1-64)?

Report Bugs, Issues and non- package Requests
User avatar
Eadwine Rose
Administrator
Posts: 9389
Joined: Wed Jul 12, 2006 2:10 am

Re: How to get Devede installed on mx15b1-64?

#31

Post by Eadwine Rose » Wed Dec 16, 2015 2:45 pm

In 15b2 right now, installed devede from the standard repos, I also installed mencoder, libav-tools and ffmpeg from those standard repos.

It removed mplayer and added libquvi-scripts, libquvi7 and mplayer2.

Devede starts, however when I go into the settings I can't select ffmpeg, it is simply not there. It stays stuck on avconv which I don't want because that errors in making a dvd.


How do I get that ffmpeg option to become available? I have even rebooted, no dice. Does anyone know? I DO have dvd styler available, but still, it would be nice to get this one back to working as well :smile:
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
Stevo
Developer
Posts: 20151
Joined: Fri Dec 15, 2006 8:07 pm

Re: How to get Devede installed on mx15b1-64?

#32

Post by Stevo » Wed Dec 16, 2015 8:01 pm

Yes, I confirmed this by just installing ffmpeg and devede in a live session, and avconv is the only option showing.

It doesn't see mencoder as an option after installing, either.

User avatar
Stevo
Developer
Posts: 20151
Joined: Fri Dec 15, 2006 8:07 pm

Re: How to get Devede installed on mx15b1-64?

#33

Post by Stevo » Wed Dec 16, 2015 8:15 pm

Here's a clunky workaround.

Close devede.

Edit .devede in your home folder to use ffmpeg as the encoder rather than avconv.

Code: Select all

encoder_video:ffmpeg

encoder_menu:ffmpeg
Now when starting devede in the terminal, I can see that it's using that setting:

Code: Select all

linea:  encoder_video:ffmpeg

linea:  encoder_menu:ffmpeg
Edit: tested it, and it's still using avconv, maybe we can add ffmpeg as an alternative dependency.
Last edited by Stevo on Wed Dec 16, 2015 8:32 pm, edited 2 times in total.

User avatar
timkb4cq
Developer
Posts: 5145
Joined: Wed Jul 12, 2006 4:05 pm

Re: How to get Devede installed on mx15b1-64?

#34

Post by timkb4cq » Wed Dec 16, 2015 8:15 pm

This may be related.

I tried to install mplayer in a liveUSB session today, and mplayer appeared to be installed successfully - but it wouldn't work.

The issue seems to be that libavcodec-ffmpeg56 won't install because is relies on libx265-59 which is still in the testing repo. libavcodec-ffmpeg-extra56 satisfies the dependency & will install - but it contains no library files! That looks like an unnoticed build problem.

I think I recall a discussion earlier about why libx265-59 couldn't move to main, but I can't remember why it was...
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Stevo
Developer
Posts: 20151
Joined: Fri Dec 15, 2006 8:07 pm

Re: How to get Devede installed on mx15b1-64?

#35

Post by Stevo » Wed Dec 16, 2015 9:09 pm

I got it working correctly in a live session by installing the ffmpeg 2.8.3 and libavcodec-ffmpeg-extra56 packages from Jessie backports, along with the Devede 4.3 backport I linked to on the second page of the thread. I'll just port over the jessie-backports ffmpeg 2.8.3--backports also has libx265-59.

Can we just keep the two libx265-43 debs in MX main and add the x265-1.7 packages in main, so we don't break anything that depends on those?

It appears our VLC and handbrake are the only things that depend on the -43 version, so we could also try rebuilding those against the newer version if we can't keep the -43.

User avatar
Stevo
Developer
Posts: 20151
Joined: Fri Dec 15, 2006 8:07 pm

Re: How to get Devede installed on mx15b1-64?

#36

Post by Stevo » Sat Dec 19, 2015 2:24 pm

On the RC 1, enabling the test repo and upgrading to the new ffmpeg 2.8.3 libraries adds ffmpeg to the drop-down list.

I'm rebuilding vlc and handbrake against the newer libx265 so we can move it, them, and the new ffmpeg to the main repo.

User avatar
Eadwine Rose
Administrator
Posts: 9389
Joined: Wed Jul 12, 2006 2:10 am

Re: How to get Devede installed on mx15b1-64?

#37

Post by Eadwine Rose » Sat Dec 19, 2015 2:31 pm

Hrmm.. I just did that.. enabled the testrepo and upgraded ffmpeg which took along libav-tools

Started devede, which gave me nothing. Then started through the terminal and it says this:

Code: Select all

$ devede
DeVeDe 3.23.0 beta1
Locale: en_US.UTF-8
Using package-installed files
/home/eadwine/
Cores: 4 Virtual cores: 4
Entro en fonts
Salgo de fonts
/home/eadwine/
Temp Directory is:  /var/tmp
home load:  /home/eadwine/.devede
linea:  video_format:pal

linea:  temp_folder:/var/tmp/

linea:  multicore:1

linea:  hyperthreading:1

linea:  sub_language:EN (ENGLISH)

linea:  sub_codepage:ISO-8859-1

linea:  AC3_fix:0

linea:  AC3_fix_ffmpeg:0

linea:  AC3_fix_avconv:0

linea:  erase_tmp_files:1

linea:  encoder_video:avconv

linea:  encoder_menu:avconv

linea:  
Traceback (most recent call last):
  File "/usr/bin/devede", line 404, in <module>
    global_vars["encoder_video"]=global_vars["encoders"][l-1]
IndexError: list index out of range
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
Stevo
Developer
Posts: 20151
Joined: Fri Dec 15, 2006 8:07 pm

Re: How to get Devede installed on mx15b1-64 (now 15rc1-64)?

#38

Post by Stevo » Sat Dec 19, 2015 8:51 pm

What about if you rename the hidden config file ".devede" in your home directory?

User avatar
Eadwine Rose
Administrator
Posts: 9389
Joined: Wed Jul 12, 2006 2:10 am

Re: How to get Devede installed on mx15b1-64 (now 15rc1-64)?

#39

Post by Eadwine Rose » Sun Dec 20, 2015 3:08 am

Renamed, and started:

Code: Select all

$ devede
DeVeDe 3.23.0 beta1
Locale: en_US.UTF-8
Using package-installed files
/home/eadwine/
Cores: 4 Virtual cores: 4
Entro en fonts
Salgo de fonts
/home/eadwine/
Temp Directory is:  /var/tmp
home load:  /home/eadwine/.devede
Traceback (most recent call last):
  File "/usr/bin/devede", line 404, in <module>
    global_vars["encoder_video"]=global_vars["encoders"][l-1]
IndexError: list index out of range
It says home load /home/eadwine/.devede but there IS no .devede in the /home/eadwine/ folder anymore.


I downgraded them both again, renamed that .devede file, started devede and it appears as a new file once I close devede again.
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
Stevo
Developer
Posts: 20151
Joined: Fri Dec 15, 2006 8:07 pm

Re: How to get Devede installed on mx15b1-64 (now 15rc1-64)?

#40

Post by Stevo » Sun Dec 20, 2015 6:33 pm

I tried to reproduce the problem on a new 64 bit Live session:

enable the MX test repo and reload

install ffmpeg
install mplayer2
install devede

Devede starts, shows only ffmpeg for the video converter and avconv for the menu converter. I made an ISO from a short video to confirm that it worked.

Post Reply

Return to “Bugs and Non-Package Requests Forum”