Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Nvidia drivers won't install

Report Bugs, Issues and non- package Requests
Post Reply
lend27
Forum Novice
Forum  Novice
Posts: 65
Joined: Wed Apr 29, 2015 4:02 pm

Nvidia drivers won't install

#1

Post by lend27 » Mon Nov 09, 2015 9:41 am

When I install them through the command line and finsih up with "nvidia-xconfig" it tells me it can't find my xconfig file. The driver installs but no X on reboot.
How do I properly install my Nvidia drivers? I have Geforce GTX-760.

Thanks....love the distro!


Len

User avatar
Jerry3904
Administrator
Posts: 25737
Joined: Wed Jul 19, 2006 6:13 am

Re: Nvidia drivers won't install

#2

Post by Jerry3904 » Mon Nov 09, 2015 10:14 am

Most of us use sgfxi, following the on-screen prompts. Basic directions from the Users Manual:


From your desktop:
Press Ctrl-Alt-F1 to get to a terminal prompt.
Log in as root (su and password)
Type: sgfxi

At boot:
Type e when on the GRUB menu to be able to edit it
Add “3” to the end of the kernel line in GRUB’s menu entry for MX Linux
The system will boot directly to the console.
Log in as root (su and password)
Type: sgfxi
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

lend27
Forum Novice
Forum  Novice
Posts: 65
Joined: Wed Apr 29, 2015 4:02 pm

Re: Nvidia drivers won't install

#3

Post by lend27 » Mon Nov 09, 2015 10:38 am

I will try that! Thank you!

Len

User avatar
Eadwine Rose
Administrator
Posts: 9326
Joined: Wed Jul 12, 2006 2:10 am

Re: Nvidia drivers won't install

#4

Post by Eadwine Rose » Mon Nov 09, 2015 11:14 am

I just did this, all is well now though it took longer and was slightly different than on 14.4. The one thing you need to make sure is to read the instructions that sgfxi gives you.

Also, starting the desktop after the second time of running sgfxi didn't work for me, so.. type

Code: Select all

startx
as user to kick it into gear if this happens :smile:

Good luck!
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

lend27
Forum Novice
Forum  Novice
Posts: 65
Joined: Wed Apr 29, 2015 4:02 pm

Re: Nvidia drivers won't install

#5

Post by lend27 » Mon Nov 09, 2015 11:18 am

I read through the wiki instructions and had to use ethernet to install, but I finished the install and all is well.
Running the Nvidia 355.11 as we speak :)


Thanks!
Len
You do not have the required permissions to view the files attached to this post.

Post Reply

Return to “Bugs and Non-Package Requests Forum”