Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

A Japanese keyboard is not set definitely

Report Bugs, Issues and non- package Requests
Post Reply
fu-sen
Forum Regular
Forum Regular
Posts: 148
Joined: Tue May 27, 2014 9:33 am

A Japanese keyboard is not set definitely

#1

Post by fu-sen » Mon Jun 02, 2014 8:54 pm

Because there is point release of MX-14, I let this bug progress.

When I chose Japanese keyboard (jp106) by installation of MX-14, it becomes English by reboot.
I suppose that this appoints the setting of the keyboard by mistake.

The same problem occurs in AntiX:
http://antix.freeforums.org/wrong-for-t ... t5114.html

But setting may be different in Xfce.
If Xfce original setting includes a hint, I may give a remedy concretely.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 24976
Joined: Wed Jul 19, 2006 6:13 am

Re: A Japanese keyboard is not set definitely

#2

Post by Jerry3904 » Mon Jun 02, 2014 8:59 pm

If I understand the problem correctly, you need to click Settings manager > Keyboard. On the Layout tab, uncheck "Use System Defaults," then click on the Add button to set which language(s) your keyboard will use.

Is that what you meant?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

fu-sen
Forum Regular
Forum Regular
Posts: 148
Joined: Tue May 27, 2014 9:33 am

Re: A Japanese keyboard is not set definitely

#3

Post by fu-sen » Mon Jun 02, 2014 9:07 pm

I know the solution to problem by the setting.
As for the problem reporting, there is "jp106" in the item of the keyboard with an installer.
It is that the setting of this has a problem.

fu-sen
Forum Regular
Forum Regular
Posts: 148
Joined: Tue May 27, 2014 9:33 am

Re: A Japanese keyboard is not set definitely

#4

Post by fu-sen » Tue Jun 03, 2014 12:11 am

When I make a keyboard jp106 in MX-14 Installer:
Keyboard model:
Generic 105-Key (intl) PC

Keyboard layout:
jp106
English (US)
Originally sets "jp106" to "Keyboard model".
But I think that the "Generic 105-Key (intl) PC" is enough without there being it in the item of Keyboard model.
Japanese should become available about Keyboard layout.

Right:

Code: Select all

Keyboard model:
Generic 105-Key (intl) PC or jp106

Keyboard layout:
Japanese

Post Reply

Return to “Bugs and Non-Package Requests Forum”