Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Panel dissapearing on Startup at random.

Report Bugs, Issues and non- pacakage Requests
Message
Author
kb50
Forum Novice
Forum  Novice
Posts: 20
Joined: Sun Nov 26, 2017 9:51 pm

Panel dissapearing on Startup at random.

#1 Post by kb50 » Sat Jan 13, 2018 4:02 pm

I am having an issue, where when I boot up MX-17 sometimes, not always, the PANEL disappears just when the Wallpaper is displayed.

I can get it back by logging out and back in, however.
I am using Noveau driver, but it was happening when NVIDIA driver was installed as well. Made no difference.

I do have a Ton of Wallpaper, stuffed into a folder named WALLPAPER which is replacing the default one, of the Desktop Settings.
I have it also set to Random Change every 10 minutes. I do use Conky to display a clock, but I have tried without Conky so that does not seem to be the issue.

Secondly and this could be unrelated, but when I logout the login box does not display my username, unless you drop it down.
I did change my picture, and filled in my information to the user in the About Me, however that also seems to lose settings other than the Profile Image.
The profile image does show in the lock screen.

number698
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Feb 15, 2016 1:49 pm

Re: Panel dissapearing on Startup at random.

#2 Post by number698 » Mon May 07, 2018 12:58 pm

I''ve lost the panel/s too. Tried logging in/out, never brings back panels, tried getting to the panel setting (failed to popup the options). Created fresh user but no panel at startup at all. ???

live-usb version: 2.12.13
iso passes md5 check

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8665
Joined: Sun Dec 16, 2007 1:17 pm

Re: Panel dissapearing on Startup at random.

#3 Post by dolphin_oracle » Mon May 07, 2018 1:08 pm

that's really odd that the new user didn't have a panel.

try running it manually

Code: Select all

xfce4-panel &
also, do you have or have had multiple monitors?
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)

number698
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Feb 15, 2016 1:49 pm

Re: Panel dissapearing on Startup at random.

#4 Post by number698 » Mon May 07, 2018 1:26 pm

hi, its a laptop with no other monitors attached.

(xfce4-panel:9924): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8665
Joined: Sun Dec 16, 2007 1:17 pm

Re: Panel dissapearing on Startup at random.

#5 Post by dolphin_oracle » Mon May 07, 2018 1:51 pm

so this stick has NEVER been used on a machine with multiple monitors? are you running with persistence?

what theme are you running?

please post the output of

Code: Select all

inxi -r
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)

number698
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Feb 15, 2016 1:49 pm

Re: Panel dissapearing on Startup at random.

#6 Post by number698 » Mon May 07, 2018 2:07 pm

fresh stick today - root persistence, run only on this lappy - default theme, created 2nd panel, changed some settings, installed kodi, chromiun.

Also - MX tweak 'restore default panel' does not bring panel back.




$ inxi -r
Repos: Active apt repos in: /etc/apt/sources.list.d/antix.list
1: deb http://nl.mxrepo.com/antix/stretch stretch main
Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
1: deb http://ftp.uk.debian.org/debian/ stretch-updates main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/debian.list
1: deb http://ftp.uk.debian.org/debian/ stretch main contrib non-free
2: deb http://security.debian.org/ stretch/updates main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/mx.list
1: deb http://nl.mxrepo.com/mx/repo/ stretch main non-free
No active apt repos in: /etc/apt/sources.list.d/various.list
Last edited by number698 on Mon May 07, 2018 2:17 pm, edited 1 time in total.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21790
Joined: Wed Jul 19, 2006 6:13 am

Re: Panel dissapearing on Startup at random.

#7 Post by Jerry3904 » Mon May 07, 2018 2:16 pm

What are the settings for each of the 2 panels under Preferences > Display, Automatically hide the Panel
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

number698
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Feb 15, 2016 1:49 pm

Re: Panel dissapearing on Startup at random.

#8 Post by number698 » Mon May 07, 2018 2:26 pm

Jerry3904 wrote:What are the settings for each of the 2 panels under Preferences > Display, Automatically hide the Panel
unable to get to those preferences now, panel settings Just gives up showing the popup window, bottom 1 was not hidden, top was hide intelligently, but i was able to use MX tweak to 'restore default panel' - NO visible panel appeared though.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8665
Joined: Sun Dec 16, 2007 1:17 pm

Re: Panel dissapearing on Startup at random.

#9 Post by dolphin_oracle » Mon May 07, 2018 2:33 pm

if xfce4-panel won't run at all, the mx-tweak restore function won't do anything. it just backs up the panel configs, not the app itself. but the configs probably did reset.

what about themes? what theme are you using?

I really stretching here, because what that error message usually means is that 2 conflicting versions of the application are installed somehow.

if you boot WITHOUT persistence enabled, do you have a panel?
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)

number698
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Feb 15, 2016 1:49 pm

Re: Panel dissapearing on Startup at random.

#10 Post by number698 » Mon May 07, 2018 2:47 pm

Hmm, OK - deleted rootfs, created new one ONLY changed panel from default to vertical, installed kodi and chromium, rebooted and the panel has GONE ?

will go through more tries, to pin it down further

PS: before rebooting, started up kodi and chromium, changed kodi settings from full screen to window.

Post Reply

Return to “Bugs and Non-Package Requests Forum”