Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Default Browser

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 1983
Joined: Mon Nov 21, 2011 5:50 pm

Default Browser

#1 Post by Gordon Cooper » Thu Jan 11, 2018 11:15 pm

Current default is PaleMoon - have been using it for more than a year. In a new installation of MX-17, I cannot use the links in the MX Manual unless Firefox is also
installed - but not made the default. An Input/Output error is reported. Have double checked this. Delete Firefox and links will not work from Pale Moon. Re-install Firefox (from the MX Package Installer) but do not make it the default, and the links work ???

Can live with this, but when I use a link, do get a pop-up asking if Firefox should be the default. A bug or me?

Edit: PaleMoon works perfectly as a browser regardless of Firefox.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
towwire
Forum Regular
Forum Regular
Posts: 296
Joined: Fri Oct 15, 2010 12:15 pm

Re: Default Browser

#2 Post by towwire » Fri Jan 12, 2018 1:21 am

I'm using MX-16, not sure but you may have to edit some files. Show hidden files and then look here,
/home/your_name/.gconf/desktop/gnome/url-handlers/

For https you may have this code:

Code: Select all

<?xml version="1.0"?>
<gconf>
	<entry name="needs_terminal" mtime="1488993186" type="bool" value="false"/>
	<entry name="enabled" mtime="1488993186" type="bool" value="true"/>
	<entry name="command" mtime="1488993186" type="string">
		<stringvalue>/opt/firefox/firefox %s</stringvalue>
	</entry>
</gconf>
my guess is that you need to change the path to where Pale Moon is located. Please back it up before you edit, Remember this my best guess. All the handlers show Firefox or Thunderbird on my machine.
Edit DO NOT do the above unless some one like stevo say's it's ok.

You can open Settings and then Preferred Applications, change web Browser to Pale Moon and your links will then open on Pale Moon.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6002
Joined: Wed Jul 12, 2006 2:10 am

Re: Default Browser

#3 Post by Eadwine Rose » Fri Jan 12, 2018 2:10 am

What I always do is the following:

Open a terminal, su to root, and enter

Code: Select all

update-alternatives --config x-www-browser
and enter the browser you want
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 1983
Joined: Mon Nov 21, 2011 5:50 pm

Re: Default Browser

#4 Post by Gordon Cooper » Fri Jan 12, 2018 3:12 am

Thanks for replies towire and Edwine. Have done some more more digging

1. On an installation of MX-16.1, PaleMoon works properly in handing the Manual Links and there is NO copy of Firefox on this system.

2. Wondered if the pdf reader had any part in the problem, but no. Okular behaves exactly the same as qpdf, will not activate the links. This may be a bug in the
recent Pale Moon update. Will also see if copy of the MX17 manual behaves with an MX 16 OS and the older PM.

3. Have looked at the Preferred Applications, they do say Firefox even though in the setup, PaleMoon is set as the default
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22414
Joined: Wed Jul 19, 2006 6:13 am

Re: Default Browser

#5 Post by Jerry3904 » Fri Jan 12, 2018 5:56 am

Have looked at the Preferred Applications, they do say Firefox even though in the setup, PaleMoon is set as the default
That's what you need to change. You can use CLI as ER does, or click on the Start menu and begin to type "Preferred" to get the GUI (also via All Settings).
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 1983
Joined: Mon Nov 21, 2011 5:50 pm

Re: Default Browser

#6 Post by Gordon Cooper » Fri Jan 12, 2018 6:46 am

Yep, that has fixed it thanks ER and Jerry - although it was not quite so easy, the palemoon file name in the bin was incorrect, had to re-install Pale Moon and do the
Preferred Apps bit again. Why this allowed to use PM as a normal browser but not for Manual Links, can remain a mystery. Bedtime, goodnight.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

Post Reply

Return to “Bugs and Non-Package Requests Forum”