Page 1 of 1

how to get FileZilla from version 3.24 to 3.44 ?

Posted: Thu Aug 15, 2019 5:35 pm
by say_hello
dear community,



how to get FileZilla from version 3.24 to 3.44 ?

i have 3.24 on my machine - and want to get the newest one.
3.44.2 (2019-08-15)
Bugfixes and minor changes:
MSW: Fixed a crash if using predefined sites through fzdefaults.xml
Fixes to protocol selection glitches in the Site Manager
Increase maximum length of response lines when using FTP
3.44.1 (2019-08-09)
how to do that?!

love to hear from you

Re: how to get FileZilla from version 3.24 to 3.44 ?

Posted: Thu Aug 15, 2019 7:33 pm
by JayM
First, search the MX Stable and (especially) Test repos in MX Package Installer to see if a newer version is already there. If it isn't, to request new or updated software packages be added to the MX Repositories please read these instructions. then post your request here.

Re: how to get FileZilla from version 3.24 to 3.44 ?

Posted: Thu Aug 15, 2019 7:53 pm
by Jerry3904
I see 3.39 is there in MX Popular applications. No Debian based distro seems to have 3.44 that I can see.

Is OP sure that 3.39 (default in Debian Buster and Sid) won't be enough?

Re: how to get FileZilla from version 3.24 to 3.44 ?

Posted: Thu Aug 15, 2019 10:21 pm
by Stevo
I'll take a look at it, but if that fails, it should be available as a Flatpak in our package installer, according to the Google.

Hmmm...seems doable, as long I don't run into weird stuff like needing a newer gcc compiler.

###################################################################################

Well, I jinxed it, the configure failed with

Code: Select all

cc1: error: -Werror=partial-availability: no option -Wpartial-availability
We do have that gcc-8 in our experimental repo I can try, though.

Re: how to get FileZilla from version 3.24 to 3.44 ?

Posted: Thu Aug 15, 2019 10:52 pm
by Stevo
And now it fails with

Code: Select all

checking for libfilezilla >= 0.18.1
When I already backported 0.15.1, which is the newest that Debian has. But I'll take that on tomorrow.

Re: how to get FileZilla from version 3.24 to 3.44 ?

Posted: Fri Aug 16, 2019 4:33 am
by baldyeti
Jerry3904 wrote:
Thu Aug 15, 2019 7:53 pm
I see 3.39 is there in MX Popular applications. No Debian based distro seems to have 3.44 that I can see.
I am not seeing this - MXPI shows me the version for packages in stable/test repos, but *not* for popular ones (not even as a tooltip)

Re: how to get FileZilla from version 3.24 to 3.44 ?

Posted: Fri Aug 16, 2019 5:51 am
by Jerry3904
My bad: forgot I'm not on MX-18.x, sorry.

Re: how to get FileZilla from version 3.24 to 3.44 ?

Posted: Fri Aug 16, 2019 1:49 pm
by Stevo
I was able to build and install 3.44.2 on both MX 18 and 19, using gcc-8 on both, but only the MX 19 version runs. It fails on MX 17 with the message "can't find libfilezilla.so", though it exists on the system and was built against it. It did not require any runtime libraries from gcc-8 on MX 18.

So, I'll send up the MX 19 version for main, but it looks like Flatpak time for MX 18 for now. There is a possibility that I can build some version that works between 3.24 and 3.43 for MX 17, but I need some input about what your requirement is.