Welcome!
Important information
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-18.1 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.3.1 release info here

New users[/u
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

Khaled
Forum Novice
Forum  Novice
Posts: 10
Joined: Wed Dec 12, 2018 10:20 am

Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#1

Post by Khaled » Wed Dec 12, 2018 11:16 am

This is a minor issue.
Last update included updating gimp from 2.8 to 2.10 (which was long awaited).
However it won't run, its output was as follow:

Code: Select all

gimp: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgegl-0.4.so.0: undefined symbol: babl_format_with_space
So I figured out the problem was with the package "libbabl-0.1-0". I found in Synaptic that there is a mx- modified version of it, then I forced installing it (Package -> Force Version -> select "0.1.58-1~mx17+1 (mx)").
Synaptic will call it downgrade, although the installed version is lower "1:0.1.28-dmo1", anyway installed it and now everything is fine.
My guess is that although mx packages team took care of this, their modified packaged was estimated to be lower version just because the debian-stable default package's version begins with "1:" before the version "0.1.28".

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2931
Joined: Wed Apr 11, 2018 5:09 pm

Re: Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#2

Post by fehlix » Wed Dec 12, 2018 11:41 am

Gimp 2.10 installes and run's just fine here. Don't see version "1:0.1.28-dmo1" of libbabl-0.1 in stable, so you must have got somwhere else, hence the conflict:

Code: Select all

 apt policy libbabl-0.1
libbabl-0.1-0:
  Installed: 0.1.58-1~mx17+1
  Candidate: 0.1.58-1~mx17+1
  Version table:
 *** 0.1.58-1~mx17+1 500
        500 http://mxrepo.com/mx/repo stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     0.1.18-1 500
        500 http://ftp.us.debian.org/debian stretch/main amd64 Packages
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4658
Joined: Wed Jul 12, 2006 4:05 pm

Re: Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#3

Post by timkb4cq » Wed Dec 12, 2018 1:39 pm

You have installed the Debian-Multimedia version of libbabl which uses an epoch to show it's version as being higher than ours.
Disable the deb-multimedia.org repo, and
Gui solution: Open Synaptic, select libbabl-0.1-0, use Package -> Force version to select the MX version and apply.
or
CLI solution: sudo apt-get install -t mx libbabl-0.1-0
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 17974
Joined: Fri Dec 15, 2006 8:07 pm

Re: Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#4

Post by Stevo » Wed Dec 12, 2018 4:22 pm

Yes, if you look at the GIMP thread, it's a known issue with a known solution. I was expecting to see a few more of these with the upgrade for everyone.

Packages with "dmo" in the version are from deb-multimedia, except for Stretch's mkvtoolnix, where the packager goofed by forgetting to remove it.

Code: Select all

     9.8.0-dmo1 500
        500 http://ftp.us.debian.org/debian stretch/main amd64 Packages

Khaled
Forum Novice
Forum  Novice
Posts: 10
Joined: Wed Dec 12, 2018 10:20 am

Re: Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#5

Post by Khaled » Wed Dec 12, 2018 7:14 pm

timkb4cq wrote: You have installed the Debian-Multimedia version of libbabl which uses an epoch to show it's version as being higher than ours.
Stevo wrote: Packages with "dmo" in the version are from deb-multimedia
Yes it seems that's exactly the case. Thanks for the info. :)
timkb4cq wrote: Disable the deb-multimedia.org repo
I think I had that repo installed in first place just for a hell of dependency of gstreamer pluggins by kivy, which I use for work, so I am afraid I may not have the luxury to try to ditch that repo right now.
timkb4cq wrote: Gui solution: Open Synaptic, select libbabl-0.1-0, use Package -> Force version to select the MX version and apply.
Yes that's what I had done, and it works perfectly thereafter as I said.
Though, apt would always tell me that I have a package that needs to be updated!
Is there some sort of way to blacklist libbabl-0.1-0 1:0.1.28-dmo1, or just libbabl-0.1-0 from being checked for update ?

User avatar
Richard
Posts: 2476
Joined: Fri Dec 12, 2008 10:31 am

Re: Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#6

Post by Richard » Wed Dec 12, 2018 7:54 pm

Is there some sort of way to blacklist libbabl-0.1-0 1:0.1.28-dmo1, or just libbabl-0.1-0 from being checked for update ?
You can do it from Synaptic.
Or with aptitude.
MX18.1: Thinkpad T430: Dual Core, Intel i5-3320M, Ivy Bridge, 8GB RAM, 4.19.0-1-amd64, 119GB SSD 840PRO, Intel Graphics-Audio-Network
MX18.1: AsusTek EeePC 1005HA: Intel Dual Core Atom N270, 1GB RAM, 4.19.0-1-686, 150GB HDD

User avatar
Richard
Posts: 2476
Joined: Fri Dec 12, 2008 10:31 am

Re: Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#7

Post by Richard » Wed Dec 12, 2018 7:56 pm

aptitude = Hold
synaptic = Lock
MX18.1: Thinkpad T430: Dual Core, Intel i5-3320M, Ivy Bridge, 8GB RAM, 4.19.0-1-amd64, 119GB SSD 840PRO, Intel Graphics-Audio-Network
MX18.1: AsusTek EeePC 1005HA: Intel Dual Core Atom N270, 1GB RAM, 4.19.0-1-686, 150GB HDD

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 17974
Joined: Fri Dec 15, 2006 8:07 pm

Re: Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#8

Post by Stevo » Wed Dec 12, 2018 9:55 pm

Once you've installed whatever you need from deb-multimedia, you don't need to keep it enabled. In fact, that's the worst thing you can do.

I wonder if having deb-multimedia enabled beforehand messed up your gstreamer dependencies, since the Stretch Kivy 1.9.1 will install without deb-multimedia.

Khaled
Forum Novice
Forum  Novice
Posts: 10
Joined: Wed Dec 12, 2018 10:20 am

Re: Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#9

Post by Khaled » Thu Dec 13, 2018 4:31 am

Richard wrote: aptitude = Hold
synaptic = Lock
Thanks, that's exactly what I was looking for.
Stevo wrote: Once you've installed whatever you need from deb-multimedia, you don't need to keep it enabled. In fact, that's the worst thing you can do.
I will do that after your advice. Should I lock its already installed packages first to not losing them ?
Stevo wrote: I wonder if having deb-multimedia enabled beforehand messed up your gstreamer dependencies, since the Stretch Kivy 1.9.1 will install without deb-multimedia.
It is not a debian package dependency, but an optional requirement for kivy to be able to play videos.

Khaled
Forum Novice
Forum  Novice
Posts: 10
Joined: Wed Dec 12, 2018 10:20 am

Re: Last major update: Gimp 2.10 needs version "0.1.58-1~mx17+1" of libbabl-0.1-0

#10

Post by Khaled » Thu Dec 13, 2018 7:10 am

I would also like to ask, is there something really bad about deb-multimedia in particular, or you just mean I shouldn't add any additional Debian repository ?
I have just few, like sublimetext repo, which I don't really need to keep it there, but I am curious to know. I used to alternate between debian-based and ubuntu-based distros for the last 12 years, sometimes in the old days I even used to install a lot of ppa, though I don't remember I ever managed to break my system that way. May be it's just my poor memory.

Post Reply

Return to “General”