Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

(SOLVED) keep apps from running at start up

Post Reply
Message
Author
User avatar
MissRed
Forum Novice
Forum  Novice
Posts: 3
Joined: Mon Nov 05, 2018 6:53 pm

(SOLVED) keep apps from running at start up

#1 Post by MissRed » Sun Dec 02, 2018 9:31 pm

Hi everyone! I recently installed MX and so far I'm enjoying it. However, I'm now facing kind of a situation; whenever I turn on my netbook and/or login some apps auto start; Nomacs and xfce4-termnal, I have to click on the "X" to close them, no images in Nomacs and a blank terminal. I already checked in session and startup and there's no option there to keep them from doing this. How can I do that? I'm like really new to Linux in general and if a GUI approach is possible that would be really nice. Thanks in advance for your answers.
Last edited by MissRed on Mon Dec 03, 2018 8:09 am, edited 1 time in total.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10078
Joined: Sun Dec 16, 2007 1:17 pm

Re: keep apps from running at start up

#2 Post by dolphin_oracle » Sun Dec 02, 2018 9:32 pm

clear your saved sessions. xfce tries to remember whats running when you shutdown, and then restarts it next boot.

Settings->Session & Startup->Sessions Tab -> clear saved sessions
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
MissRed
Forum Novice
Forum  Novice
Posts: 3
Joined: Mon Nov 05, 2018 6:53 pm

Re: keep apps from running at start up

#3 Post by MissRed » Sun Dec 02, 2018 9:44 pm

dolphin_oracle wrote:
Sun Dec 02, 2018 9:32 pm
clear your saved sessions. xfce tries to remember whats running when you shutdown, and then restarts it next boot.

Settings->Session & Startup->Sessions Tab -> clear saved sessions
Well, but it happens everytime and those apps are not always running. Thanks for your answer. I'll try that and hope it works cause it's kind of annoying.

User avatar
MissRed
Forum Novice
Forum  Novice
Posts: 3
Joined: Mon Nov 05, 2018 6:53 pm

Re: keep apps from running at start up

#4 Post by MissRed » Mon Dec 03, 2018 8:07 am

Thank you! That worked! I logout-login and no Nomacs no xfce4-terminal wndows :happy:

Post Reply

Return to “General”