Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Mullvad vpn client issue [SOLVED]

Message
Author
Hooten
Forum Novice
Forum  Novice
Posts: 33
Joined: Sat May 05, 2018 5:52 pm

Re: Mullvad vpn client issue

#11 Post by Hooten » Tue Sep 25, 2018 10:54 am

fehlix wrote:
Tue Sep 25, 2018 10:53 am
Hooten wrote:
Tue Sep 25, 2018 10:48 am
fehlix wrote:
Tue Sep 25, 2018 10:40 am

oops.. no error message?
Client just stuck at "Connecting to daemon".
I meant, when you start the above daemon , do you got any messages?
Oh sorry, not at all.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1734
Joined: Wed Apr 11, 2018 5:09 pm

Re: Mullvad vpn client issue

#12 Post by fehlix » Tue Sep 25, 2018 10:59 am

Hooten wrote:
Tue Sep 25, 2018 10:54 am
fehlix wrote:
Tue Sep 25, 2018 10:53 am
Hooten wrote:
Tue Sep 25, 2018 10:48 am


Client just stuck at "Connecting to daemon".
I meant, when you start the above daemon , do you got any messages?
Oh sorry, not at all.
Which is good. So what's left, I assume, is to startup the daemon earlier
in the process before the network manager is up
Which means to have a little init.d script for the sturtup of either one of the above daemons.
:snail:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1734
Joined: Wed Apr 11, 2018 5:09 pm

Re: Mullvad vpn client issue

#13 Post by fehlix » Tue Sep 25, 2018 11:45 am

Perhaps - at least for a test - try to start the daemon as this.
Do add those lines add the end of the file /etc/rc.local
Keep only one line un-commented either for mullvad-daemon or for qomui-service - not both.
Make sure the last line will be exit 0 followed by a new line.

Code: Select all

# leave onle one line uncommented
/opt/mullvad-vpn/resources/mullvad-daemon  -v --disable-stdout-timestamps
# 
/usr/bin/env qomui-service
So the file /etc/rc.local looks either like this
for mullvad-daemon

Code: Select all

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
/opt/mullvad-vpn/resources/mullvad-daemon  -v --disable-stdout-timestamps

exit 0

or like this for qomui-service

Code: Select all

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
/usr/bin/env qomui-service

exit 0

EDIT: and do reboot after those changes ... :snail:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Hooten
Forum Novice
Forum  Novice
Posts: 33
Joined: Sat May 05, 2018 5:52 pm

Re: Mullvad vpn client issue

#14 Post by Hooten » Wed Sep 26, 2018 12:00 pm

fehlix wrote:
Tue Sep 25, 2018 11:45 am
Perhaps - at least for a test - try to start the daemon as this.
Do add those lines add the end of the file /etc/rc.local
Keep only one line un-commented either for mullvad-daemon or for qomui-service - not both.
Make sure the last line will be exit 0 followed by a new line.

Code: Select all

# leave onle one line uncommented
/opt/mullvad-vpn/resources/mullvad-daemon  -v --disable-stdout-timestamps
# 
/usr/bin/env qomui-service
So the file /etc/rc.local looks either like this
for mullvad-daemon

Code: Select all

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
/opt/mullvad-vpn/resources/mullvad-daemon  -v --disable-stdout-timestamps

exit 0

or like this for qomui-service

Code: Select all

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
/usr/bin/env qomui-service

exit 0

EDIT: and do reboot after those changes ... :snail:
I think i've done it right, but nothing changed. BTW i'm testing it in vm, not to worry about bricking anything in my main system.
You do not have the required permissions to view the files attached to this post.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1734
Joined: Wed Apr 11, 2018 5:09 pm

Re: Mullvad vpn client issue

#15 Post by fehlix » Wed Sep 26, 2018 6:20 pm

Hooten wrote:
Wed Sep 26, 2018 12:00 pm
I think i've done it right, but nothing changed. BTW i'm testing it in vm, not to worry about bricking anything in my main system.
Yeah, it's probably too late with rc.local at the end of the runlevel, it needs to be get started earlier.
So what is needed would be to have init.d start script to get it a bit earlier started.
You might look whether you can find any mullvad related service files, which we might convert
to inti.d scripts.
:snail:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Hooten
Forum Novice
Forum  Novice
Posts: 33
Joined: Sat May 05, 2018 5:52 pm

Re: Mullvad vpn client issue

#16 Post by Hooten » Thu Sep 27, 2018 11:35 am

fehlix wrote:
Wed Sep 26, 2018 6:20 pm
Hooten wrote:
Wed Sep 26, 2018 12:00 pm
I think i've done it right, but nothing changed. BTW i'm testing it in vm, not to worry about bricking anything in my main system.
Yeah, it's probably too late with rc.local at the end of the runlevel, it needs to be get started earlier.
So what is needed would be to have init.d start script to get it a bit earlier started.
You might look whether you can find any mullvad related service files, which we might convert
to inti.d scripts.
:snail:
Look i'm not that stupid. I did what you said first and after that i started mullvad, but same thing happened. :frown:

Hooten
Forum Novice
Forum  Novice
Posts: 33
Joined: Sat May 05, 2018 5:52 pm

Re: Mullvad vpn client issue

#17 Post by Hooten » Thu Sep 27, 2018 11:45 am

I also trying to run mullvad through openvpn following the instructions from here :https://mullvad.net/en/guides/linux-ope ... tallation/
But when i go to 4. step i get [FAIL] Starting virtual private network daemon: mullvad_no failed!

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1734
Joined: Wed Apr 11, 2018 5:09 pm

Re: Mullvad vpn client issue

#18 Post by fehlix » Thu Sep 27, 2018 11:52 am

OK, I meant if you look for mullvad servcice files within the systemd folder /etc/systemd/system.
And if you post those here we might convert them into alternative start files,
so they get started ealier than rc.local, which appreaas to be to late, when you start MX17 with the default SysVint start system.
I can't test this myself, as I have no mullvad vpn. :happy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Hooten
Forum Novice
Forum  Novice
Posts: 33
Joined: Sat May 05, 2018 5:52 pm

Re: Mullvad vpn client issue

#19 Post by Hooten » Thu Sep 27, 2018 12:05 pm

fehlix wrote:
Thu Sep 27, 2018 11:52 am
OK, I meant if you look for mullvad servcice files within the systemd folder /etc/systemd/system.
And if you post those here we might convert them into alternative start files,
so they get started ealier than rc.local, which appreaas to be to late, when you start MX17 with the default SysVint start system.
I can't test this myself, as I have no mullvad vpn. :happy:
There is a file named "mullvad-daemon.service" and that is inside:

# Systemd service unit file for the Mullvad VPN daemon

[Unit]
Description=Mullvad VPN daemon
Wants=network.target
After=network-online.target
StartLimitBurst=5
StartLimitIntervalSec=20

[Service]
Restart=always
RestartSec=1
ExecStart=/opt/Mullvad\x20VPN/resources/mullvad-daemon -v --disable-stdout-timestamps

[Install]
WantedBy=multi-user.target

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1734
Joined: Wed Apr 11, 2018 5:09 pm

Re: Mullvad vpn client issue

#20 Post by fehlix » Thu Sep 27, 2018 12:25 pm

Ah thats, looks nice. The path differs from the one I gave above.
What happens if you start from the command line this

Code: Select all

/opt/Mullvad\ VPN/resources/mullvad-daemon -v --disable-stdout-timestamps
Note the backslash before the space.
Would the daemon run ?
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “General”