Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

NTFS partition - SOLVED -

Message
Author
mx65
Forum Novice
Forum  Novice
Posts: 37
Joined: Sat Jan 07, 2017 3:11 pm

NTFS partition - SOLVED -

#1 Post by mx65 » Tue Jan 02, 2018 9:43 pm

How do I mount an NTFS partition without entering a root password in MX linux 17? :alien:
Last edited by mx65 on Thu Jan 04, 2018 8:34 am, edited 1 time in total.

User avatar
Richard
Posts: 1819
Joined: Fri Dec 12, 2008 10:31 am

Re: NTFS partition

#2 Post by Richard » Wed Jan 03, 2018 12:43 am

You have to specify it in /etc/fstab.
MX17.1____: T430-2017, 8 GB RAM, 4.15.0-1-amd64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DC9, LibO605, Dropbox, FF61, FFesr, mPDFed, Py3, CherryT, Vbox
linux counter #288562

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 3012
Joined: Sun May 27, 2007 5:37 am

Re: NTFS partition

#3 Post by asqwerth » Wed Jan 03, 2018 1:07 am

Run Disk Manager, mount the nfts partition by clicking on the checkbox on the left, ensure the driver displayed for said partition is ntfs-3g instead of ntfs. If not, select edit option in Disk Manager and change to correct driver. Then save the settings and close disk manager. Reboot and it will be automounted for normal use.

This is in the Manual, I believe.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
penguin
Forum Regular
Forum Regular
Posts: 232
Joined: Wed Jan 04, 2017 3:15 pm

Re: NTFS partition

#4 Post by penguin » Wed Jan 03, 2018 2:50 am

Have a look in this site. Easy and elegant way.

Code: Select all

https://linuxnewbieguide.org/how-to-read-and-write-to-windows-ntfs-drives-as-any-user/
Maybe you find it interesting.

balarm
Forum Novice
Forum  Novice
Posts: 63
Joined: Thu Dec 07, 2017 3:15 pm

Re: NTFS partition

#5 Post by balarm » Wed Jan 03, 2018 5:31 am

If the partition is internal you can use MXtools >Mx utilities check enable internal drives
You do not have the required permissions to view the files attached to this post.
mx1 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine: Device: laptop System: LENOVO product: 1951A47 v: ThinkPad T60

mx65
Forum Novice
Forum  Novice
Posts: 37
Joined: Sat Jan 07, 2017 3:11 pm

Re: NTFS partition

#6 Post by mx65 » Wed Jan 03, 2018 10:45 am

Thanks balarm, I did not know that option in MX tools :happy:

balarm
Forum Novice
Forum  Novice
Posts: 63
Joined: Thu Dec 07, 2017 3:15 pm

Re: NTFS partition

#7 Post by balarm » Wed Jan 03, 2018 2:50 pm

Please, edit your initil post and write SOLVED.
Thanks.
mx1 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine: Device: laptop System: LENOVO product: 1951A47 v: ThinkPad T60

User avatar
surya88
Forum Novice
Forum  Novice
Posts: 2
Joined: Sun Jan 14, 2018 12:40 pm

Re: NTFS partition - SOLVED -

#8 Post by surya88 » Sun Jan 21, 2018 8:35 am

Thanks, this helped me too. I have a 2 TB disk formatted in NTFS and used as a data drive for both the MX and Windows 10 installations. All of a sudden today, the 2 TB would be mounted and the folders in the drive shown with locked symbols even though right click - > Permissions showed that the logged (non-root) user had permission to read and write to the drive and folders. It didn't behave this way previously. Following instructions on this thread I ran Disk Manager and even though it showed the drive as ntfs-3d, I rechecked it and then it mounted fine and now allows the logged in user to write to the folder. This is a somewhat mysterious and inconsistent behavior.

User avatar
penguin
Forum Regular
Forum Regular
Posts: 232
Joined: Wed Jan 04, 2017 3:15 pm

Re: NTFS partition - SOLVED -

#9 Post by penguin » Sun Feb 18, 2018 9:12 am

I am adding a tip for NFTS partition on this case ( small lock on NFTS folder or you have problem with read and write when mount this partition)

On the last days I had the same problem.I do not know why. So. I tried to repair NFTS from Windows , but when I mounted NFTS partition, Linux did not allowed me to write or read. A small lock icon was on file icon. So :

Lets suppose that NFTS partition is sdb1, mounted it on /mnt/WinNFTS and we have labeled this partition as WinNFTS

First : unmount it
sudo umount /mnt/WinNFTS

Suppose that your user name is : mxlinux . You are part of users group .You can check by id mxlinux
If not than add mxlinux user to this group by sudo usermod -a -G users mxlinux
from wiki https://wiki.archlinux.org/index.php/NTFS-3G
Allowing group/user
In /etc/fstab you can also specify other options like those who are allowed to access (read) the partition. For example, for you to allow people in the users group to have access:

/dev/NTFS-partition /mnt/windows ntfs-3g gid=users,umask=0022 0 0
By default, the above line will enable write support for root only. To enable user writing, you have to specify the user who should be granted write permissions. Use the uid parameter together with your username to enable user writing:

/dev/NTFS-partition /mnt/windows ntfs-3g uid=username,gid=users,umask=0022 0 0
If you are running on a single user machine, you may like to own the file system yourself and grant all possible permissions:

/dev/NTFS-partition /mnt/windows ntfs-3g uid=username,gid=users 0 0
Now lets try to mount NFTS partition by: sudo mount -t ntfs /dev/sdb1 /mnt/WinNFTS -o uid=mxlinux,gid=users


uppps ! on this point I get error:

Similar to this error ( I get similar error on my system):

Code: Select all

https://askubuntu.com/questions/462381/cant-mount-ntfs-drive-the-disk-contains-an-unclean-file-system
Error mounting /dev/sdb1 at /mnt/ubuntu/Media Center: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda6" "/media/rolindroy/Media Center"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda6': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option
scroll down ...

Code: Select all

if you can't access the drive, execute the following command:

sudo ntfsfix /dev/sdXY
where XY is the partition
e.g sda2 or sdb1
Then, mount with:
sudo mount -o rw /dev/sdXY
repair as ....in our case : sudo ntfsfix /dev/sdb1
try to remount by sudo mount -t ntfs /dev/sdb1 /mnt/WinNFTS -o uid=mxlinux,gid=users

upps... No error.

The last thing is adding an entry on your fstab by sudo leafpad /etc/fstab ( I use leafpad as my editor); as recommended by Archwiki (see above on this post).The follow entry mounts automatically WinNTFS partition on boot.
On our case LABEL=WinNFTS /mnt/WinNFTS ntfs-3g auto,uid=mxlinux,gid=users,umask=0022 0 0.

Hope it helps.

sunrat
Forum Regular
Forum Regular
Posts: 145
Joined: Mon Mar 28, 2016 9:54 pm

Re: NTFS partition - SOLVED -

#10 Post by sunrat » Fri Feb 23, 2018 7:46 pm

The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option
If you disable fastboot and don't hibernate Windows, you shouldn't get this error so thereby won't need to use ntfsfix.

Post Reply

Return to “General”