Page 1 of 2

SOLVED - Grub Customizer - Assignments not working in order

Posted: Tue Jul 03, 2018 12:40 pm
by HessenZone
I've been running MX Linux with systemd which involved using the simple workaround of booting into a selectable MX Linux systemd setup. I did this primarily because I've never encountered any problems using systemd on Linux distros - ever - and because I was too lazy to immerse myself into the first and only problem when it did appear not long ago. Eventually I decided that it was time to get things going like they're meant to work by default, meaning MX Linux without systemd.

I had initially made some adjustments to my grub file with the grub customizer tool. So I rebooted, selected regular MX Linux (the one without systemd at the end), made sure that it was indeed the correct selection on the screen before pressing the enter button to continue booting. Once I was logged in, I went to the support site of the app which was behaving incorrectly without systemd and started working with someone on their chat support. Well, they had me run a test which showed that everything was working properly ... even though I should have been logged into the MX Linux session which was giving me problems when systemd was not being used. The problems no longer appeared to exist ???

So, either their software was updated during my last run without systemd, or for some odd reason my assigned boot order in the grub menu did not boot me into the proper MX Linux session. I suspect that I'm in the wrong MX session because the grub menu that I assigned to work with the grub customizer, did not show me those same options in the same order as my boot screen during the reboot. My first question then is this - regardless which MX session I'm in, is there a simple terminal command which will show me if I'm currently running systemd or not?
I may have more to ask after that's cleared up. Thanks.
Grub_Customizer.jpg

Re: Grub Customizer - Assignments not working in order

Posted: Tue Jul 03, 2018 12:44 pm
by dolphin_oracle
ps -aux |grep systemd would be what I would check. things like udev-systemd and logind will be running under both sysvinit and systemd, but there should be a systemd process with a PID of 1 if systemd is running.

Re: Grub Customizer - Assignments not working in order

Posted: Tue Jul 03, 2018 12:51 pm
by HessenZone
Yeah, I just figured that one out and I'm indeed running MX Linux with systemd even though that was clearly *NOT* my selected option during boot. So now the next question becomes, how do I change the grub menu so that systemd is forced to come in as only my second or third choice? Altering the boot options with the grub customizer obviously did not work - properly.

One thing that I noticed during that reboot, was the fact that Manjaro apparently didn't like having the grub menu mucked around with, because that's where I noticed most of the problem with things not appearing in my assigned order. I'll be deleting Manjaro later this week, to replace it with Mint 19 Cinnamon. My preferred setup is MX Linux, but I have to keep up to date with Mint users who like the flashier feel of Cinnamon.

Re: Grub Customizer - Assignments not working in order

Posted: Tue Jul 03, 2018 1:08 pm
by dolphin_oracle
HessenZone wrote:
Tue Jul 03, 2018 12:51 pm
Yeah, I just figured that one out and I'm indeed running MX Linux with systemd even though that was clearly *NOT* my selected option during boot. So now the next question becomes, how do I change the grub menu so that systemd is forced to come in as only my second or third choice? Altering the boot options with the grub customizer obviously did not work - properly.

One thing that I noticed during that reboot, was the fact that Manjaro apparently didn't like having the grub menu mucked around with, because that's where I noticed most of the problem with things not appearing in my assigned order. I'll be deleting Manjaro later this week, to replace it with Mint 19 Cinnamon. My preferred setup is MX Linux, but I have to keep up to date with Mint users who like the flashier feel of Cinnamon.

the first question to ask is sysvinit and systemd-shim still installed?

Re: Grub Customizer - Assignments not working in order

Posted: Tue Jul 03, 2018 1:14 pm
by HessenZone
According to Synaptic, both are there. I would have expected them to be too, since I didn't physically change i.e. remove or rename anything. Grub just didn't provide me with the choice that I selected and I believe that may have something to do with Manjaro and the grub that was initially created by it - perhaps having some overlap of sorts somewhere? It's a triple-boot setup without Windows and without a Virtual Box.
Oops, running out of time for tonight (19:14 hrs here). Gotta go, be back in the AM German time. ;)

Re: Grub Customizer - Assignments not working in order

Posted: Tue Jul 03, 2018 1:41 pm
by dreamer
If you managed to set systemd as default you should be able to do the reverse and set sysvinit as default. Only manage GRUB from the distro that controls GRUB. MX 17 controls my GRUB on this PC, but Ubuntu 14.04 is set as default (my MEGA account and a few other things are set up there). You can select boot "first entry", boot "previously used" entry etc. Then save. Make sure to manage GRUB from the right distro and take a close look at all the options available in Grub Customizer. You already changed it once. I changed GRUB boot screen which sounds simple enough but it was a ton of work to get it working.

I have a faint memory of MX not having Advanced Options set up "in the right order". You might want to move the right option to the top. Should look something like this:
Advanced options:
MX (Sysvinit)
MX Recovery mode
MX Systemd

My guess is that the GRUB MX option always boots the first entry that is displayed in the Advanced options menu (if not set otherwise).

Re: Grub Customizer - Assignments not working in order

Posted: Tue Jul 03, 2018 3:13 pm
by male
HessenZone wrote:My first question then is this - regardless which MX session I'm in, is there a simple terminal command which will show me if I'm currently running systemd or not?
a simple terminal command here under antiX

Code: Select all

# ps -p 1
  PID TTY          TIME CMD
    1 ?        00:00:00 init
It's systemd that, stands there

Code: Select all

1 ?        00:00:07 systemd

Re: Grub Customizer - Assignments not working in order

Posted: Tue Jul 03, 2018 10:10 pm
by Richard
These are my results on MX 17.1 running SysV init:

Code: Select all

$ ps -aux |grep systemd
root       465  0.0  0.0  46920  4176 ?        Ss   Jul02   0:00 /lib/systemd/systemd-udevd --daemon
root      2078  0.0  0.0  40520  2580 ?        S    Jul02   0:00 /sbin/cgmanager --daemon -m name=systemd
root      2958  0.0  0.0  46556  4540 ?        S    Jul02   0:00 /lib/systemd/systemd-logind
richard  15574  0.0  0.0  48064   976 pts/1    S+   22:05   0:00 grep systemd
root     23797  0.0  0.0 261056  4268 ?        Sl   14:53   0:00 /usr/lib/x86_64-linux-gnu/systemd-shim
richard@T430:~

Code: Select all

$ ps -p 1
  PID TTY          TIME CMD
    1 ?        00:00:01 init
richard@T430:~

Re: Grub Customizer - Assignments not working in order

Posted: Wed Jul 04, 2018 2:17 am
by HessenZone
I was thinking that I could edit the grub file manually in order to achieve the correct order? Why is it only possibly to set the grub file from the "primary" of the three linux installations? That doesn't make sense to me since grub is supposed to be installed in the root of the drive, as that's always the default. That would indicate to me that there's only one grub file. Manjaro was the second OS which was installed of the three, yet when I boot the computer, a Manjaro logo still appears anyway and the manjaro/grub settings were more jumbled than the others. This would appear to indicate that Manjaro left some kind of trace which impacts the graphical/visible gui grub settings.
If there's only one grub file as I suspect there should only be one, then I should be able to edit that via terminal.
Off to search I go, will return shorly ...

Re: Grub Customizer - Assignments not working in order

Posted: Wed Jul 04, 2018 2:29 am
by HessenZone
Using the command:

Code: Select all

gksu featherpad /boot/grub/grub.cfg
I was about to edit the grub file manually, but then changed my mind since there's no point in making new changes while my intentions are to write over Manjaro with Mint 19 Cinnamon in the next few days. That's going to change the grub again anyway. So for now I'm just going to use grub-customizer to return to the original defaults. We'll see what happens once I have Cinnamon installed, in lieu of Manjaro.