Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

All open windows are showing in all work spaces

Post Reply
Message
Author
k357k9
Forum Novice
Forum  Novice
Posts: 31
Joined: Sat Feb 12, 2011 9:16 am

All open windows are showing in all work spaces

#1 Post by k357k9 » Mon Jun 18, 2018 12:42 pm

This is a brand new install from June ISO on metal and this seems to be the only glitch.
There are 4 work spaces and all show all open windows all the time.
I never saw XFCE do this. KDE has a setting to control this.
Is there a special setting for MX?

User avatar
fehlix
Forum Regular
Forum Regular
Posts: 818
Joined: Wed Apr 11, 2018 5:09 pm

Re: All open windows are showing in all work spaces

#2 Post by fehlix » Mon Jun 18, 2018 1:15 pm

k357k9 wrote:
Mon Jun 18, 2018 12:42 pm
This is a brand new install from June ISO on metal and this seems to be the only glitch.
There are 4 work spaces and all show all open windows all the time.
I never saw XFCE do this. KDE has a setting to control this.
Is there a special setting for MX?
Well, within my brand-new installed MX-17.1_June I do have only 2 default workspaces and I do see only the opened application window within one workspace. But if you right-click on the individual icon on the panel you can select "Show always", which means show within all workspaces ...
...which indicates to me, you might have a bit tweaked to much already
your brand-new installation.

k357k9
Forum Novice
Forum  Novice
Posts: 31
Joined: Sat Feb 12, 2011 9:16 am

Re: All open windows are showing in all work spaces

#3 Post by k357k9 » Mon Jun 18, 2018 1:29 pm

Yes, I did increase the count to 4 from 2 work spaces, but that should not affect anything.
And, I changed that visible and always settings, too.
Let me play around with it some more.

User avatar
chrispop99
Forum Guide
Forum Guide
Posts: 2272
Joined: Tue Jan 27, 2009 3:07 pm

Re: All open windows are showing in all work spaces

#4 Post by chrispop99 » Mon Jun 18, 2018 2:09 pm

If I'm understanding your problem correctly, right-click the panel, select Panel Preferences>Items>Window Buttons>Edit icon. In the Filtering section, un-check Show windows from all workspaces or viewports.

Chris
Test machines:
32-bit non-PAE - Thinkpad T41, 1.6GHz Pentium M, 1GB RAM.
32-bit PAE - DELL Latitude D610, 1.73GHz Pentium M, 2GB RAM.
64-bit - Lenovo T61, 2GHz Core 2 Duo, 2GB RAM
64-bit - Gigabyte Z77P-D3, Intel i3-3220, GeForce 8400 GS, 4GB PC3-12800.

k357k9
Forum Novice
Forum  Novice
Posts: 31
Joined: Sat Feb 12, 2011 9:16 am

Re: All open windows are showing in all work spaces

#5 Post by k357k9 » Mon Jun 18, 2018 3:54 pm

Thanks Chris. That setting is well hidden.

Post Reply

Return to “Desktop Environment”