Page 3 of 4

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Mon May 07, 2018 8:13 am
by fehlix
Issue confirmed!
Delete and Cut is not working using Thunar with my Nikon digicam „mounted“ through gvfs-gphoto2.
Workaround: Instead of Cut‘n‘Paste or Delete moving files with Drag‘n‘Drop does work
and will remove file from the cam.
On terminal command-line delete and ‘move’ is working using gvfs-rm and gvfs-move, resp.
Writing files onto the digi-cam through gvfs-gphoto2 bridge is by design not supported as indicated on my cam by gvfs-info:

Code: Select all

LANG=C gvfs-info gphoto2://[usb:001,006]/DCIM/100NIKON/
display name: 100NIKON
name: 100NIKON
type: directory
size:  0
uri: gphoto2://[usb:001,006]/DCIM/100NIKON
attributes:
  standard::type: 2
  standard::is-hidden: FALSE
  standard::name: 100NIKON
  standard::display-name: 100NIKON
  standard::icon: folder
  standard::content-type: inode/directory
  standard::size: 0
  standard::symbolic-icon: folder-symbolic
  id::filesystem: gphoto2:host=%5Busb%3A001%2C006%5D
  access::can-read: TRUE
  access::can-write: FALSE
  access::can-execute: TRUE
  access::can-delete: TRUE
  access::can-trash: FALSE
  access::can-rename: FALSE

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Mon May 07, 2018 6:46 pm
by rokytnji.1
Image

Just getting ready to upload my photos I took from my camera and insert them in my thread in another forum.
Good Luck guys.

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Sat May 19, 2018 7:51 am
by linwinux
fehlix wrote:
Mon May 07, 2018 8:13 am
Issue confirmed!
Delete and Cut is not working using Thunar with my Nikon digicam „mounted“ through gvfs-gphoto2.
Workaround: Instead of Cut‘n‘Paste or Delete moving files with Drag‘n‘Drop does work
and will remove file from the cam.
On terminal command-line delete and ‘move’ is working using gvfs-rm and gvfs-move, resp.
Writing files onto the digi-cam through gvfs-gphoto2 bridge is by design not supported as indicated on my cam by gvfs-info:

Code: Select all

LANG=C gvfs-info gphoto2://[usb:001,006]/DCIM/100NIKON/
display name: 100NIKON
name: 100NIKON
Drag 'n' Drop does not work either. Thunar won't allow me to drag the folder or the pictures themselves to another drive, partition, or stick. But I can drag and drop the files to existing bookmarks within Thunar as well as to my home directory. However, those files are just being copied. When all is said and done, the actual original files remain on the camera. At least that's how it works for me with Thunar. OS doesn't seem to matter since I can reproduce the identical behavior in both, MX as well as in Mint.

.

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Wed Jun 27, 2018 12:34 pm
by HessenZone
This issue must be related directly to whatever Thunar does to create digital camera access on (some or all?) digital cameras. With a USB stick I don't have this problem. Tested with external USB drive, no problem either. Then I tried my smartphone for retrieving files and that worked too. But with my digital camera I cannot retrieve/delete the photos by using Thunar. I hope somebody can fix this because I tried one of the camera-app solutions posted here, and it worked. However, the photo transfer was very very slow.

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Wed Jun 27, 2018 3:15 pm
by fehlix
HessenZone wrote:
Wed Jun 27, 2018 12:34 pm
...
But with my digital camera I cannot retrieve/delete the photos by using Thunar.
...
Welcome to the forum.
Have you tried moving with Drag'n'Drop as indicated in my post #21 above, which will delete the pictures-files on the digi-cam?

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Thu Jun 28, 2018 1:50 am
by HessenZone
Of course I tried drag 'n' drop since that would be something obvious to try. Then I tried the suggestion for using Caja and that did the trick. Since Caja does the job, this would indicate to me that something - but I don't know what, would need to be fixed in Thunar. Anyway, problem solved (for me).

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Thu Jun 28, 2018 3:04 am
by stsoh
try upgrade thunar 1.6.12 to 1.6.15 from mx test repo.

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Thu Jun 28, 2018 3:21 am
by HessenZone
Thanks, but I don't really see any point to add more time to something that is now working for me. Thunar will continue to be my default file manager but I will use Caja when I have to transfer image files from my camera. I also noticed that Caja has (must retrieve from repos) has built-in resize and rotate functions which are really practical, especially since my camera photos are normally much larger then what I use on the computer. Eventually I'll end up with the newer Thunar upgrade automatically anyway. I'll keep an eye out for the changes.

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Tue Jul 03, 2018 5:42 am
by JohnyWalter
A perfect example might be if I now decide to upload an attachment to this message, using the 'Upload attachment' and 'Choose File' underneath this very comment box, there is no way (as yet!) I can find my camera and it's folders in the window that opens.
Why is that?
I don't mind if it's a weird name like camera but I can't find THAT or anything like it anywhere either!
There is no "gphoto2" in the filesystem, so why is it telling me that is it's 'Path'?
Surely the operating system HAS to have a path to the device & it's folders.
Why can't I find it?

Re: Thunar - Camera - Very annoying missing privileges !!!

Posted: Tue Jul 03, 2018 5:52 am
by richb
You need a minimum of 5 posts to post attachments.