Welcome!
Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[Solved] Boot Device Not Found after Mx Linux 18 Dual Boot Install

User avatar
Head_on_a_Stick
Forum Regular
Forum Regular
Posts: 348
Joined: Sun Mar 17, 2019 3:37 pm

Re: Boot Device Not Found after Mx Linux 18 Dual Boot Install

#11

Post by Head_on_a_Stick » Wed May 15, 2019 1:00 pm

Check if GRUB is actually installed to the MBR:

Code: Select all

sudo dd if=/dev/sda bs=512 count=1 | xxd
Look for a "GRUB .Geom.Hard Disk.Read. Error" message in the output.

If it isn't there then you can try installing GRUB:

Code: Select all

sudo grub-install --target=i386-pc /dev/sda
You have an msdos partition table so you won't be able to try UEFI booting unless you add a BIOS boot partition (and run the UEFI grub-install command).

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 3990
Joined: Wed Apr 11, 2018 5:09 pm

Re: Boot Device Not Found after Mx Linux 18 Dual Boot Install

#12

Post by fehlix » Wed May 15, 2019 1:19 pm

That looks all ok. Might be you have tried it already.
So if you press the Fn key to show the BIOS-Boot menu, you still get
the BIOS error.
Now try again this:

1st from LiveBOOT MX run "MX Boot repair"
and choose reinstall grub and choose GRUB into MBR target of sda
close and open again "MX Boot repair"
and do the same again and reinstall grub and choose GRUB into PBR target of sda6
Now you have two GRUB-"MBR"s installed one within the real MBR of /dev/sda
and one into the partition boot record PBR of sda6.

Now try to reboot and select the HD from BIOS-menu to boot from.

If that still not solve the issue. Do this.
Open Gparted when running MX Live USB. And set the boot-flag on the first partition /dev/sda1.
(Right click on sda1 -> mark -> choose boot)
Reason: The boot flag is not used by grub but by the BIOS only,
that might simply a BIOS bug, as it should load the GRUB-MBR written to /dev/sda.

If that still not helps.
I suggest as mentioned above to boot from antiX19a with help of BOOT rescue menu,
into the installed MX Linux or run grub-rescue-scan.
And recreate grub from the installed running/chrooted MX Linux.
So any error messages when creating/installing grub might be help to
find out the reason.
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

luishector
Forum Novice
Forum  Novice
Posts: 8
Joined: Tue May 14, 2019 6:22 pm

Re: Boot Device Not Found after Mx Linux 18 Dual Boot Install

#13

Post by luishector » Wed May 15, 2019 2:01 pm

Thanks Head_on_a_stick,

I do get an error when I issue that command:

Code: Select all


luis@mx-laptop:~$ sudo dd if=/dev/sda bs=512 count=1|xxd
[sudo] password for luis: 
1+0 records in
1+0 records out
00000000: eb63 90d0 bc00 7c8e c08e d8be 007c bf00  .c....|......|..
00000010: 06b9 0002 fcf3 a450 681c 06cb fbb9 0400  .......Ph.......
00000020: bdbe 0780 7e00 007c 0b0f 850e 0183 c510  ....~..|........
00000030: e2f1 cd18 8856 0055 c646 1105 c646 1000  .....V.U.F...F..
00000040: b441 bbaa 55cd 135d 720f 81fb 55aa 7509  .A..U..]r...U.u.
00000050: f7c1 0100 7403 fe46 1066 0080 0100 0000  ....t..F.f......
00000060: 0000 0000 fffa 9090 f6c2 8074 05f6 c270  ...........t...p
00000070: 7402 b280 ea79 7c00 0031 c08e d88e d0bc  t....y|..1......
00000080: 0020 fba0 647c 3cff 7402 88c2 52bb 1704  . ..d|<.t...R...
512 bytes copied, 0.0287371 s, 17.8 kB/s00000090: f607 0374 06be 887d e817 01be 057c b441  ...t...}.....|.A

000000a0: bbaa 55cd 135a 5272 3d81 fb55 aa75 3783  ..U..ZRr=..U.u7.
000000b0: e101 7432 31c0 8944 0440 8844 ff89 4402  ..t21..D.@.D..D.
000000c0: c704 1000 668b 1e5c 7c66 895c 0866 8b1e  ....f..\|f.\.f..
000000d0: 607c 6689 5c0c c744 0600 70b4 42cd 1372  `|f.\..D..p.B..r
000000e0: 05bb 0070 eb76 b408 cd13 730d 5a84 d20f  ...p.v....s.Z...
000000f0: 83d0 00be 937d e982 0066 0fb6 c688 64ff  .....}...f....d.
00000100: 4066 8944 040f b6d1 c1e2 0288 e888 f440  @f.D...........@
00000110: 8944 080f b6c2 c0e8 0266 8904 66a1 607c  .D.......f..f.`|
00000120: 6609 c075 4e66 a15c 7c66 31d2 66f7 3488  f..uNf.\|f1.f.4.
00000130: d131 d266 f774 043b 4408 7d37 fec1 88c5  .1.f.t.;D.}7....
00000140: 30c0 c1e8 0208 c188 d05a 88c6 bb00 708e  0........Z....p.
00000150: c331 dbb8 0102 cd13 721e 8cc3 601e b900  .1......r...`...
00000160: 018e db31 f6bf 0080 8ec6 fcf3 a51f 61ff  ...1..........a.
00000170: 265a 7cbe 8e7d eb03 be9d 7de8 3400 bea2  &Z|..}....}.4...
00000180: 7de8 2e00 cd18 ebfe 4752 5542 2000 4765  }.......GRUB .Ge
00000190: 6f6d 0048 6172 6420 4469 736b 0052 6561  om.Hard Disk.Rea
000001a0: 6400 2045 7272 6f72 0d0a 00bb 0100 b40e  d. Error........
000001b0: cd10 ac3c 0075 f4c3 daad da0a 0000 0020  ...<.u......... 
000001c0: 2100 07df 130c 0008 0000 0020 0300 00df  !.......... ....
000001d0: 140c 07fe ffff 0028 0300 2a4f 7811 00fe  .......(..*Ox...
000001e0: ffff 05fe ffff fe77 7b11 02e0 bc28 0000  .......w{....(..
000001f0: 0000 0000 0000 0000 0000 0000 0000e 55aa  ..............U.
I'm not sure what this error means -- a quick web search seems to point back to a BIOS or HDD format issue?

I will proceed with the installation of GRUB into MBR of SDA and into PBR of sda6 as also suggested.

Luis

User avatar
Head_on_a_Stick
Forum Regular
Forum Regular
Posts: 348
Joined: Sun Mar 17, 2019 3:37 pm

Re: Boot Device Not Found after Mx Linux 18 Dual Boot Install

#14

Post by Head_on_a_Stick » Wed May 15, 2019 2:08 pm

luishector wrote:
Wed May 15, 2019 2:01 pm
I do get an error when I issue that command
That's not an error, it's just a message in the hexcode of the MBR that confirms the presence of the GRUB bootloader.

You don't need to install GRUB to /dev/sda because it's already there.

FWIW installing GRUB to the partition boot record is not recommended and may break easily.

luishector
Forum Novice
Forum  Novice
Posts: 8
Joined: Tue May 14, 2019 6:22 pm

Re: Boot Device Not Found after Mx Linux 18 Dual Boot Install

#15

Post by luishector » Wed May 15, 2019 2:25 pm

Gotcha,

AFAIK it was changing the boot flag on SDA1 is what fixed things. Should I remove grub from the PBR?

Thanks again !

Luis

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 3990
Joined: Wed Apr 11, 2018 5:09 pm

Re: Boot Device Not Found after Mx Linux 18 Dual Boot Install

#16

Post by fehlix » Wed May 15, 2019 2:38 pm

luishector wrote:
Wed May 15, 2019 2:25 pm
AFAIK it was changing the boot flag on SDA1 is what fixed things. Should I remove grub from the PBR?
Well, you found a BIOS bug. :eek:
So you fixed the Boot-show stopper by setting the flag on the first partition to make BIOS happy. :number1:
Grub's boot-record can reside on MBR (thats the on /dev/sda) and an PBR /dev/sda6.
From BIOS you can only boot using the MBR.
But, It doesn't hurt to have it on a PBR, even if you cannot use it directly.
The reason why GRUB does not recomment to user PBR for it's boot-record to use,
is that cannot use it embedded core-image code but must search the grub's core image with the filesystem using "bios" functions and block lists, and this is not very robust, as you can imagine.
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

luishector
Forum Novice
Forum  Novice
Posts: 8
Joined: Tue May 14, 2019 6:22 pm

Re: [Solved] Boot Device Not Found after Mx Linux 18 Dual Boot Install

#17

Post by luishector » Wed May 15, 2019 5:35 pm

Gotcha. Thanks everyone!

MX Linux is giving this old 8-year old machine some new life!

Luis

Post Reply

Return to “Installation”