Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] MX Installer problem - autoinstall creates 72.5 GB SWAP

User avatar
Fibogacci
Forum Regular
Forum Regular
Posts: 120
Joined: Sun Dec 30, 2018 4:19 pm

[SOLVED] MX Installer problem - autoinstall creates 72.5 GB SWAP

#1

Post by Fibogacci » Sun May 12, 2019 9:43 pm

I have a problem with MX Installer and option: Auto-install using entire disk

MX Linux 18.2 32 bit
inxi -F screen below
Image

MX Installer breaks the installation, it cannot create partitions.

As you can see in video below (after 1:00 minute), GParted shows two swap partitions, one of them is 72.50 GiB.
https://www.youtube.com/watch?v=OWDvzFNObpA

Image

What could cause such a behaviour?

Thank you for any suggestions.
Last edited by Fibogacci on Mon May 13, 2019 8:13 pm, edited 1 time in total.
MX-18 Continuum x86_64: laptop Dell Inspiron N7110, Intel Core i5-2410M @ 2.900GHz, 4GB RAM, Kernel: 4.19, DE: Xfce
---
Telegram: @Fibogacci
Telegram group: http://t.me/mxlinuxpopolsku

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 9941
Joined: Wed Jul 12, 2006 1:42 am

Re: MX Installer problem - autoinstall creates 72.5 GB SWAP

#2

Post by Adrian » Sun May 12, 2019 9:59 pm

Can you please try this "beta" installer, see if has the same problem?
https://github.com/MX-Linux/gazelle-ins ... _amd64.deb

In Live environment, click on the link and install it with Gdebi (or download and install with dpkg -i)

EDIT: updated link to latest beta

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 11559
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX Installer problem - autoinstall creates 72.5 GB SWAP

#3

Post by dolphin_oracle » Sun May 12, 2019 10:08 pm

The op's problem is a new one to me.

I suggest using Gparted to make the partitiinstaller and use the custom install.

Also I'm curious...are those IDE drives or SATA drives?
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18
lenovo s21e - MX-18, antiX-17.3.1 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
AK-47
Forum Regular
Forum Regular
Posts: 210
Joined: Sun Mar 24, 2019 7:04 pm

Re: MX Installer problem - autoinstall creates 72.5 GB SWAP

#4

Post by AK-47 » Sun May 12, 2019 11:07 pm

Well at least you won't need to upgrade the RAM again.

Can you please run the installer Adrian mentioned above, and post the terminal output? Use: sudo -E minstall > installation.txt
There's a new release about to come out, and if there is a bug I may be able to fix it.
MX Linux 18.3 - Panasonic CF-30 - 3GB RAM - 160GB HDD - Core 2 Duo

User avatar
JayM
Forum Guide
Forum Guide
Posts: 1073
Joined: Tue Jan 08, 2019 4:47 am

Re: MX Installer problem - autoinstall creates 72.5 GB SWAP

#5

Post by JayM » Sun May 12, 2019 11:15 pm

dolphin_oracle wrote:
Sun May 12, 2019 10:08 pm
Also I'm curious...are those IDE drives or SATA drives?
I think the WD800JB is an 80GB WD Caviar, IDE/ATAPI.
https://www.cnet.com/products/wd-blue-w ... 00-series/
The others are probably USB pen drives.
New users: Please read this first, and don't forget to add system and hardware information (Quick System Info) to posts!

bobbee
Forum Novice
Forum  Novice
Posts: 36
Joined: Sun Apr 07, 2019 7:17 pm

Re: MX Installer problem - autoinstall creates 72.5 GB SWAP

#6

Post by bobbee » Sun May 12, 2019 11:24 pm

It doesn't look like there is a partition for the OS.

I wonder if you could just change the flags on sda1 so it is not labeled as swap.

What does it do when it boots?

I like to set my partitions and have never used the auto-install.

User avatar
Fibogacci
Forum Regular
Forum Regular
Posts: 120
Joined: Sun Dec 30, 2018 4:19 pm

Re: MX Installer problem - autoinstall creates 72.5 GB SWAP

#7

Post by Fibogacci » Mon May 13, 2019 4:17 am

Ok, thank you for advice, I will try this beta installer this evening (and post here terminal output).

The drive is WD800 (WD Caviar) Western Digital 80.0 GB - ATA. Drive is ok, it was tested with GSmartControl - all tests run fine.

Computer has (in specification) 512 MB RAM, but inxi -F shows only 367 MB.

Other USB drive (pendrive) - 1 GB with SWAP (partition)

Another USB is MX 18.2 32 bit Live-USB (remastered).

I've tested WD800 with gpt and ms-dos partion table - both the same results - 72.5 GB SWAP.

Also, it is remastered MX 18.2 Live-USB (only current updates and AnyDesk and TeamViewer installed), so I'll try installing (for test) with 18.2 ISO without remastering as well.

Thank you.
MX-18 Continuum x86_64: laptop Dell Inspiron N7110, Intel Core i5-2410M @ 2.900GHz, 4GB RAM, Kernel: 4.19, DE: Xfce
---
Telegram: @Fibogacci
Telegram group: http://t.me/mxlinuxpopolsku

User avatar
Fibogacci
Forum Regular
Forum Regular
Posts: 120
Joined: Sun Dec 30, 2018 4:19 pm

Re: MX Installer problem - autoinstall creates 72.5 GB SWAP

#8

Post by Fibogacci » Mon May 13, 2019 8:13 pm

Ok, I think I can say the problem is solved. Actually it is maybe not even a problem - well, bad luck.

TL;DR
I think MX Installer is fine. The possible problem/cause was my specific (rare, low RAM) configuration with 1GB SWAP partition on USB.

Actually, I didn't test suggested 'beta' version of installer.

Explanation:

The possible cause could be initially (I suppose) my USB drive with 1 GB SWAP partition.

When Minstall starts formating partitions, at the beginning there is swapoff process. Because this exact computer had only 367 MB physical RAM and AnyDesk was running (I don't remember, but RAM + SWAP could have together 400-500 MB or more) - something went wrong.

Minstall formated WD 80GB drive and there were some labels (probably in Partition Table).

Later in cfdisk I saw:
Filesystem LABEL: swap
Filesystem: SWAP
Mountpoint: SWAP
(or something like that)

Reformatting partition (removing, changing etc.) in GParted didn't help at the beginning. There were still such labels, so next minstall and formatting gave the same results (72.5 GB SWAP).

I don't know what worked, but I did many things and trials (in GParted, cfdisk, changing UUID, reformatting, removing swap entry from /etc/fstab etc.) - at the end there was WD 80GB drive without any labels.

Then I tested minstall (installation on hard drive) with two different MX 18.2 Live-USB - with option A) 1 GB SWAP partition on USB, and option B) without that 1GB SWAP on USB - everything went ok. (about 270-280 MB RAM was enough for running installation and auto-formatting, and after a few seconds freshly created SWAP was started) (and I didn't run AnyDesk this time)

To sum up: average, new user should be fine with auto-install. My configuration is really rare (low RAM plus SWAP on USB), experimental and unusual. At the moment I cannot repeat install with similar result (error) so...

Anyway, I'll try later that 'beta' installer to see how it works.

Thank you.
MX-18 Continuum x86_64: laptop Dell Inspiron N7110, Intel Core i5-2410M @ 2.900GHz, 4GB RAM, Kernel: 4.19, DE: Xfce
---
Telegram: @Fibogacci
Telegram group: http://t.me/mxlinuxpopolsku

User avatar
AK-47
Forum Regular
Forum Regular
Posts: 210
Joined: Sun Mar 24, 2019 7:04 pm

Re: MX Installer problem - autoinstall creates 72.5 GB SWAP

#9

Post by AK-47 » Mon May 13, 2019 9:58 pm

Fibogacci, good to hear you resolved the problem.
A new "Release Candidate" installer has been made since then:

64-bit: https://github.com/MX-Linux/gazelle-ins ... _amd64.deb
32-bit: https://github.com/MX-Linux/gazelle-ins ... 8_i386.deb

In this new installer the "swapoff -a" occurs as soon as you click Next the first time (on the terms page), so relevant issues will be picked up way before the install process starts.
I thought about disabling it just for the drive it was being installed on, but that would mean you'd likely end up in the same mess because this would have to happen right before the partitioning stage after the disk selections are made.
MX Linux 18.3 - Panasonic CF-30 - 3GB RAM - 160GB HDD - Core 2 Duo

User avatar
Fibogacci
Forum Regular
Forum Regular
Posts: 120
Joined: Sun Dec 30, 2018 4:19 pm

Re: MX Installer problem - autoinstall creates 72.5 GB SWAP

#10

Post by Fibogacci » Tue May 14, 2019 8:24 am

AK-47 wrote:
Mon May 13, 2019 9:58 pm
Fibogacci, good to hear you resolved the problem.
A new "Release Candidate" installer has been made since then:

64-bit: https://github.com/MX-Linux/gazelle-ins ... _amd64.deb
32-bit: https://github.com/MX-Linux/gazelle-ins ... 8_i386.deb

In this new installer the "swapoff -a" occurs as soon as you click Next the first time (on the terms page), so relevant issues will be picked up way before the install process starts.
I thought about disabling it just for the drive it was being installed on, but that would mean you'd likely end up in the same mess because this would have to happen right before the partitioning stage after the disk selections are made.
Ok, thank you, I'll use these two and test with installations.

Actually, I did try another installation and manage to install without initial SWAP on USB, with some unneeded services/processes killed, with AnyDesk running and transmitting screen to another computer - and maximum RAM usage was from 270 to 275 MB (and then SWAP was created on hard drive by minstall, so computer could use it).

I need that AnyDesk running during installation(s) because I'm making some screencasts/tutorials from these installations, so another computer is recording the process.

By the way, it's fascinating, spectacular and beautiful that MX can be installed in GUI with such a low RAM consumption ;) It's real pleasure to observe that process.
MX-18 Continuum x86_64: laptop Dell Inspiron N7110, Intel Core i5-2410M @ 2.900GHz, 4GB RAM, Kernel: 4.19, DE: Xfce
---
Telegram: @Fibogacci
Telegram group: http://t.me/mxlinuxpopolsku

Post Reply

Return to “Installation”