The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Boot from USB stick fails


Re: Boot from USB stick fails


Post by male » Thu Jan 31, 2019 11:30 am

fehlix wrote:
male wrote:Also here only the dd - command is used and no, the stick does not have to be formatted, because dd overwrites EVERYTHING. ;)

It might happen that old. residual partiontable informationon on the stick can confuse linux, when it tries to identify the partitions to mount. As the size of the ISO is ofter smaller than the stick, only the number of bytes of the size of the ISO gets written onto the stick.
Sorry, I can't leave it like this!

@kerber used this command:

Code: Select all

dd if=MX-18_x64.iso of=/dev/sdc bs=4M && sync
there is nothing wrong with that. I've been putting my ISO's on the stick with dd for 10 years.
I never had any problems with that.

This gives the impression that this dd command is responsible for changing the partition table of the stick. The partition table, however, would with:

Code: Select all

dd if=/dev/zero of=/dev/sdc bs=512 count=1
dd if=/dev/zero of=/dev/sdc

"Known is...", which stands on the front of the recommended tools MX and dd is in the back.

Maybe it's just the other way around: The use of these "tools" and the recommendation to edit the partition table of the sticks leads exactly to the mentioned "Known is...". Problems. :p

Forum Novice
Forum  Novice
Posts: 7
Joined: Sun Dec 06, 2015 10:29 am

Re: Boot from USB stick fails


Post by kerber » Wed Feb 06, 2019 1:56 pm

Thank's to everybody who gave help.

I first downloaded again the iso of MX-18. This time I downloaded MX-18_January_x64.iso from http://ftp.lip6.fr/pub/linux/distributi ... Snapshots/. I checked its md5sum and it was OK. I wrote a usb stick with the dd command. Then I tried to check it as someone said:

Code: Select all

cat *.md5 | md5sum -c
I got:

Code: Select all

md5sum: 'entrée standard' : n'a trouvé aucune ligne de somme de contrôle correctement formatée selon MD5
This means: no good
However I tried to boot on this usbstick and of course it failed.

Then I went back to the iso image I had previoulsy downloaded. I check once more that its md5sum was good. I wrote it again on the usbstick and ckecked it as adviced;

Code: Select all

cat *.md5 | md5sum -c
initrd.gz: Réussi
linuxfs: Réussi
vmlinuz: Réussi
(Réussi = Successful)
And then my PC successfully booted on the usbstick. Live session of MX-18 was running and now MX-18 is installed on the HD.

I suppose that my usbstick is somewhat defficient. Sometime the iso image is correctly writen with dd, sometime it's not.

Thank you again for encouraging me to persevere.

User avatar
Forum Veteran
Forum Veteran
Posts: 4562
Joined: Wed Apr 11, 2018 5:09 pm

Re: Boot from USB stick fails


Post by fehlix » Wed Feb 06, 2019 2:05 pm

male wrote:
Thu Jan 31, 2019 11:30 am
dd if=/dev/zero of=/dev/sdc bs=512 count=1
GPT partition table information is also located in some more places like at the end of the stick.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Installation”