Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Could not open \EFI\BOOT\fallback.efi": 14 [SOLVED]

User avatar
Sparky
Forum Regular
Forum Regular
Posts: 471
Joined: Sun Dec 23, 2018 7:07 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#21

Post by Sparky » Wed Jan 23, 2019 4:18 pm

I have disabled fast boot, secure boot and EFI secure mode. I'll try to make the changes you provided
MX Linux Asus F552, 12GB RAM, 1TB HDD

User avatar
Sparky
Forum Regular
Forum Regular
Posts: 471
Joined: Sun Dec 23, 2018 7:07 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#22

Post by Sparky » Wed Jan 23, 2019 4:32 pm

fehlix wrote:
Wed Jan 23, 2019 4:16 pm

within that USB stick copy from
/EFI/BOOT/grubx64.efi
to
/EFI/BOOT/fallback.efi
If that's not working either.
They are at the same place? Do you mean copy somewhere else?
MX Linux Asus F552, 12GB RAM, 1TB HDD

User avatar
Sparky
Forum Regular
Forum Regular
Posts: 471
Joined: Sun Dec 23, 2018 7:07 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#23

Post by Sparky » Wed Jan 23, 2019 4:36 pm

Ok added fallback, now it's back to the frozen cursor.
MX Linux Asus F552, 12GB RAM, 1TB HDD

User avatar
fehlix
Developer
Posts: 4630
Joined: Wed Apr 11, 2018 5:09 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#24

Post by fehlix » Wed Jan 23, 2019 4:48 pm

Sparky wrote:
Wed Jan 23, 2019 4:36 pm
Ok added fallback, now it's back to the frozen cursor.
OK, think we may try to disable any graphik mode in grub ...
will send a graphik less grub.cfg ... :snail: ... :turtle: ... be back soon :snail:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
fehlix
Developer
Posts: 4630
Joined: Wed Apr 11, 2018 5:09 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#25

Post by fehlix » Wed Jan 23, 2019 5:15 pm

fehlix wrote:
Wed Jan 23, 2019 4:48 pm
Sparky wrote:
Wed Jan 23, 2019 4:36 pm
Ok added fallback, now it's back to the frozen cursor.
OK, think we may try to disable any graphik mode in grub ...
will send a graphik less grub.cfg ... :snail: ... :turtle: ... be back soon :snail:
Ok let's try a minimal graphik less grub-menu:
Please do this on the USB stick
copy existing /boot/grub/grub.cfg
to /boot/grub/grub.cfg.orig
and edit /boot/grub/grub.cfg
and replace the content with this:

Code: Select all

set timeout=60
menu_color_normal=white/black
menu_color_highlight=yellow/light-gray
set default=1
menuentry " MX-18 x64 (Dec 20, 2018)" {
linux /antiX/vmlinuz quiet
initrd /antiX/initrd.gz
}
menuentry " MX-18 x64 Customize Boot (text menus)" {
linux /antiX/vmlinuz quiet menus
initrd /antiX/initrd.gz
}
submenu ">>> Advanced Options for MX-18 x64 <<<" {
menuentry " MX-18 x64 Failsafe" {
linux /antiX/vmlinuz quiet nomodeset failsafe
initrd /antiX/initrd.gz
}
menuentry " MX-18 x64 (1024x768)" {
linux /antiX/vmlinuz quiet
initrd /antiX/initrd.gz
}
menuentry " Power Off" --hotkey=P { halt}
menuentry " Reboot"  --hotkey=R {reboot}
}
menuentry " Memory Test (64-bit UEFI)" {chainloader /boot/uefi-mt/mtest-64.efi}
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
dolphin_oracle
Developer
Posts: 12199
Joined: Sun Dec 16, 2007 1:17 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#26

Post by dolphin_oracle » Wed Jan 23, 2019 5:17 pm

fehlix wrote:
Wed Jan 23, 2019 4:16 pm
Sparky wrote:
Wed Jan 23, 2019 4:04 pm
Tried rufus, default fat 32. Unfortunately it is back to the same error as the subject line.
within that USB stick copy from
/EFI/BOOT/grubx64.efi
to
/EFI/BOOT/fallback.efi
If that's not working either.
I assume we might need disable graphic mode with grub itself.
BTW: have you disabled EFI secure mode?
good suggestion, I've done this in the past with some success.

and secure boot shouldn't matter for live, but I guess stranger things have happened.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Sparky
Forum Regular
Forum Regular
Posts: 471
Joined: Sun Dec 23, 2018 7:07 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#27

Post by Sparky » Thu Jan 24, 2019 3:17 am

fehlix wrote:
Wed Jan 23, 2019 5:15 pm
fehlix wrote:
Wed Jan 23, 2019 4:48 pm
Sparky wrote:
Wed Jan 23, 2019 4:36 pm
Ok added fallback, now it's back to the frozen cursor.
OK, think we may try to disable any graphik mode in grub ...
will send a graphik less grub.cfg ... :snail: ... :turtle: ... be back soon :snail:
Ok let's try a minimal graphik less grub-menu:
Please do this on the USB stick

linux /antiX/vmlinuz quiet nomodeset failsafe
initrd /antiX/initrd.gz
}
menuentry " MX-18 x64 (1024x768)" {
linux /antiX/vmlinuz quiet
initrd /antiX/initrd.gz
}
menuentry " Power Off" --hotkey=P { halt}
menuentry " Reboot" --hotkey=R {reboot}
}
menuentry " Memory Test (64-bit UEFI)" {chainloader /boot/uefi-mt/mtest-64.efi}
[/code]
I'm going to try it now. My fear is that if the Live USB doesn't work by default without all these changes, how will it install correctly?
Isn't the Live USB used to see if a distro works on a certain computer?
MX Linux Asus F552, 12GB RAM, 1TB HDD

User avatar
Sparky
Forum Regular
Forum Regular
Posts: 471
Joined: Sun Dec 23, 2018 7:07 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#28

Post by Sparky » Thu Jan 24, 2019 3:26 am

I tried it, I got the frozen cursor. I think this machine has a problem with Debian, it works on Ubuntu distros. Very strange.
MX Linux Asus F552, 12GB RAM, 1TB HDD

User avatar
geo3geo
Forum Novice
Forum  Novice
Posts: 1
Joined: Thu Jan 24, 2019 11:19 am

Re: Could not open \EFI\BOOT\fallback.efi": 14

#29

Post by geo3geo » Thu Jan 24, 2019 11:23 am

There's an identical problem in a thread at
https://www.antixforum.com/forums/topic ... liveantix/
May be some ideas worth investigation.
Geo

User avatar
fehlix
Developer
Posts: 4630
Joined: Wed Apr 11, 2018 5:09 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#30

Post by fehlix » Thu Jan 24, 2019 11:25 am

Sparky wrote:
Thu Jan 24, 2019 3:26 am
I tried it, I got the frozen cursor. I think this machine has a problem with Debian, it works on Ubuntu distros. Very strange.
Would you mind to show some system info from this laptop,
when you booted from Ubuntu or Mint:
like

Code: Select all

inxi -Fxz

Code: Select all

lsblk -f

Code: Select all

sudo fdisk -l
We will need to fix this grub. I'll do some excersises to see whether I can provide a workarround. stay tuned ... :turtle:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Installation”