Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Could not open \EFI\BOOT\fallback.efi": 14 [SOLVED]

User avatar
Buck Fankers
Forum Regular
Forum Regular
Posts: 403
Joined: Sat Mar 10, 2018 9:06 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#51

Post by Buck Fankers » Fri Jan 25, 2019 12:41 pm

fehlix wrote:
Fri Jan 25, 2019 12:35 pm
Buck Fankers wrote:
Fri Jan 25, 2019 12:23 pm
I have a special case so it is not important in this case.
Can you boot from an usb-stick at all? Or just not from MX LiveUSB stick?
Perhabs open a new thread and explain your situation a bit more.
Thanks
I wrote few posts above and the only reason I did is, in case if it would help (It was a long shot anyway) with current problem. Which you already solved, congrats, so all is fine. I did find a work around for my specific and pretty unique case. I just though it may be related to this issue which now I see, it is not, since problem is solved. :happy:

User avatar
BitJam
Forum Veteran
Forum Veteran
Posts: 3345
Joined: Sat Aug 22, 2009 11:36 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#52

Post by BitJam » Fri Jan 25, 2019 2:27 pm

Sparky wrote:
Fri Jan 25, 2019 5:39 am
Well it worked! I have no idea what BitJam did, but thank you. any possibility to see MX 18 work this way?
Thanks for testing!

I can try to make an xdelta3 patch for you to add the fix to your current MX iso file. I was unable to make a patch for the antiX iso I made so I had to upload the whole thing. I imagine you are using MX-18_x64.iso. The patch would be for a specific iso file.

Also, if you have one more usb-stick, you might want to run live-usb-maker (or the GUI version) in antiX. To clone your "dd" live-usb and create a "real" live-usb that has persistence and all that Jazz. Then it would be easy to copy the MX .iso file to the "real" live-usb and run xdelta3 there. But IIUC, you can also run xdelta3 directly on Windows.
Will I cry when it's all over?
When I die will I see Heaven?

User avatar
BitJam
Forum Veteran
Forum Veteran
Posts: 3345
Joined: Sat Aug 22, 2009 11:36 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#53

Post by BitJam » Fri Jan 25, 2019 2:49 pm

Okay, I uploaded an MX-18b_x64.xd3 xdelta3 patch to fix the MX-18_x64.iso file. I uploaded it to the same Dropbox directory: antiX-17.3.1b_x64-base

On Linux you would run it like this:

Code: Select all

xdelta3 -f -d -s MX-18_x64.iso MX-18b_x64.xd3 MX-18b_x64.iso
The xdelta3 program starts with the original iso file, applies the .xd3 patch to it and creates the new file MX-18b_x64.iso. I don't know how xdelta3 is used on Windows but I imagine the same 3 files would need to be specified somehow.

edit: MX-18b2 --> MX-18b
Will I cry when it's all over?
When I die will I see Heaven?

User avatar
Sparky
Forum Regular
Forum Regular
Posts: 467
Joined: Sun Dec 23, 2018 7:07 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#54

Post by Sparky » Wed Jan 30, 2019 5:47 pm

Thank you very much! MX is running like a charm now, thanks!
MX Linux Asus F552, 12GB RAM, 1TB HDD

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 12136
Joined: Sun Dec 16, 2007 1:17 pm

Re: Could not open \EFI\BOOT\fallback.efi": 14

#55

Post by dolphin_oracle » Wed Jan 30, 2019 6:41 pm

Sparky wrote:
Wed Jan 30, 2019 5:47 pm
Thank you very much! MX is running like a charm now, thanks!
thanks for sticking with the testing!

BitJam and fehlix have already sent us some changes and we've incorporated those into snapshot, so hopefully the Feb snapshot will be less problematic for folks.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

miks
Forum Novice
Forum  Novice
Posts: 21
Joined: Wed Apr 13, 2016 6:01 am

Re: Could not open \EFI\BOOT\fallback.efi": 14 [SOLVED]

#56

Post by miks » Sun Feb 03, 2019 12:08 pm

I just had the same problem with a new Zenbook UX433. Found this thread and updated the iso with the patch and it booted no problem, so thanks for that. Posting this from the zenbook running the live usb - unfortunately, no sound, which I thought was sorted by running the 4.19 kernel, which this has. I will install and see if the sound works for the installed version and start a new thread if I can't sort it out.....

Post Reply

Return to “Installation”