Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

dual boot: (Windows + MX)

ada
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Jan 14, 2019 7:55 pm

dual boot: (Windows + MX)

#1

Post by ada » Wed Jan 16, 2019 7:04 pm

Hi,

Ok, I have managed to install the MX.18 as a dual boot.

Here is my NVME drive partition layout:

/dev/nvme0n1p1: LABEL="SYSTEM" UUID="900F-AF6D" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="294699d8-a806-45cd-804c-0198b5efb79a"
/dev/nvme0n1p3: UUID="B2401C64401C3199" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="f9055ab2-ad38-44f7-bcc5-cb5ca55b199e"
/dev/nvme0n1p4: LABEL="Windows RE tools" UUID="6C8C10C48C108AAA" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="fd57ba6a-5e7f-455a-987e-2e34aff9b545"
/dev/nvme0n1p5: UUID="7a699ba3-e360-4cb3-b627-2000c92e41cd" TYPE="swap" PARTUUID="1dd554a0-2249-864d-93e2-d387288e3094"
/dev/nvme0n1p6: LABEL="rootMX18" UUID="296ad35f-293f-46dc-b408-1a48c572d950" TYPE="ext4" PARTUUID="1ab08106-3298-d842-aaf9-1050b1b4be54"
/dev/nvme0n1: PTUUID="d6b83766-7ae4-4bbf-9beb-e07079fa218d" PTTYPE="gpt"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="d35a991a-c716-4d3c-9877-d38474d5de25"

As you see /dev/nvme0n1p6 is my root partition /dev/nvme0n1p5 is swap.
The EFS is /dev/nvme0n1p1

The installer forced me to select 'root partition' for boot instead of /dev/nvme0n1p1.

I rebooted after the install and the grub screen showed me the MX options. But the booting drops to initramfs shell.

I see the following two errors before the initramfs shell.

nouveau 0000:65:00.0 secboot:error during falcon reset -110
nouveau 0000:65:00.0 gr: init failed, -110

-----------------------------------

Busybox v1.221...

Gaveup waiting for root file system device common problems
- boot args
- check rootdealy
-Missing modules
ALERT UUID=296ad35f-293f-46dc-b408-1a48c572d950 does not exist.

Dropping to shell.

In my experiences with other linux distros (Arch), I have selected EFI partition for boot. But MX installer forced me to select root partition. Is that an issue here?

Any help/pointers?

-Ada

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 4563
Joined: Wed Apr 11, 2018 5:09 pm

Re: dual boot: (Windows + MX)

#2

Post by fehlix » Wed Jan 16, 2019 9:14 pm

ada wrote:
Wed Jan 16, 2019 7:04 pm
nouveau 0000:65:00.0 secboot:error during falcon reset -110
Have you turned off secure boot within UEFI system setup.
Btw, installing / mounting boot into the ESP partion might not a good idea,
most systems require a /boot/efi mount point to the ESP when e.g. upadate of nvram is needed.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

ada
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Jan 14, 2019 7:55 pm

Re: dual boot: (Windows + MX)

#3

Post by ada » Wed Jan 16, 2019 9:52 pm

secure boot is turned off.

It could be an issue with nvme drive not being recognized, because when I do 'blkid' on the initramfs prompt, I do not see anything-- not even a single partition is listed.

Do I need to load any required modules for the loader to see nvme drive?

caprea
Forum Regular
Forum Regular
Posts: 186
Joined: Sat Aug 23, 2014 7:01 am

Re: dual boot: (Windows + MX)

#4

Post by caprea » Wed Jan 16, 2019 10:06 pm


ada
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Jan 14, 2019 7:55 pm

Re: dual boot: (Windows + MX)

#5

Post by ada » Wed Jan 16, 2019 10:29 pm

I just tried it but of no help.

The installer from liveUSB could see NVMe drive properly and the installation process went smooth. The problem occurs on reboot. I see the MX grub screen and I get the initramfs prompt once I select the os.

The grub bootloader is not seeing the nvme drive for some reason. I modified kernel parameters by pressing 'e' on grub menu options, but of no improvement.

Thank you caprea.
-Ada

User avatar
BitJam
Forum Veteran
Forum Veteran
Posts: 3345
Joined: Sat Aug 22, 2009 11:36 pm

Re: dual boot: (Windows + MX)

#6

Post by BitJam » Thu Jan 17, 2019 1:50 am

Note: maybe someone else has a better/easier idea.

TL;DR: you may have needed "nvme" in the list in the file /etc/initramfs-tools/modules before installing.

f the nouveau message is a red herring then the problem may be that your initrd lacks the kernel driver needed to access your NVMe. The missing module is probably "nvme".

Diagnose from busybox prompt
I suggest you try running "dmesg" or "dmesg | less" at the busybox prompt to see if something terrible has happened.

At the busybox prompt you could try running "lsmod" to see if the nvme module is loaded. Or

Code: Select all

find /lib/modules -name "nvme*"
You want to see something like:

Code: Select all

lib/modules/4.19.0-1-amd64/kernel/drivers/nvme
lib/modules/4.19.0-1-amd64/kernel/drivers/nvme/host/nvme.ko
lib/modules/4.19.0-1-amd64/kernel/drivers/nvme/host/nvme-core.ko
If it is not there then this is the problem. If it is there and not loaded then you could try loading it and see if your nvme devices show up. But we can't fix the problem from here.

Diagnose and fix from live
FWIW, You may be able to diagnose this problem and fix it from the live system (but a recent change by Debian may render their initramfs file inscrutable) Boot live, make sure the installed system is mounted or mount it if it isn't. The file you want is something like /boot/initrd.img-4.19.0-1-amd64 but you might want to use a * or tab complete. It is possible that Debian made it difficult to read this file. Use the "file" command on it. If it says ASCII cpio archive then we cannot open it. If it says "gzip compressed data ..." then we are fine.

You can open up the file with:

Code: Select all

/live/bin/unpack-initrd -f /boot/initrd.img-*
This will/should create a directory initrd/ with the contents of that file. Use this command to look for the nvme modules:

Code: Select all

find initrd/lib/modules -name "nvme*"
You want to see something like:

Code: Select all

initrd/lib/modules/4.19.0-1-amd64/kernel/drivers/nvme
initrd/lib/modules/4.19.0-1-amd64/kernel/drivers/nvme/host/nvme.ko
initrd/lib/modules/4.19.0-1-amd64/kernel/drivers/nvme/host/nvme-core.ko
If they are not there then we can copy them in and repack the initrd and you should be good to go.

Fix with a re-install or a chroot
Another approach would be to either re-install or chroot into your installed system. If re-installing, do the edit before you run the installer. Edit the file /etc/initramfs-tools/modules and add "nvme" to the list. If you chrooted into the installed system then run "sudo update-initramfs after you edit.
Will I cry when it's all over?
When I die will I see Heaven?

ada
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Jan 14, 2019 7:55 pm

Re: dual boot: (Windows + MX)

#7

Post by ada » Thu Jan 17, 2019 4:30 pm

BitJam,

Code: Select all

find /lib/modules -name "nvme*"
The output of the above command DID find all the nvme files you have listed.

I did follow your fix using 'chroot' method. But there is no improvement.

Code: Select all

cat /proc/cmdline
on initramfs prompt show that nvme and nvme_core modules. But still there is no improvement. The /dev directory doesn't have nvme directory listed. I get the same error again: ALTERT! UUID=xxxxx doesn't exist. Dropping to shell.

At the point of giving up, I tried to install on a different SSD (not NVMe drive). The installation went smooth and rebooted. Voila everything works

So, I compared the dmesg output on these two installtions (nvme vs SSD).

SSD/working version:

Code: Select all

[    3.860639] hid-generic 0003:05AC:020B.0004: input,hidraw3: USB HID v1.10 Device [Mitsumi Electric Apple Extended USB Keyboard] on usb-0000:00:14.0-10.2.3/input1
[    3.897023] nvme nvme0: missing or invalid SUBNQN field.
[    3.897071] nvme nvme0: Shutdown timeout set to 8 seconds
[    3.931089]  nvme0n1: p1 p2 p3 p4 p5 p6
[    3.986544] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:64/0000:64:00.0/0000:65:00.1/sound/card1/input16
[    3.986668] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:64/0000:64:00.0/0000:65:00.1/sound/card1/input17
[    3.986780] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:64/0000:64:00.0/0000:65:00.1/sound/card1/input18
[    3.986909] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:64/0000:64:00.0/0000:65:00.1/sound/card1/input19
[    6.233861] Adding 16777212k swap on /dev/sdb1.  Priority:-2 extents:1 across:16777212k SSFS
[    6.262743] EXT4-fs (sdb2): re-mounted. Opts: (null)
[    6.492035] device-mapper: uevent: version 1.0.3
[    6.492123] device-mapper: ioctl: 4.39.0-ioctl (2018-04-03) initialised: dm-devel@redhat.com
[    6.690350] lp: driver loaded but no devices found
[    6.711629] ppdev: user-space parallel port driver
[    6.757272] loop: module loaded 
[    6.871572] random: crng init done
NVMe/non-working version
0117191216(2).jpg
As you see, after the "hid-generic" at 3.831454 there was around 30 seconds gap before "random: crng init done"

But in the working version, the boot process continues to find nvme drive as expected.
What is going on here?

Thank you
Ada
You do not have the required permissions to view the files attached to this post.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 12136
Joined: Sun Dec 16, 2007 1:17 pm

Re: dual boot: (Windows + MX)

#8

Post by dolphin_oracle » Thu Jan 17, 2019 4:43 pm

I suggest boot back with the live usb and check the UUID of the nvme partition that should be root partition and compare to the one that the system can't find.

Code: Select all

 UUID=296ad35f-293f-46dc-b408-1a48c572d950
just to make sure there isn't a problem with an incorrect UUID first.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

ada
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Jan 14, 2019 7:55 pm

Re: dual boot: (Windows + MX)

#9

Post by ada » Thu Jan 17, 2019 4:51 pm

I think I found the solution. The vmd module is missing.

I could boot from NVMe when I disabled Intel VMD in BIOS.

Please take a look at this:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=891482

Now how do I add the vmd module? I did see that it is available in /lib/modules directory.
Will it be sufficient to add vmd in /etc/initramfs-tools/modules, rebuild initramfs with 'update-initramfs -u -k all'.

Do I need to copy vmd.ko to /etc/modules-load.d/ ?

Please suggest the correct way to do this.

Thank you
-Ada

User avatar
BitJam
Forum Veteran
Forum Veteran
Posts: 3345
Joined: Sat Aug 22, 2009 11:36 pm

Re: dual boot: (Windows + MX)

#10

Post by BitJam » Thu Jan 17, 2019 5:01 pm

ada wrote:
Thu Jan 17, 2019 4:30 pm
As you see, after the "hid-generic" at 3.831454 there was around 30 seconds gap before "random: crng init done"

But in the working version, the boot process continues to find nvme drive as expected.
What is going on here?

Thank you
Ada
Thanks for the info! I'm glad you got it to work. The error message "nvme nvme0: missing or invalid SUBNQN field" from the working-system dmesg output was useful. There are a number of threads about it. Someone had success with the boot parameter "nvme_core.default_ps_max_latency_us=0"

I believe the 30 second wait on the broken system was due to it waiting 30 seconds for your root device to appear. This seems like a reasonable time. On the live system I think we wait 15 seconds by default but this can be increased with a boot parameter.

Initrds are always very stripped down versions of the system. They don't have all the kernel modules and they are missing most of the libs and programs. It seems that something extra was needed besides the kernel modules to make your NVMe device visible.

If you boot live and set "bp=b9" then you will get a bash shell before the actual system is started. I would be curious to see if your NVMe device exists when you do that. If it doesn't show up then we need to try to fix the live-initrd too.

PS: If the NVMe doesn't show up with bp=b9 you could try adding the boot parameter nvme_core.default_ps_max_latency_us=0 and try again to see if the NVMe shows up at the b9 breakpoint.


PS2: On the running system (or live) you could do lsmod | grep nvme if more modules show up than are in the initrd then maybe that is the problem. Adding the modules to the live system is easy. Use /live/bin/unpack-initrd to create an initrd directory filled with the contents of our initrd.gz file. Copy in the missing modules then run sudo /live/bin/unpack-initrd -r to repack the live-initrd. If this works, we will make the change and inform Debian.
Will I cry when it's all over?
When I die will I see Heaven?

Post Reply

Return to “Installation”