Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Installed & Updated-Nothing Added-Good Time For Snapshot?

Post Reply
Message
Author
User avatar
KernSpy
Forum Regular
Forum Regular
Posts: 625
Joined: Wed Nov 05, 2014 10:09 pm

Installed & Updated-Nothing Added-Good Time For Snapshot?

#1 Post by KernSpy » Fri Oct 05, 2018 2:52 am

Just thought I would ask about when to take snapshots and how often. I know there is lots of different ways to backup & restore a system, but I would like to ask about preserving a fresh install - after a full update / upgrade. I have a new / fresh install of 64bit - MX 17.1 fully upgraded. I also realize there are many ways to mess up a nice new installation by following bad practices as mentioned by Paul in his post listed below.
viewtopic.php?f=104&t=44747 - How to Break Your System! I'm sure there are other pitfalls to avoid.

Once you have a newly installed system up and running and fully updated - Isn't this the best time for a backup, clone of the partition and / or a snapshot? What do you do after you have eveything installed and updated?

I haven't installed any new software as of yet. Just wondering how others proceed at this point.

Thanks!
--
MX-17.1_x64 | System76 Galago UltraPro / Clevo W740SU | Intel Core i7-4770HQ | Intel Iris Pro Graphics 5200 | 16 GB DDR3 | Intel 530 series mSATA SSD - 240-GB | WD7500BPKX - 750-GB | Intel HD Audio. Note: [System76] and the Galago's neutered UEFI

User avatar
Richard
Posts: 2148
Joined: Fri Dec 12, 2008 10:31 am

Re: Installed & Updated-Nothing Added-Good Time For Snapshot?

#2 Post by Richard » Fri Oct 05, 2018 6:29 am

After a new install: adjust the interface as I desire,
install my desired applications, run the MX-Cleanup
and then do a snapshot.
That's my plan.
MX171: Lenovo T430: Intel Ivy Bridge i5-3320M, 8GB RAM, 4.18.0-2-amd64, 119GB SSD
MX171: EeePC 1005HA: Dual Core Atom N270, 1GB RAM, 4.9.0-8-686, 150GB HDD
Thunar/Doublecmd, LibO613, Dropbox, Firefox, CherryTree, Vbox. LinuxCounter #208633

User avatar
KernSpy
Forum Regular
Forum Regular
Posts: 625
Joined: Wed Nov 05, 2014 10:09 pm

Re: Installed & Updated-Nothing Added-Good Time For Snapshot?

#3 Post by KernSpy » Fri Oct 05, 2018 6:55 am

Thank You .. Richard. I just did one as a test and it went without a hitch. I'm here now via the snapshot DVD. I see there is an install icon on the desktop. I guess I could install it back onto the system HD if I needed to. I hadn't installed anything, so the .iso was only 1.3 gb. Off to set things up and get some applications installed.

Oh and I might see how it goes if I install this in Virtualbox. :)
--
MX-17.1_x64 | System76 Galago UltraPro / Clevo W740SU | Intel Core i7-4770HQ | Intel Iris Pro Graphics 5200 | 16 GB DDR3 | Intel 530 series mSATA SSD - 240-GB | WD7500BPKX - 750-GB | Intel HD Audio. Note: [System76] and the Galago's neutered UEFI

User avatar
Richard
Posts: 2148
Joined: Fri Dec 12, 2008 10:31 am

Re: Installed & Updated-Nothing Added-Good Time For Snapshot?

#4 Post by Richard » Fri Oct 05, 2018 8:13 am

Sure.
It's always a good idea to boot up the ISO in Vbox to make sure you have a good backup.
MX171: Lenovo T430: Intel Ivy Bridge i5-3320M, 8GB RAM, 4.18.0-2-amd64, 119GB SSD
MX171: EeePC 1005HA: Dual Core Atom N270, 1GB RAM, 4.9.0-8-686, 150GB HDD
Thunar/Doublecmd, LibO613, Dropbox, Firefox, CherryTree, Vbox. LinuxCounter #208633

User avatar
Richard
Posts: 2148
Joined: Fri Dec 12, 2008 10:31 am

Re: Installed & Updated-Nothing Added-Good Time For Snapshot?

#5 Post by Richard » Fri Oct 05, 2018 5:41 pm

And after that initial snapshot, as you mentioned, generally about once a month,
when everthing seems stable, I like to make a dated snapshot as a backup.
It seems like there are always some changes or tweaks
that I'd rather not have to remember to make.
MX171: Lenovo T430: Intel Ivy Bridge i5-3320M, 8GB RAM, 4.18.0-2-amd64, 119GB SSD
MX171: EeePC 1005HA: Dual Core Atom N270, 1GB RAM, 4.9.0-8-686, 150GB HDD
Thunar/Doublecmd, LibO613, Dropbox, Firefox, CherryTree, Vbox. LinuxCounter #208633

User avatar
Buck Fankers
Forum Regular
Forum Regular
Posts: 149
Joined: Sat Mar 10, 2018 9:06 pm

Re: Installed & Updated-Nothing Added-Good Time For Snapshot?

#6 Post by Buck Fankers » Fri Oct 05, 2018 5:59 pm

KernSpy wrote:
Fri Oct 05, 2018 6:55 am
I see there is an install icon on the desktop. I guess I could install it back onto the system HD if I needed to.
Yes, that's why I like it so much. Install all your apps, add your documents... then make a snapshoot. Use this same snapshot to install the exact same copy on your second computer if you have it. Sooooo cool ;-)

User avatar
KernSpy
Forum Regular
Forum Regular
Posts: 625
Joined: Wed Nov 05, 2014 10:09 pm

Re: Installed & Updated-Nothing Added-Good Time For Snapshot?

#7 Post by KernSpy » Sat Oct 06, 2018 12:33 am

Yes, very cool indeed. MX Linux has so much going for it. Especially a great community and support team!
MX-17.1_x64 | System76 Galago UltraPro / Clevo W740SU | Intel Core i7-4770HQ | Intel Iris Pro Graphics 5200 | 16 GB DDR3 | Intel 530 series mSATA SSD - 240-GB | WD7500BPKX - 750-GB | Intel HD Audio. Note: [System76] and the Galago's neutered UEFI

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2088
Joined: Mon Nov 21, 2011 5:50 pm

Re: Installed & Updated-Nothing Added-Good Time For Snapshot?

#8 Post by Gordon Cooper » Sat Oct 06, 2018 12:53 am

Very cool indeed and that post of Paul's about how to break your system should be put on automatic repeat and published here about once a month.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
KoO
Forum Regular
Forum Regular
Posts: 306
Joined: Fri Feb 10, 2017 1:21 am

Re: Installed & Updated-Nothing Added-Good Time For Snapshot?

#9 Post by KoO » Sat Oct 06, 2018 3:26 am

Snapshot the GOD in Linux...For Antix and MX anyways
AntiX 17.2 (4.18.7) i3 ,Windows8.1 , Intel Xeon E3-1241 v3 , 16gb HyperX , Samsung EVO 860 500 GB , Samsung EVO 860 500 GB , GTX 970
Lenovo T430 AntiX17.2 (4.18.7) i3 ,MX17 ,Windows8.1 , i5 +4000 , 8gb , Samsung EVO 860 500 GB , 1TB HGST

Post Reply

Return to “Installation”