Welcome!
Important information
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-18 Final release info here
-- Migration Information to MX-18 here
-- antiX-17.3 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Windows 10 Missing From Boot Menu After Install

Post Reply
User avatar
grasshopper
Forum Regular
Forum Regular
Posts: 165
Joined: Thu Jun 19, 2008 12:56 pm

Windows 10 Missing From Boot Menu After Install

#1

Post by grasshopper » Wed Oct 03, 2018 2:01 am

I've done this a few times and never had any issues.
I have a fresh install of windows 10. I used it to resize the partition so I could install linux. I went into the linux install, created a swap, formatted the unallocated space, installed linux, told it to setup grub for linux and windows like I always do...but windows is not there in the boot menu. First time that ever happened to me. The files seem to be there on the windows partition.

I ran MX Boot repair and boot customization, no joy.

How can I get the boot menu to see Windows 10 ?

User avatar
Pierre
Posts: 521
Joined: Thu Apr 19, 2007 9:23 am

Re: Windows 10 Missing From Boot Menu After Install

#2

Post by Pierre » Wed Oct 03, 2018 6:28 am

it does seem a bit strange, if the files seem to be there on the windows partition.,
& which does show that the Windows Partition is intact & allowable.

as typically, this issues, is mainly due to Fast start being enabled on the win-10 system.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10423
Joined: Sun Dec 16, 2007 1:17 pm

Re: Windows 10 Missing From Boot Menu After Install

#3

Post by dolphin_oracle » Wed Oct 03, 2018 6:33 am

From the Linux install, run

Code: Select all

sudo update-grub 
And see if it shows up.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18
lenovo s21e - MX-18, antiX-17.3.1 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
maesch3ster
Forum Novice
Forum  Novice
Posts: 4
Joined: Mon Nov 19, 2018 2:36 am

Re: Windows 10 Missing From Boot Menu After Install

#4

Post by maesch3ster » Sat Nov 24, 2018 4:18 am

This happened to me before If I remember it correctly it's something on the bios where you need to uncheck the primary o.s / grub and it will let you choose which o.s you want to boot when you restart your pc, this happened to me a couple of years ago I'm sure i fixed it by going to the bios.

Post Reply

Return to “Installation”