Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

New instal login password not accepted-solved

Message
Author
gringo
Forum Novice
Forum  Novice
Posts: 11
Joined: Fri Apr 27, 2018 3:22 pm

New instal login password not accepted-solved

#1 Post by gringo » Sun Jul 15, 2018 8:29 pm

Hi-I have a weird problem when installing mx 17.1 on one of my laptops -Samsung ativ 5
.This laptop can be a pain with uefi boot with some distros,but I have always found a way to get things sorted.I am running Bunsenlabs at the moment,but have recently installed Manjaro,Mint,Peppermint without any issues.
My problem is that the install goes smoothly,on restart the laptop boots fine until I have to enter my password-my password isnt being accepted on first boot.I have downloaded a new image,tried several pen drives and always have the same problem.Any ideas what has caused this ?
Just to mention I have been running linux for a long time,and have also instaled MX on a couple of other notebooks without a problem.
Last edited by gringo on Mon Aug 20, 2018 7:07 pm, edited 1 time in total.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1693
Joined: Wed Apr 11, 2018 5:09 pm

Re: New instal login password not accepted

#2 Post by fehlix » Sun Jul 15, 2018 9:25 pm

gringo wrote:
Sun Jul 15, 2018 8:29 pm
My problem is that the install goes smoothly,on restart the laptop boots fine until I have to enter my password-my password isnt being accepted on first boot.
..
An keyboard layout issue? If unsure you might do a "quick-check" by choose another user and within that user-name field
type in your password which becomes visble and by this just ckecking what you typed.
Before install best to do a system-update, as some keyboard realated issues had been fiexed in the installer recently.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

gringo
Forum Novice
Forum  Novice
Posts: 11
Joined: Fri Apr 27, 2018 3:22 pm

Re: New instal login password not accepted

#3 Post by gringo » Mon Jul 16, 2018 11:34 am

Hi-just had another go at installing MX.Carried out a system update,also checked what was typed in the user field (typing correct).Installed,tried to login and the same problem again.Will install Bunsenlabs again for the time being.Thanks for your help.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1693
Joined: Wed Apr 11, 2018 5:09 pm

Re: New instal login password not accepted

#4 Post by fehlix » Mon Jul 16, 2018 11:53 am

gringo wrote:
Mon Jul 16, 2018 11:34 am
Hi-just had another go at installing MX.Carried out a system update,also checked what was typed in the user field (typing correct).Installed,tried to login and the same problem again.Will install Bunsenlabs again for the time being.Thanks for your help.
Can you log in via VT-console Ctrl+Alt+F1?
Go back from VT1 to VT7 with Alt+F7.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

gringo
Forum Novice
Forum  Novice
Posts: 11
Joined: Fri Apr 27, 2018 3:22 pm

Re: New instal login password not accepted

#5 Post by gringo » Mon Jul 16, 2018 1:11 pm

Hi-I will try again following your comments when I have time.
I needed to get the laptop up and running today for a trip,so just installed something I knew would work.
I am really surprised with this problem,as I have used and installed MX several times over the past couple of years on my own and other peoples laptops,and never had any issues.It has been my go to distro up till now,so will try again once I have some time.

Once again thanks for your help

gringo
Forum Novice
Forum  Novice
Posts: 11
Joined: Fri Apr 27, 2018 3:22 pm

Re: New instal login password not accepted

#6 Post by gringo » Fri Aug 03, 2018 3:40 pm

Hi-so just reinstalled mx17.1-booted no problem-still won`t accept my login password just sends me back to the login screen.
Did the ctrl+alt+F1 and entered my login and password-I get the following message;
No mail.
No directory, logging in with HOME=/

and then;

myusername@mx:/$,I tried startx at this point and just get the flashing bar.

Just to mention that when I do a fresh install I keep my home partition as it has all my photos and music-I delete all unwanted files.I do this with other distros (manjaro,bunsen labs,mint)and have never had a problem.
Any ideas?

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1693
Joined: Wed Apr 11, 2018 5:09 pm

Re: New instal login password not accepted

#7 Post by fehlix » Fri Aug 03, 2018 4:53 pm

gringo wrote:
Fri Aug 03, 2018 3:40 pm
Hi-so just reinstalled mx17.1-booted no problem-still won`t accept my login password just sends me back to the login screen.
Did the ctrl+alt+F1 and entered my login and password-I get the following message;
No mail.
No directory, logging in with HOME=/

and then;

myusername@mx:/$,I tried startx at this point and just get the flashing bar.

Just to mention that when I do a fresh install I keep my home partition as it has all my photos and music-I delete all unwanted files.I do this with other distros (manjaro,bunsen labs,mint)and have never had a problem.
Any ideas?
What I would do. Install fresh again, but choose home as part of / (root) partition,
keep existing home as separate home-data partiton, i.e. don't touch existing home.
After reboot mount existing home(-data)-partition and check/fix permissions issues.
Reason: the existing home might have simple other userid/groupid,
and in addition existing hidden-settings might interfere with your login.
After that mount home-data permantently through fstab and symlink you Pictures/Music/Videos
folder into your home-folder.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

gringo
Forum Novice
Forum  Novice
Posts: 11
Joined: Fri Apr 27, 2018 3:22 pm

Re: New instal login password not accepted

#8 Post by gringo » Fri Aug 03, 2018 5:09 pm

Hi-I appreciate what you are saying,but this looks like a work around rather than solving the problem.
Before I install any distro I delete all unwanted folders and files from the home partition,including anything hidden.I finish up with only my docs,download,pictures and music folders,plus my own conky file.
I don`t have the same problem with other debian,ubuntu,arch based distros,so I was hoping that it would be a matter of booting my live pendrive to change some login settings.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1693
Joined: Wed Apr 11, 2018 5:09 pm

Re: New instal login password not accepted

#9 Post by fehlix » Fri Aug 03, 2018 5:26 pm

gringo wrote:
Fri Aug 03, 2018 5:09 pm
...
Before I install any distro I delete all unwanted folders and files from the home partition,including anything hidden.I finish up with only my docs,download,pictures and music folders,plus my own conky file...
Have you checked the permissions, userid, groupid of the existing home? usually with latest MX it shall be for the first user 1000:1000 for userid:groupid. If those differ you will not get a proper home as the installer will not fix it for you.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

gringo
Forum Novice
Forum  Novice
Posts: 11
Joined: Fri Apr 27, 2018 3:22 pm

Re: New instal login password not accepted

#10 Post by gringo » Fri Aug 03, 2018 5:37 pm

Hi - I always use the same user id for my home partition-I used a different ID years ago and know it gives problems.
Over the last week I have installed Linux Mint and Manjaro following the procedure I have used over the last few years and havent have any issues with the home file or login.I don`t like problems defeating me but this one looks like it might.

Post Reply

Return to “Installation”