Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] xfce panel won't start when booting from install usb nor when booting from HDD after installation

Post Reply
Message
Author
User avatar
abbreviatedman
Forum Novice
Forum  Novice
Posts: 22
Joined: Sun Apr 22, 2018 8:33 pm

[SOLVED] xfce panel won't start when booting from install usb nor when booting from HDD after installation

#1 Post by abbreviatedman » Sun Apr 22, 2018 8:58 pm

The panel is just white. I can move the location of the panel, even right-click it to modify it or log out, but no items are available in the Add Items menu.

I'm guessing it has to do with some or all of:

1. I installed over a partition on my disk (which had antiX successfully installed on it). I don't think this is it, I installed it over a perfectly good partition, but while I've shrunk and added partitions before (as I did when I shrunk my Bodhi partition and installed antiX in the other half), and I've wiped disks and installed OSes on them, I've never wiped and installed over just one partition before. Still, it seemed pretty straightforward!

2. More likely: I get a message on booting from my install usb that

Code: Select all

system.d login can't start user services
(or something very close to that; I can check the exact wording). I get the TTY login immediately, and upon logging in, try running

Code: Select all

startx
. Is that wrong? Why am I getting that message?

I'm running all this on:

ThinkPad x220
16GB RAM
45GB partition of 120GB SSD, with I think about 10GB devoted to swap.

Any help would be greatly appreciated. Although I'm really enjoying Bodhi, playing around with the live usb persistence of antiX/MX sounds like just a ton of fun.

Thanks!
-abbreviatedman

[Edited for formatting and for ambiguity of post title.]
Last edited by abbreviatedman on Sun Apr 22, 2018 11:29 pm, edited 2 times in total.
ThinkPad x220
16 GBs of RAM
120-GB SSD
Greatest Of All ThinkPads

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9066
Joined: Sun Dec 16, 2007 1:17 pm

Re: xfce panel won't start on install usb nor on install onto hdd

#2 Post by dolphin_oracle » Sun Apr 22, 2018 9:22 pm

did you save your home folder from a previous install or anything like that?

the systemd-login message is expected and of no consequence. but you should be booting to either lightdm or an xfce desktop.

I'm a little confused by the post title? Did the panel start up when you booted from the LiveUSB?

I'm actually tempted to say there is something wrong with your download.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
abbreviatedman
Forum Novice
Forum  Novice
Posts: 22
Joined: Sun Apr 22, 2018 8:33 pm

Re: xfce panel won't start on install usb nor on install onto hdd

#3 Post by abbreviatedman » Sun Apr 22, 2018 9:28 pm

* I'll check the ISO integrity. I know I should do this every time, but... Well, lazies gonna lazy.

* I still have a home folder on my Bodhi partition (not an issue, right?), but I don't THINK I saved anything from the antiX install that was previously on the partition. I can try a reinstall and make sure I'm not saving the home folder. That's an install option, right?

* Sorry about the ambiguity in the title! The panel won't load (or possibly render?) when I boot from the install ISO in order to install, nor once I've installed and I'm booting from my new HD partition. Does that explain it better?

Thanks for the help!
-abbreviatedman
ThinkPad x220
16 GBs of RAM
120-GB SSD
Greatest Of All ThinkPads

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9066
Joined: Sun Dec 16, 2007 1:17 pm

Re: xfce panel won't start on install usb nor on install onto hdd

#4 Post by dolphin_oracle » Sun Apr 22, 2018 9:40 pm

abbreviatedman wrote:* I'll check the ISO integrity. I know I should do this every time, but... Well, lazies gonna lazy.

* I still have a home folder on my Bodhi partition (not an issue, right?), but I don't THINK I saved anything from the antiX install that was previously on the partition. I can try a reinstall and make sure I'm not saving the home folder. That's an install option, right?

* Sorry about the ambiguity in the title! The panel won't load (or possibly render?) when I boot from the install ISO in order to install, nor once I've installed and I'm booting from my new HD partition. Does that explain it better?

Thanks for the help!
-abbreviatedman
Yep, thanks. I don't think we should bother installing until you get a good boot from the usb.

posting the output from

Code: Select all

inxi -F
may benefit, but I'm not sure about that.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
abbreviatedman
Forum Novice
Forum  Novice
Posts: 22
Joined: Sun Apr 22, 2018 8:33 pm

Re: xfce panel won't start when booting from install usb nor when booting from HDD after installation

#5 Post by abbreviatedman » Sun Apr 22, 2018 9:46 pm

I'm reinstalling just to be sure, but since I downloaded from a torrent, the checksum should be good, from my (new) understanding.
ThinkPad x220
16 GBs of RAM
120-GB SSD
Greatest Of All ThinkPads

User avatar
abbreviatedman
Forum Novice
Forum  Novice
Posts: 22
Joined: Sun Apr 22, 2018 8:33 pm

Re: xfce panel won't start when booting from install usb nor when booting from HDD after installation

#6 Post by abbreviatedman » Sun Apr 22, 2018 11:28 pm

It was just a bad download indeed. Not sure how that happened, but I'm booting from the install ISO just fine now.

Marking it Solved! (And myself red-faced.)

Thanks, Dolphin!
ThinkPad x220
16 GBs of RAM
120-GB SSD
Greatest Of All ThinkPads

User avatar
abbreviatedman
Forum Novice
Forum  Novice
Posts: 22
Joined: Sun Apr 22, 2018 8:33 pm

Re: [SOLVED] xfce panel won't start when booting from install usb nor when booting from HDD after installation

#7 Post by abbreviatedman » Sat Apr 28, 2018 9:32 am

Just a followup: been using MX Linux as my daily driver for a week now, and I absolutely love it. Giving a live ISO to a friend next week!
ThinkPad x220
16 GBs of RAM
120-GB SSD
Greatest Of All ThinkPads

Post Reply

Return to “Installation”