Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.2 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

(SOLVED) Install issues with MX 17.1 final 64 bit

User avatar
Forum Guide
Forum Guide
Posts: 1539
Joined: Sun Dec 16, 2007 6:29 pm

Re: Install issues with MX 17.1 final 64 bit


Post by GuiGuy » Fri Mar 16, 2018 10:23 am

I hope this is relevant: I have not read all the detail in this thread but it seems that the grub installation process confuses the installer.
I have used EasyBCD, and IIRC it works without having grub installed, so why not try the installer again without installing grub?

User avatar
Forum Regular
Forum Regular
Posts: 462
Joined: Sun Dec 07, 2008 10:02 pm

Re: Install issues with MX 17.1 final 64 bit


Post by muskt » Fri Mar 16, 2018 1:21 pm

I SURRENDER !!!!!!!!!!!!!

I cannot spend any more time on this project.

I enjoy a challenge; however, this one has me beaten into the ground.

The progress made last evening by D_O & me is gone. I attempted to reinstall Grub--total failure.
I started over--total failure
I used a different USB drive--total failure.
I have 6 sticks of memory in the box. I removed the three newest ones (more than one year since installed)--no difference.
I fired up MX17.1 on the laptop & downloaded a fresh copy of the ISO & burned it to a different USB--booted the desktop from that drive--GParted still fails--install fails.

I have always treated Linux as a learning device--notice I did not use the term "toy" or any derogatory name--I have always struggled with it. I may attempt to install MX17.1 again in the not-too-distant future; but, for now---I surrender.

D_O, I regret infringing on your time, and want to sincerely thank you for your generosity, patience, and willingness to help me with this problem. Thank You is totally insufficient; but, all I can offer.

Thank You
Jerry in Delaware

User avatar
Forum Regular
Forum Regular
Posts: 462
Joined: Sun Dec 07, 2008 10:02 pm

Re: Install issues with MX 17.1 final 64 bit


Post by muskt » Thu Apr 19, 2018 3:39 pm

OK!! Success (This is going to be a long post)

Why the excitement?? I have finally been able to get MX17.1 64Bit installed and operational.
This has been an incredibly long and frustrating ordeal for me. I have experienced nothing like this before, and have successfully installed every previous version of MX on this same computer.

Since this thread is pretty old, I’ll provide a short recap of what I was experiencing.

Every attempt to install MX17.1 64Bit failed at the formatting partition stage (every time). Never before with any other version. I tried different USB drives, I tried burning via Win10, Mepis 11, MX16.1 64Bit, & MX 17 64Bit. After the failure, the computer was pretty much locked up & required the reset button to shutdown.

Dolphin_Oracle worked with me one evening for 2-3 hours & we finally gave up in order to get some sleep. (Another huge Thank You, D_O.)
After several days of not touching Linux, I started in again—by myself. I did a lot of reading on the web.
A bit about my computer might prove helpful at this point.

I7-930, 18G ram, Asus P6X58D Premium Mobo. Nvidia GT550 Graphics, 1 DVD drive, (here is the weird part) One 256G SSD, 3 WD Raptor 300G drives, & 1 Seagate 167G drive.

I had numerous OSs installed—Windows 10 on SSD, Win 7 & Mepis 11 on one WD drive, MX 16.1 64 on another, & MX17 64 on another. You can see that this system has evolved over the years. I have always been afraid of GRUB—I have always used EasyBCD as the boot medium.

So, I decided that it was time to come into the current world, & acquired a used WD Raptor 600G drive (for MX17.1 64). I disconnected all of the other drives and the install for MX17.1 worked the first time. I installed GRUB to Root.

Next, I reconnected the SSD, and could not under any circumstances get it to boot Win 10. Have you figured out that I know very little about Linux? More studying on the web—another install of MX17.1 (I disconnected the SSD first) with Grub on MBR. Reconnected the SSD & updated Grub—It still wouldn’t boot Windows. (I know, I know—good thing, right.) Much thinking passed, & I realized that I had started using EasyBcd when I still ran Windows 7. Yep, all the boot stuff was on the Win 7 drive (which I had not yet connected)—no boot sector stuff on the SSD. A couple more days of studying, & I was able to get the boot sector stuff installed on the SSD. Updated GRUB on MX17.1, & now I have a fully functional dual-boot with MX17.1 & Windows 10.

So, happily, I reconnected the other hard drives, & rebooted into MX 17.1. I attempted to open GParted, & the computer locked up just as when attempting to install MX17.1 a few weeks ago.

Several unpure thoughts, & a few unpure words followed.

I disconnected all the drives except for the MX17.1, & the SSD and rebooted into MX17.1. All OK. Shut down, & reconnected one additional drive. Booted MX17.1, & removed all traces of Win7 or Linux on that drive. Rinse, lather, & repeat till all drives are reconnected and only MX17.1 and Windows 10 are on any of the drives.

There was one partition formatted ext4 on one of the drives that contained a lot of data, but no label. I was not able to access any data on it, so I have not a clue if that partition was causing the problems.
I realize that 6 drives is a lot. Since they are relatively small, I now plan to use them to store pics & movies of the grandkids.

I can truthfully state that I learned a lot during this series of events. Hopefully, I can retain some of it for future use.
Thank you Developer Team, & especially Dolphin_Oracle for your time & hand-holding to try & get me up & running. I really appreciate it.

Jerry in Delaware

Post Reply

Return to “Installation”