Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX is slow after lqast update

Message
Author
jerry525
Forum Novice
Forum  Novice
Posts: 72
Joined: Sat Jun 07, 2014 10:39 am

MX is slow after lqast update

#1 Post by jerry525 » Tue Sep 30, 2014 3:02 am

Hello, I have two computers both performing slowly after the last update.
CPU is cycling & everything is jittery (not smooth). Here are my specs:

Processor : 2x Intel(R) Atom(TM) CPU N270 @ 1.60GHz
Memory : 2063MB (380MB used)
Resolution : 1024x600 pixels
OpenGL Renderer : Mesa DRI Intel(R) 945GME x86/MMX/SSE2

HTOP shows it's the usr/bin/x..... that is consuming the cpu

Can anyone help please?

User avatar
joany
Forum Veteran
Forum Veteran
Posts: 5919
Joined: Mon Feb 12, 2007 1:45 pm

Re: MX is slow after lqast update

#2 Post by joany » Tue Sep 30, 2014 10:20 am

By "last update" are you referring to the Intel graphics driver package? Also, could you be more specific as to which /usr/bin/x... process is chewing up CPU and how much?
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.

jerry525
Forum Novice
Forum  Novice
Posts: 72
Joined: Sat Jun 07, 2014 10:39 am

Re: MX is slow after lqast update

#3 Post by jerry525 » Tue Sep 30, 2014 11:58 am

Thanks. Yes it was the graphics drivers.

The process is: usr/bin/x -dpi $DPI :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

It is consuming 5-12% cpu.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9318
Joined: Wed Jul 12, 2006 2:26 pm

Re: MX is slow after lqast update

#4 Post by kmathern » Tue Sep 30, 2014 12:22 pm

Could you post the output of the following?

Code: Select all

inxi -Gxx
Fwiw I get similar cpu usage on my system because it's using "GLX Renderer: Gallium 0.4 on llvmpipe" (software rendering). I have Kabini - Radeon HD 8240 graphics, but they're not supported that well in Wheezy.

jerry525
Forum Novice
Forum  Novice
Posts: 72
Joined: Sat Jun 07, 2014 10:39 am

Re: MX is slow after lqast update

#5 Post by jerry525 » Tue Sep 30, 2014 1:01 pm

Graphics: Card: Intel Mobile 945GSE Express Integrated Graphics Controller
bus-ID: 00:02.0 chip-ID: 8086:27ae
Display Server: X.Org 1.12.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1024x600@60.0hz
GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2
GLX Version: 1.4 Mesa 8.0.5 Direct Rendering: Yes

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9318
Joined: Wed Jul 12, 2006 2:26 pm

Re: MX is slow after lqast update

#6 Post by kmathern » Tue Sep 30, 2014 3:28 pm

jerry525 wrote:Graphics: Card: Intel Mobile 945GSE Express Integrated Graphics Controller
bus-ID: 00:02.0 chip-ID: 8086:27ae
Display Server: X.Org 1.12.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1024x600@60.0hz
GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2
GLX Version: 1.4 Mesa 8.0.5 Direct Rendering: Yes
That looks right.

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 11380
Joined: Wed Jul 12, 2006 5:54 am

Re: MX is slow after lqast update

#7 Post by lucky9 » Tue Sep 30, 2014 3:45 pm

boot into init 3 and run sgfxi as root
you might have to do this twice
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
richb
Administrator
Posts: 17045
Joined: Wed Jul 12, 2006 2:17 pm

Re: MX is slow after lqast update

#8 Post by richb » Tue Sep 30, 2014 4:07 pm

lucky9 wrote:boot into init 3 and run sgfxi as root
you might have to do this twice
Worth a try, but usually does not help much with Intel graphics cards.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 8877
Joined: Wed Jul 12, 2006 1:42 am

Re: MX is slow after lqast update

#9 Post by Adrian » Tue Sep 30, 2014 4:25 pm

Is compositing turned on? You might need to turn it off. From Settings -> Windows Manager Tweaks -> Compositor tab.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16174
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX is slow after lqast update

#10 Post by Stevo » Tue Sep 30, 2014 5:49 pm

There was an update in wheezy-backports to the Intel driver to

xserver-xorg-video-intel_2.21.15-2~bpo70+1

If you think this upgrade is causing the problem, and you have rebooted and confirm that the problem persists, you can downgrade to the stock Wheezy version in Synaptic (Force Version) of 2:2.19.0-6 to see if that cures it. Make sure to reboot after the downgrade.

Post Reply

Return to “Older Versions”