Welcome!

Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 Final release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

[Solved] Trying to install Wine

Message
Author
johnnyhop
Forum Novice
Forum  Novice
Posts: 22
Age: 65
Joined: Sun Jan 16, 2011 8:17 am

[Solved] Trying to install Wine

#1 Postby johnnyhop » Fri Oct 18, 2013 3:02 pm

Last spring--I think May, Wine installed with no problem from apt-get. A few weeks ago the hard drive's partition record got corrupted so after that was cared for, a clean reinstall was done of 11x64. After the first update and many packages were unavailable, All repositories were enabled, updates did a little better but many couldn't be done. Then found on forum instructions to use this sources.list. Copied and pasted overwriting the previous sources.list and an update/upgrade could find all but three

Code: Select all

W: Failed to fetch http://restricted.mepis-deb.org/mepiscr/repo/dists/mepis11cr/restricted/binary-amd64/Packages.gz  401  Authorization Required

W: Failed to fetch http://restricted.mepis-deb.org/mepiscr/repo/dists/mepis11cr/restricted-non-free/binary-amd64/Packages.gz  401  Authorization Required

W: Failed to fetch ftp://mepis.mirrorcatalogs.com/mepis/packages/mepis/dists/mepis-11.0/main/binary-amd64/Packages.gz  Unable to fetch file, server said 'Failed to open file.  '

E: Some index files failed to download, they have been ignored, or old ones used instead.


When attempting to install wine this message is given:

Code: Select all

The following packages have unmet dependencies:
 wine : Depends: ia32-libs (>= 1.6) but it is not going to be installed
E: Broken packages


Nearest I can tell from the Debian website this ia32-libs is for running 32 bit applications on 64 bit architecture. Is there a repository that can be added to sources.list that would contain this ia32-libs fie? If it is now necessary to download it from Debian, where do I put it so dpkg can find it?
Last edited by johnnyhop on Sat Oct 19, 2013 4:36 pm, edited 1 time in total.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 3845
Joined: Wed Jul 12, 2006 4:05 pm

Re: Trying to install Wine--get unmet dependencies message.

#2 Postby timkb4cq » Fri Oct 18, 2013 4:16 pm

The first two not-found repositories are the restricted community repos which are no longer active. Disable them. We lost the overseas hosting and nobody in a suitable country has stepped up to take it over. Fortunately, debian has started including most of the packages that made the restricted repos necessary and the deb-multimedia has the rest for M11 & M12.

The third is a dead mirror of the main MEPIS repository. Disable that one & enable this one (already in the list) instead

Code: Select all

http://www.mirrorservice.org/sites/ftp.mepis.org/mepis/

Once you have that one working install ia32-libs. It's in the standard 64bit debian squeeze repositories. It was probably not installing before because not having Warren's repo working led to version mismatches...
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 11380
Joined: Wed Jul 12, 2006 5:54 am

Re: Trying to install Wine--get unmet dependencies message.

#3 Postby lucky9 » Fri Oct 18, 2013 4:28 pm

First you really need to do some reading and asking. The restricted repositories are no longer there. So they are commented out by default. Don't use them.

For the mirror catalogs, use the alternate one only. The ftp server has been giving problems for a while.
To get around this you can manually edit the /etc/apt/sources.list (as root) by adding http to the stanza's that don't have it. IE: instead of ftp://ftp, have http://ftp. That enables both and you only need one that works. When APT (Synaptic is only a GUI for it) finds a working repository it stops. It checks both entries and if either works it's happy.

Unless you've installed something from the Community Repositories (CR), do not enable them.

Likewise the deb.multimedia repository.

On the first installation upgrade use the Command Line (CL) outside of X. IE: Ctrl+Alt+F1. (Unless you loose the Internet.) To get the Internet outside of X you can enable the CR and install ceni before you leave X. It will connect outside of X easily. It has to be run as root. Be sure to disable the CR before continuing. It's not recommended to leave them enabled during an upgrade.

From the CL become root and enter apt-get update (hit the Enter key)
Then enter apt-get dist-upgrade (hit the Enter key)

After this first upgrade if you need to install proprietary video drivers it's time to do so. Afterwards you can install most anything from debian, deb-multimedia, etc. Don't upgrade with the CR enabled. You're way better off only upgrading individual programs from them.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain


Return to “Community Repository (CR)”

Who is online

Users browsing this forum: No registered users and 2 guests