Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Kdenlive graphic acceleration

Post Reply
Message
Author
User avatar
nlyric
Forum Regular
Forum Regular
Posts: 490
Joined: Fri Jul 14, 2006 7:49 pm

Kdenlive graphic acceleration

#1 Post by nlyric » Wed Sep 05, 2018 7:04 pm

Hey everyone, kind of new to posting here. Been away from linux and a computer for so long that I feel painfully ignorant. In another life I was a regular on Mepis lovers forum. I recognize some users from back then.
Anyway what i'm trying to do is get graphics acceleration working in kdenlive. It is usable now but previews can be choppy at times. Even audio in preview sometimes. I have an old dell laptop that my nephew sent me. When I go to Setting/configure kdenlive/playback and check the box "use GPU processing (movit library) and restart kdenlive I get a warning.
So I started kdenlive from terminal to see whats up. I'm not even sure I'm on the right path here to solve what I'm trying to solve.

In GUI I get "Cannot initialize Movit's GLSL manager, please disable Movit"

In terminal I believe this might be the relevant part " Movit system requirements: OpenGL version 2.1 is too old (OpenGL 3.0 needed)"

Questions How do I fix this? Will fixing this even help? All my rendering does fine audio and video so like I said the program is usable as is but would be nice if previews were smoother. I feel like I've forgotten everything I ever knew about Linux so go easy. Thanks in advance.
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile
OpenGL version string: 2.1 Mesa 13.0.6
OpenGL shading language version string: 1.20
OpenGL extensions:

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16300
Joined: Fri Dec 15, 2006 8:07 pm

Re: Kdenlive graphic acceleration

#2 Post by Stevo » Wed Sep 05, 2018 7:16 pm

It could be that the hardware just doesn't support openGL 3.0, especially if it's old.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9392
Joined: Sun Dec 16, 2007 1:17 pm

Re: Kdenlive graphic acceleration

#3 Post by dolphin_oracle » Wed Sep 05, 2018 7:20 pm

Older intel core processors do not support OpenGL 3.0. My ironlake era laptop has similar issues with obs-studio.

Sandybridge and later should support OpenGL 3.0
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
nlyric
Forum Regular
Forum Regular
Posts: 490
Joined: Fri Jul 14, 2006 7:49 pm

Re: Kdenlive graphic acceleration

#4 Post by nlyric » Wed Sep 05, 2018 7:32 pm

Well that settles that ... Appreciate it!!!!

Post Reply

Return to “General”