Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

Message
Author
davemx
Forum Novice
Forum  Novice
Posts: 53
Joined: Sun Aug 12, 2018 2:31 pm

Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#1 Post by davemx » Tue Aug 21, 2018 5:28 pm

This is part two of a tale that I posted about trying to get Windows 7 installed on a USB3-only motherboard. Was it co-incidental that my Ethernet should start malfunctioning at that same time, across a Windows 7 installation and 5 Linux installs? Did Windows 7 somehow break my hardware?

This was the first part.

https://davespagnol.wordpress.com/2018/ ... -computer/

And this is the bit about the Ethernet problem.

https://davespagnol.wordpress.com/2018/ ... -go-wrong/

It's funny now, but not at the time!
Desktop: Mini-Box M350 with Asus H110i-plus motherboard, Pentium G4600 processor, 2TB SSD and 16Gb RAM DDR4-2133
Printer/Scanner: Brother MFC-J5320W
Laptop: Upgraded Lenovo B50-45

larryg
Forum Novice
Forum  Novice
Posts: 8
Joined: Fri Aug 17, 2018 8:44 pm

Re: Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#2 Post by larryg » Wed Aug 22, 2018 10:03 am

Ha! Same thing happened to me when I was installing a new router and cable modem in my son's new apartment. I just grabbed 3 cables from an old install and headed over to his place and hooked it up. It did not work, and then I remembered why I had 3 cables in my previous install. Of the original two cables, one was bad. So I purchased a different cable and swapped the bad one out. Being a moron, I just left the bad one behind my router. Now it is in the trash! Debugging this twice was bad enough. No third time.

davemx
Forum Novice
Forum  Novice
Posts: 53
Joined: Sun Aug 12, 2018 2:31 pm

Re: Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#3 Post by davemx » Thu Aug 23, 2018 10:50 am

I've now had a bit of weird behaviour with the replacement cable, though not as much. I ordered a USB Wireless Dongle for £5 sterling, and I'm still waiting for it to arrive. It will be less than 3ft from the transmitter, so let's see if that's more reliable and with no loss of speed.
Desktop: Mini-Box M350 with Asus H110i-plus motherboard, Pentium G4600 processor, 2TB SSD and 16Gb RAM DDR4-2133
Printer/Scanner: Brother MFC-J5320W
Laptop: Upgraded Lenovo B50-45

davemx
Forum Novice
Forum  Novice
Posts: 53
Joined: Sun Aug 12, 2018 2:31 pm

Re: Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#4 Post by davemx » Sat Aug 25, 2018 2:36 pm

It seems I was a victim of r8169-itis. I tried installing r8168-dkms from the repos but it didn't build. I tried building it from source, and that worked better, it even rebuilt the initrd and added the blacklist file. And it worked, too. But it still took a while to log into the modem though. I added a cheap Ralink 5370 dongle and the computer connects to the router instantaneously with no dropouts. It doesn't matter that it's a nano type, because it's only 3ft from the modem!
Desktop: Mini-Box M350 with Asus H110i-plus motherboard, Pentium G4600 processor, 2TB SSD and 16Gb RAM DDR4-2133
Printer/Scanner: Brother MFC-J5320W
Laptop: Upgraded Lenovo B50-45

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1429
Joined: Sun Dec 16, 2007 6:29 pm

Re: Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#5 Post by GuiGuy » Sat Aug 25, 2018 6:22 pm

Dave,
Please give details of your working nano dongle.
My nano dongle
Bus 005 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
works for only a few minutes before losing connection.
So I would like to obtain a more usable nano dongle.

Best wishes,
from yet another Dave.

davemx
Forum Novice
Forum  Novice
Posts: 53
Joined: Sun Aug 12, 2018 2:31 pm

Re: Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#6 Post by davemx » Tue Aug 28, 2018 10:11 am

Hi Dave!

The problem is that many of the adverts on line don't tell you the chipsets but this one did!
I bought this one: https://www.amazon.co.uk/dp/B00JZFT3VS/

Vendor ID: 148F (Ralink)
Device ID: 5370
Module: ‎rt2800usb
Desktop: Mini-Box M350 with Asus H110i-plus motherboard, Pentium G4600 processor, 2TB SSD and 16Gb RAM DDR4-2133
Printer/Scanner: Brother MFC-J5320W
Laptop: Upgraded Lenovo B50-45

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1429
Joined: Sun Dec 16, 2007 6:29 pm

Re: Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#7 Post by GuiGuy » Tue Aug 28, 2018 12:20 pm

Thanks Dave,
Have one on order now :crossfingers: .

davemx
Forum Novice
Forum  Novice
Posts: 53
Joined: Sun Aug 12, 2018 2:31 pm

Re: Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#8 Post by davemx » Tue Aug 28, 2018 8:09 pm

Best of luck.
Desktop: Mini-Box M350 with Asus H110i-plus motherboard, Pentium G4600 processor, 2TB SSD and 16Gb RAM DDR4-2133
Printer/Scanner: Brother MFC-J5320W
Laptop: Upgraded Lenovo B50-45

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1429
Joined: Sun Dec 16, 2007 6:29 pm

Re: Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#9 Post by GuiGuy » Wed Aug 29, 2018 12:45 pm

Success!
Bus 002 Device 002: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Posting with it now :happy:

Thanks again, Dave.

P.S. This is an old eeepc901 with defunct internal wifi - rather slow but quite usable with MX.

davemx
Forum Novice
Forum  Novice
Posts: 53
Joined: Sun Aug 12, 2018 2:31 pm

Re: Fixed. For info/amusement. Wired Ethernet not working but Wireless working fine.

#10 Post by davemx » Wed Aug 29, 2018 2:50 pm

Brilliant. By the way, here is the third part of the saga, the trilogy that was never meant to be written:

https://davespagnol.wordpress.com/2018/ ... ss-i-know/

(with apologies to Johnny Nash).
Desktop: Mini-Box M350 with Asus H110i-plus motherboard, Pentium G4600 processor, 2TB SSD and 16Gb RAM DDR4-2133
Printer/Scanner: Brother MFC-J5320W
Laptop: Upgraded Lenovo B50-45

Post Reply

Return to “General”