Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

PulseAudio Equalizer

Message
Author
User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: PulseAudio Equalizer

#11 Post by fehlix » Sun Jul 29, 2018 8:22 pm

Mauser wrote:
Sun Jul 29, 2018 8:05 pm
Thanks. It shows that it's installed but it's nowhere to be found on my computer. :(
which qpaeq

Code: Select all

/usr/bin/qpaeq
But you might further read #6 above, if not already done so.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Mauser
Forum Regular
Forum Regular
Posts: 714
Joined: Mon Jun 27, 2016 7:32 pm

Re: PulseAudio Equalizer

#12 Post by Mauser » Sun Jul 29, 2018 8:25 pm

fehlix wrote:
Sun Jul 29, 2018 8:22 pm
Mauser wrote:
Sun Jul 29, 2018 8:05 pm
Thanks. It shows that it's installed but it's nowhere to be found on my computer. :(
which qpaeq

Code: Select all

/usr/bin/qpaeq
But you might further read #6 above, if not already done so.
I did thanks. Much of what I read I don't understand. I will have to wait for when MX Linux comes with it per-installed.

User avatar
richb
Administrator
Posts: 17250
Joined: Wed Jul 12, 2006 2:17 pm

Re: PulseAudio Equalizer

#13 Post by richb » Sun Jul 29, 2018 8:49 pm

Steps outlined in post #6 do work.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

nik.gnomic
Forum Novice
Forum  Novice
Posts: 15
Joined: Sun Mar 26, 2017 8:56 pm

Re: PulseAudio Equalizer

#14 Post by nik.gnomic » Sun Jul 29, 2018 9:45 pm

Mauser wrote:
Sun Jul 29, 2018 8:05 pm
It shows that it's installed but it's nowhere to be found on my computer. :(
assuming you got installed ok for step 1, use this command to check step 2:

Code: Select all

pactl list short sinks
if the two new modules are shown on that list you have completed step 2 to add the installed equalizer to Pulseaudio

User avatar
Mauser
Forum Regular
Forum Regular
Posts: 714
Joined: Mon Jun 27, 2016 7:32 pm

Re: PulseAudio Equalizer

#15 Post by Mauser » Sun Jul 29, 2018 10:10 pm

nik.gnomic wrote:
Sun Jul 29, 2018 9:45 pm
Mauser wrote:
Sun Jul 29, 2018 8:05 pm
It shows that it's installed but it's nowhere to be found on my computer. :(
assuming you got installed ok for step 1, use this command to check step 2:

Code: Select all

pactl list short sinks
if the two new modules are shown on that list you have completed step 2 to add the installed equalizer to Pulseaudio
The developers of this equalizer never checked their work. Never should you have to go through all this in 2018. This why I am going to wait till it comes with MX Linux. It should install and work from the package manager. I get this. What does it mean?

Code: Select all

pactl list short sinks
0	alsa_output.pci-0000_00_1f.3.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED

plzd
Forum Novice
Forum  Novice
Posts: 42
Joined: Fri Feb 10, 2017 11:03 pm

Re: PulseAudio Equalizer

#16 Post by plzd » Mon Jul 30, 2018 8:47 pm

fehlix wrote:
Sun Jul 29, 2018 4:30 pm
Thanks, for writing down the stepps :number1: , which I was to lazy to do so :bagoverhead:
Not a problem. Just hoping it will help. :happy:
Dell E6220 i7 2640M CPU @ 2.80GHz Intel Sandybridge Mobile 8GB Ram 128GB SSD - 23" Acer G235h Monitor

nik.gnomic
Forum Novice
Forum  Novice
Posts: 15
Joined: Sun Mar 26, 2017 8:56 pm

Re: PulseAudio Equalizer

#17 Post by nik.gnomic » Mon Aug 13, 2018 10:49 pm

I am following documentation at:
https://www.freedesktop.org/wiki/Softwa ... Equalizer/

Equalizer may be installed, but still needs to be loaded as Pulseaudio module

Adjusting for name of your audio device, this can be added to Pulseaudio configuration

Code: Select all

load-module module-equalizer-sink sink_name=equalized master=pci-0000_00_1f.3.analog-stereo set_default=true
set-default-sink equalized
Can be added to end of system file /etc/pulse/default.pa
But I find it better to copy file to home folder before adding extra 2 lines above

Code: Select all

cp /etc/pulse/default.pa ~/.config/pulse/default.pa
Pulseaudio must be restarted (log out or reboot) to load new module and default setting

Any further configuration can be done in gui - Pulseaudio Volume Control (pavucontrol) and Equalizer (qpaeq)

This is the easier option workaround instead of configuration tuning Pulseaudio to hardware
Or running better DSP in JACK.
But if need to remediate audio, not much benefit using JACK anyway

User avatar
Laurentius
Forum Novice
Forum  Novice
Posts: 55
Joined: Sat Jan 20, 2018 9:44 pm

Re: PulseAudio Equalizer

#18 Post by Laurentius » Sun Oct 21, 2018 1:31 am

hello.

I am trying to make the equalizer work. I installed pulseaudio-equalizer and run the 2 steps commands from the #6 post, but i get error message on the second:

Code: Select all

$ pactl load-module  module-dbus-protocol
Failure: Module initialization failed
This is the output of pactl list short sinks:

Code: Select all

$ pactl list short sinks
0	alsa_output.pci-0000_00_1b.0.analog-stereo	module-alsa-card.c	s16le 2ch 44100Hz	RUNNING
1	alsa_output.pci-0000_00_1b.0.analog-stereo.equalizer	module-equalizer-sink.c	float32le 2ch 44100Hz	SUSPENDED
What could be wrong?
And qpaeq:

Code: Select all

$ qpaeq
There was an error connecting to pulseaudio, please make sure you have the pulseaudio dbus module loaded, exiting...

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: PulseAudio Equalizer

#19 Post by fehlix » Sun Oct 21, 2018 6:40 pm

Laurentius wrote:
Sun Oct 21, 2018 1:31 am
What could be wrong?
And qpaeq:

Code: Select all

$ qpaeq
There was an error connecting to pulseaudio, please make sure you have the pulseaudio dbus module loaded, exiting...
Try unload :

Code: Select all

pactl unload-module module-dbus-protocol
pactl unload-module module-equalizer-sink
and load again:

Code: Select all

pactl load-module module-equalizer-sink
pactl load-module module-dbus-protocol
qpaeq 
If still load errors show,
check "old" versions within your path:

Code: Select all

locate module-dbus-protocol.so
# output should be:
/usr/lib/pulse-10.0/modules/module-dbus-protocol.so
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Laurentius
Forum Novice
Forum  Novice
Posts: 55
Joined: Sat Jan 20, 2018 9:44 pm

Re: PulseAudio Equalizer

#20 Post by Laurentius » Mon Oct 22, 2018 6:09 pm

Thank you fehlix.
Now it did work. At least the eq window opened.

Code: Select all

mx17-2@cq40mx:~
$ pactl unload-module module-dbus-protocol
Failed to unload module: Module module-dbus-protocol not loaded
mx17-2@cq40mx:~
$ pactl unload-module module-equalizer-sink
Failed to unload module: Module module-equalizer-sink not loaded
mx17-2@cq40mx:~
$ pactl load-module module-equalizer-sink
22
mx17-2@cq40mx:~
$ pactl load-module module-dbus-protocol
23
mx17-2@cq40mx:~
$ qpaeq
(and the equalizer window opened)
None of the modules seemed to be loaded, probably because i restarted the os after that first try.

But now I know how to unload modules!
And i can launch the eq even from whisker menu.

Post Reply

Return to “General”