Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Time Setings in MX17.1

Message
Author
User avatar
GTK48
Forum Novice
Forum  Novice
Posts: 6
Joined: Mon Jul 23, 2018 1:21 pm

Time Setings in MX17.1

#1 Post by GTK48 » Thu Jul 26, 2018 7:15 am

The time will not display the proper time or time zone when I boot into MX17. This is also messing up the time in other Distros and in Windows 10. There is like a 60 second or longer delay before the time is set properly. I really like this Distro and would like to keep it, but this problem is a deal breaker for me.Any help with this issue would be appreciated.

Discostu
Forum Novice
Forum  Novice
Posts: 34
Joined: Wed Jul 11, 2018 3:13 am

Re: Time Setings in MX17.1

#2 Post by Discostu » Thu Jul 26, 2018 7:35 am

Check this article, it should help with the problems you're describing:

https://mxlinux.org/wiki/system/time-settings

I had similar problems after my first installation of MX Linux. If I remember correctly the solution was to open MX Timeset GUI and set hardware time to local time.

User avatar
Richard
Posts: 1954
Joined: Fri Dec 12, 2008 10:31 am

Re: Time Setings in MX17.1

#3 Post by Richard » Thu Jul 26, 2018 7:40 am

Time-Setting has been moved since MX-15.
Now located at Start-Menu > Settings > MX Time Settings
or, open Whiskermenu and type timeset then press Enter for the MX-Timeset-GUI.
All the rest seems the same.
MX171: Lenovo T430-2017: i5-3320M, 8 GBRAM, 4.15.0-1-amd64, intel_pstate, 119 GB SSD
MX171: AA1(ZG5)/EeePC-1005HA: DualCoreN270, 1 GBRAM, 4.15.0-1-686-pae, 150 GB HDD
DC9, LibO610, Dbox, PM, FF, mPDFed, CherryT, Vbox. ____ Linux Counter #288562

User avatar
GTK48
Forum Novice
Forum  Novice
Posts: 6
Joined: Mon Jul 23, 2018 1:21 pm

Re: Time Setings in MX17.1

#4 Post by GTK48 » Thu Jul 26, 2018 7:52 am

OK, I made some changes right after I posted and the Time in MX 17.1 is now working, but when I boot back into Windows 10, the time is off by 4 hours and both are set the same. I set the time as you suggested. Thanks for your help, I will keep on looking at this.

User avatar
Richard
Posts: 1954
Joined: Fri Dec 12, 2008 10:31 am

Re: Time Setings in MX17.1

#5 Post by Richard » Thu Jul 26, 2018 8:07 am

To solve your problem, you need to set the Hardware Clock to Local Time in MX.
MX171: Lenovo T430-2017: i5-3320M, 8 GBRAM, 4.15.0-1-amd64, intel_pstate, 119 GB SSD
MX171: AA1(ZG5)/EeePC-1005HA: DualCoreN270, 1 GBRAM, 4.15.0-1-686-pae, 150 GB HDD
DC9, LibO610, Dbox, PM, FF, mPDFed, CherryT, Vbox. ____ Linux Counter #288562

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22243
Joined: Wed Jul 19, 2006 6:13 am

Re: Time Setings in MX17.1

#6 Post by Jerry3904 » Thu Jul 26, 2018 8:16 am

Note to self: this needs to be added to that Wiki article.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
GTK48
Forum Novice
Forum  Novice
Posts: 6
Joined: Mon Jul 23, 2018 1:21 pm

Re: Time Setings in MX17.1

#7 Post by GTK48 » Thu Jul 26, 2018 8:39 am

Richard wrote:
Thu Jul 26, 2018 8:07 am
To solve your problem, you need to set the Hardware Clock to Local Time in MX.
That fixed it, Thank you very much. :number1:

sunrat
Forum Regular
Forum Regular
Posts: 176
Joined: Mon Mar 28, 2016 9:54 pm

Re: Time Setings in MX17.1

#8 Post by sunrat » Thu Jul 26, 2018 10:54 am

Richard wrote:
Thu Jul 26, 2018 8:07 am
To solve your problem, you need to set the Hardware Clock to Local Time in MX.
I prefer to set Windows to use UTC. That way it plays nice with multiple Linux installs on the same system.

https://wiki.archlinux.org/index.php/ti ... in_Windows
As noted, Win10 needs the QWORD value IIRC.

User avatar
GTK48
Forum Novice
Forum  Novice
Posts: 6
Joined: Mon Jul 23, 2018 1:21 pm

Re: Time Setings in MX17.1

#9 Post by GTK48 » Thu Jul 26, 2018 11:11 am

sunrat wrote:
Thu Jul 26, 2018 10:54 am
Richard wrote:
Thu Jul 26, 2018 8:07 am
To solve your problem, you need to set the Hardware Clock to Local Time in MX.
I prefer to set Windows to use UTC. That way it plays nice with multiple Linux installs on the same system.

https://wiki.archlinux.org/index.php/ti ... in_Windows
As noted, Win10 needs the QWORD value IIRC.
That is how I had it set and it was not working.

User avatar
sivaraj
Forum Novice
Forum  Novice
Posts: 15
Joined: Wed Oct 10, 2007 2:43 am

Re: Time Setings in MX17.1

#10 Post by sivaraj » Sun Jul 29, 2018 4:30 am

It looks recent mx installer behavior changed for time settings and it forces the computer hardware clock to UTC .
The installer released with March MX-17.1 iso is working fine and do not know when exactly it changed .
But recent updated snapshot iso installer behaves differently .

I feel the installer behavior change is wrong.
Selecting local time or utc and time zone worked well with installer since Mepis days
It is one of a unique mepis linux installer feature which you do not find with others .

But installer of recent snapshot behaves different.
It makes unintended change to hardware clock which is not everyone may wants.
My request instead of changing installer behavior please provide a mx-tool so that user can setup system time based on their preference.

Post Reply

Return to “General”