Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX-17 - Wow!

Post Reply
Message
Author
User avatar
RobbieW
Forum Novice
Forum  Novice
Posts: 8
Joined: Wed Jan 17, 2018 4:00 pm

MX-17 - Wow!

#1 Post by RobbieW » Fri Jan 19, 2018 12:56 pm

I was a user of -14,15 and 16 but I've been distro-hopping for the last year or so (I left MX for the trivial reason that I had some issues with the daemon in Turboprint, which I use for my business). Dissatisfied for various reasons I've now comeback to MX-17 and just thought I'd feed back my thoughts to the devs and anyone else who might be interested. The post title says it all, really. No problems on the install or from a week of up-time - not one glitch. Love the stock themes (I'm on dark) and the fact that the system icons are now uniform with the panel in horizontal mode at the top of the screen, which is where I like it. The whole thing feels polished up to an extent that previous versions weren't quite up to, and it runs as fast and smoothly as ever. My laptop has a Realtek RTL8821AE card, which has caused other distributions all sorts of problems. It seems just to be a dodgy connection, and the connection just drops out randomly (it's not a power management issue) which can be partially cured by installing Wicd instead of network-manager but it still experienced problems on Mint, Ubuntu and Antergos. On MX-17, no problems, none. That would be reason enough for me to keep it but here's two more. My Panasonic camera is not supported by libgphoto2 and would never play nicely with any distro (including past MXs). Opening and moving files took literally minutes per file in Thunar and often caused a system crash. This was cured to a large extent by using Nemo or PCManFM as the file manager instead, but MX-17 works perfectly with Thunar! But the biggest issue recently for me has been my iPhone, which has steadfastly refused to work with any other distro. Nada. With MX-17, the iDevice Mounter works perfectly.

So MX-17 so far gets 10/10 from me because for me, there's nothing to criticise. Well done to the team, I'm back home! There's clearly been a lot of work here and wow, for me it's been worth it - thank you! All the best, Rob.
Small business, powered by Linux.
A user, not a coder, demonstrating that a small amount of knowledge is a dangerous thing!

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9392
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX-17 - Wow!

#2 Post by dolphin_oracle » Fri Jan 19, 2018 1:01 pm

well, we try to get better every release, but dang, that's a great testimonial! Thanks!
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
RobbieW
Forum Novice
Forum  Novice
Posts: 8
Joined: Wed Jan 17, 2018 4:00 pm

Re: MX-17 - Wow!

#3 Post by RobbieW » Fri Jan 19, 2018 1:12 pm

You're most welcome - thanks again to everyone who've done all the work to produce this edition. I'm guessing that the newer kernel should take some credit too (and incidentally, as far as I'm concerned, MX-17 justifies the decision to use quite a current one) but this is a cracking distro which I'm really happy to be back with!
Small business, powered by Linux.
A user, not a coder, demonstrating that a small amount of knowledge is a dangerous thing!

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5713
Joined: Sat Jul 15, 2006 10:40 am

Re: MX-17 - Wow!

#4 Post by anticapitalista » Fri Jan 19, 2018 1:27 pm

Does Turboprint work on MX-17?
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
RobbieW
Forum Novice
Forum  Novice
Posts: 8
Joined: Wed Jan 17, 2018 4:00 pm

Re: MX-17 - Wow!

#5 Post by RobbieW » Fri Jan 19, 2018 3:39 pm

It's installed successfully via the .deb and is all configured without issue. For the last week I've been away from my printer but I'll be back in two days - I'll let you know! The issue I had previously was only ever with the tp daemon that powered the print monitor, not the controller, so I expect it to print no problems - but I'll report about the monitor soon - thanks!
Small business, powered by Linux.
A user, not a coder, demonstrating that a small amount of knowledge is a dangerous thing!

User avatar
Paul..
Forum Guide
Forum Guide
Posts: 2277
Joined: Sun Mar 18, 2007 6:34 pm

Re: MX-17 - Wow!

#6 Post by Paul.. » Fri Jan 19, 2018 3:59 pm

Aww...c'mon, we must have broken something!!

Daily: MSI 890FXA-GD70 | AMD Phenom II X6 1055T | GeForce GTX 750 Ti | 8G
Test: Thinkpad T431s | Intel i5-3437U | Intel 3rd gen Graphics | 4G

User avatar
RobbieW
Forum Novice
Forum  Novice
Posts: 8
Joined: Wed Jan 17, 2018 4:00 pm

Re: MX-17 - Wow!

#7 Post by RobbieW » Fri Jan 19, 2018 5:13 pm

Well, nothing I've found so far Paul. When I do find something I'll let you know, but at the risk of making you all blush, I ain't found nothing yet!! :-))
Small business, powered by Linux.
A user, not a coder, demonstrating that a small amount of knowledge is a dangerous thing!

User avatar
RobbieW
Forum Novice
Forum  Novice
Posts: 8
Joined: Wed Jan 17, 2018 4:00 pm

Re: MX-17 - Wow!

#8 Post by RobbieW » Sat Jan 20, 2018 1:25 pm

@anticapitalista I tried Turboprint as installed stock and it had the same problem as previously: it printed fine but the monitor, which reports progress and print levels did not work. The message ERROR: No connection to the Turboprint Daemon was displayed. Some more messing about, which I can't replicate now, showed that the daemon was not running. However, after a quick google I found out how to start the daemon manually and simply incorporated that workaround as an Application Autostart in Settings>Session and Startup. After a reboot the problem is fixed, and now it all works perfectly! I called the autostart 'Start Turboprint Monitor' and used:

Code: Select all

/usr/bin/tprintdaemon 3
As this is the same as the problem used to be on MX15/16 etc, later on I'll drop this workaround as a post in the software and configuration section of the Forum in case others have the same issue. I'm sure it's not an elegant fix but it works - if anyone would like to add a better way of achieving the same thing they're welcome to chip in! And, of course, as it's a proprietary code issue, MX-17 still keeps its 10/10! :happy:
Small business, powered by Linux.
A user, not a coder, demonstrating that a small amount of knowledge is a dangerous thing!

Post Reply

Return to “General”