Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] MX 17 beta1 issue with ath9k-htc

Post Reply
Message
Author
dr-kart
Forum Regular
Forum Regular
Posts: 126
Joined: Sun Oct 22, 2017 8:12 pm

[SOLVED] MX 17 beta1 issue with ath9k-htc

#1 Post by dr-kart » Mon Nov 06, 2017 6:55 am

Not able to establish wifi connection.
Same as before on alphas: viewtopic.php?p=423321#p423321
And
edit /etc/dhcp/dhclient.conf and comment out the line that starts with "prepends" and ends with 127.0.0.1
gives no result.
Last edited by dr-kart on Mon Nov 06, 2017 4:16 pm, edited 1 time in total.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22420
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 17 b1

#2 Post by Jerry3904 » Mon Nov 06, 2017 7:21 am

<We will have a dedicated thread on MX-17 b1 -- once it is announced!>

Could you remind us of your setup?

Code: Select all

inxi -N
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9292
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX 17 b1

#3 Post by dolphin_oracle » Mon Nov 06, 2017 7:37 am

dr-kart wrote:Not able to establish wifi connection.
Same as before on alphas: viewtopic.php?p=423321#p423321
And
edit /etc/dhcp/dhclient.conf and comment out the line that starts with "prepends" and ends with 127.0.0.1
gives no result.

whatever the problem is, its not that particular problem. I'm posting from wifi now and ran all yesterday on wired.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

dr-kart
Forum Regular
Forum Regular
Posts: 126
Joined: Sun Oct 22, 2017 8:12 pm

Re: MX 17 b1

#4 Post by dr-kart » Mon Nov 06, 2017 7:44 am

Network: Card: Qualcomm Atheros AR9271 802.11n driver: ath9k_htc

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22420
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 17 b1

#5 Post by Jerry3904 » Mon Nov 06, 2017 7:47 am

Please check the status shown by MX Network Assistant, and let us know what you find. A screen capture of the first screen would be helpful.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

dr-kart
Forum Regular
Forum Regular
Posts: 126
Joined: Sun Oct 22, 2017 8:12 pm

Re: MX 17 b1

#6 Post by dr-kart » Mon Nov 06, 2017 8:13 am

Actually my wifi hardware works and locates all the wifi networks around. It's just wouldn't connect to one.
You do not have the required permissions to view the files attached to this post.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9292
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX 17 b1

#7 Post by dolphin_oracle » Mon Nov 06, 2017 3:39 pm

looks like a possible issue with your particular atheros card and Network-manager.

There is a post here about a possible work around: https://github.com/qca/open-ath9k-htc-f ... issues/132
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
asinoro
Forum Regular
Forum Regular
Posts: 494
Joined: Mon Feb 22, 2016 12:26 pm

Re: MX 17 b1

#8 Post by asinoro » Mon Nov 06, 2017 4:02 pm

Can we see the outcome of these commands:

Code: Select all

nmcli radio wifi on ; rfkill list all

Code: Select all

sudo lshw -c network
If your case is solved edit [Solved] to your initial post title to help other users.
Don’t forget to Backup your system
Fix your Grub

dr-kart
Forum Regular
Forum Regular
Posts: 126
Joined: Sun Oct 22, 2017 8:12 pm

Re: MX 17 b1

#9 Post by dr-kart » Mon Nov 06, 2017 4:18 pm

dolphin_oracle wrote:looks like a possible issue with your particular atheros card and Network-manager.
There is a post here about a possible work around: https://github.com/qca/open-ath9k-htc-f ... issues/132
Thanks, now it works with this workaround.

Post Reply

Return to “General”