Welcome!

Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-16.1 release info here
  • antiX-17-b1-full release info here
  • antiX-16.2 release info here
New users
  • Please read this first, and don't forget to add system and hardware information to posts!
  • Read Forum Rules

MX 17 Alpha3

Message
Author
polaca57
Forum Novice
Forum  Novice
Posts: 18
Joined: Sun Sep 10, 2017 11:03 pm

MX 17 Alpha3

#1 Postby polaca57 » Wed Oct 04, 2017 9:45 pm

I am downloading MX17 A3 from Sourceforge but I don't see any announcement here or on MX blog.
Come on MX team! Don't be shy :happy:

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 7490
Age: 42
Joined: Wed Jul 12, 2006 1:42 am

Re: MX 17 Alpha3

#2 Postby Adrian » Wed Oct 04, 2017 9:52 pm

Alpha = internal testing. It has some bugs that need to be fixed, it's not really ready for public testing, but it's not a secret either, if you want to try it feel free. We haven't set up a reporting thread, we feel like a first beta will show up soon, that's when we'll call people to test it.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 6394
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX 17 Alpha3

#3 Postby dolphin_oracle » Wed Oct 04, 2017 10:41 pm

what adrian said, plus...

networking will be broken. to fix, edit /etc/dhcp/dhclient.conf and comment out the line that starts with "prepends" and ends with 127.0.0.1. then reboot or restart network-manager.
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 15 32 bit (streaming media player)
acer c720p chromebook - chromeos / MX15-64 (custom snapshot) live USB.
lenovo s21e - antiX-16 MX16(live-usb)

SwampRabbit
Forum Novice
Forum  Novice
Posts: 84
Age: 37
Joined: Tue Jun 14, 2016 2:02 pm

Re: MX 17 Alpha3

#4 Postby SwampRabbit » Thu Oct 05, 2017 7:37 pm

I am pretty sure it is premature, but I did a live USB of MX 17 alpha 3 and it booted as normal on my Lenovo G50 laptop.

Only oddity was that the icons didn’t have a cache.

Will spin it up on one of my Ryzen builds.

Please feel to PM me is any of the devs want some specific extra testing done and I can see what I can do.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 13456
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Alpha3

#5 Postby Stevo » Thu Oct 05, 2017 8:01 pm

SwampRabbit wrote:I am pretty sure it is premature, but I did a live USB of MX 17 alpha 3 and it booted as normal on my Lenovo G50 laptop.

Only oddity was that the icons didn’t have a cache.

Will spin it up on one of my Ryzen builds.

Please feel to PM me is any of the devs want some specific extra testing done and I can see what I can do.


I think we could add a postinst file that runs the cache generating command after the install for the icon packages that don't have that. Let's see if I can get that from a Debian package.

After some research, mainly here, it looks like they will be fine without caches, but the GUI might be a tad slower. Maybe we can just add a button to MX-Tweak to run "sudo update-icon-caches /usr/share/icons/*/"

polaca57
Forum Novice
Forum  Novice
Posts: 18
Joined: Sun Sep 10, 2017 11:03 pm

Re: MX 17 Alpha3

#6 Postby polaca57 » Sat Oct 07, 2017 9:53 pm

I realize this is alpha and hence no announcement. Your blog says "1. There is no official "pre-alpha" released or 'in the wild" at this time. " so I thought it needs to be corrected :)
Alpha 4 is being uploaded as we speak...

User avatar
entropyfoe
Forum Regular
Forum Regular
Posts: 614
Joined: Thu Apr 19, 2007 11:42 am

Re: MX 17 Alpha3

#7 Postby entropyfoe » Sat Oct 07, 2017 10:51 pm

What kernel?
Asus Prime 370X-Pro
AMD Ryzen 1600X (6 cores @ 3.6 GHz)
16 Gig DDR4 3200 (G Skill)
Nvidia -MSI GeForce GT 710 fanless
Samsung 960 NVMe SSD nvme0n1 P1,P2, and P3=MX-16.1, P4=antiX-17 rc1
2TB WD sda1= data
on-board ethernet & sound

SwampRabbit
Forum Novice
Forum  Novice
Posts: 84
Age: 37
Joined: Tue Jun 14, 2016 2:02 pm

Re: MX 17 Alpha3

#8 Postby SwampRabbit » Sat Oct 07, 2017 11:19 pm

Alpha 3 was using a version of 4.9 I think. Haven’t tested it on Ryzen yet, which I assume is why you asked. ;)

User avatar
eugen-b
Forum Regular
Forum Regular
Posts: 572
Joined: Tue Aug 25, 2015 1:56 pm

Re: MX 17 Alpha3

#9 Postby eugen-b » Tue Oct 10, 2017 5:46 pm

Alpha4 external tester here. Hi everybody!
I cannot connect to WiFi on the live system.

Code: Select all

nmcli dev wifi connect "MY_SSID" password "my_password"

Result:
Error: Connection activation failed: (53) the Wi-Fi network could not be found

In nm-applet and nmtui the connection is available, but it doesn't connect after a minute of spinning.

Code: Select all

eugen@mjaro ~> inxi -Nxxxz
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
           Card-2: Ralink RT5572 Wireless Adapter


Edit: Likely related to what @dolphin_oracle wrote about dhcpd.

BTW: The graphical design of Xfce on MX 17 is excellent!!
MX-14 on a Via Eden 1GHz CPU thin client, 3GB RAM, Via VX800 chipset, Via Chrome9 HC GPU, 32GB M.2 SSD;
btrfs with @ and @home subvolumes for MX-14;
added @antiX and @antiXhome subvolumes and copied antix 13.1 base into them, adjusting Grub from MX-14.

Shay2
Forum Regular
Forum Regular
Posts: 145
Age: 74
Joined: Sat Nov 05, 2016 5:32 pm

Re: MX 17 Alpha3

#10 Postby Shay2 » Tue Oct 10, 2017 6:03 pm

I had no trouble getting the wireless to work.

Code: Select all

 inxi -Fxz
System:    Host: mx1 Kernel: 4.9.0-3-amd64 x86_64 bits: 64 gcc: 6.3.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: MX-17.a4_x64 Horizon 6 October 2017
Machine:   Device: laptop System: Dell product: Latitude E6430 v: 01 serial: N/A
           Mobo: Dell model: 0H3MT5 v: A00 serial: N/A BIOS: Dell v: A17 date: 08/19/2015
Battery    BAT0: charge: 99.9 Wh 137.0% condition: 72.9/99.9 Wh (73%)
           model: LGC-LGC3.0 DELL J7KGM29 status: Full
CPU:       Dual core Intel Core i5-3320M (-HT-MCP-) arch: Ivy Bridge rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10366
           clock speeds: max: 3300 MHz 1: 1199 MHz 2: 1205 MHz 3: 1200 MHz 4: 1290 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF108GLM [NVS 5200M] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.2 )
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1600x900@59.99hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile
           version: 3.3 Mesa 13.0.6 Direct Render: Yes
Audio:     Card Intel 7 Series/C216 Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.9.0-3-amd64
Network:   Card-1: Intel 82579LM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: f060 bus-ID: 00:19.0
           IF: eno1 state: down mac: <filter>
           Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 136.1GB (3.3% used)
           ID-1: /dev/sda model: SanDisk_SDSSDA12 size: 120.0GB
           ID-2: USB /dev/sdb model: USB_Flash_Drive size: 16.0GB
Partition: ID-1: / size: 6.2G used: 7.1M (1%) fs: overlay dev: N/A
           ID-2: swap-1 size: 4.69GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A gpu: 50.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 209 Uptime: 1 min Memory: 406.5/7893.3MB
           Init: SysVinit runlevel: 5 Gcc sys: 6.3.0 Client: Shell (bash 4.4.121) inxi: 2.3.40


USB stick.

Use Unetbootin in Antix 16 with all updates, to make it.


Return to “General”

Who is online

Users browsing this forum: No registered users and 3 guests