Welcome!
Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Compiz and ATI x1270 in M8

User avatar
joany
Forum Veteran
Forum Veteran
Posts: 5918
Joined: Mon Feb 12, 2007 1:45 pm

Re: Compiz and ATI x1270 in M8

#11

Post by joany » Tue Jun 17, 2014 4:38 pm

TenderFoot wrote: However, before proceding need to install build-essential via synaptic but don't understand the bit about kernel headers?
With Synaptic open, do a search on "linux-headers" and the relevant packages will come up. Make sure the packages correspond to your kernel version. To find out what that it is, open a terminal and enter the command "uname -r."

If the header packages are already installed, then you don't need to do anything. If not, install them. You might have to reboot to have them take effect.
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9590
Joined: Wed Jul 12, 2006 2:26 pm

Re: Compiz and ATI x1270 in M8

#12

Post by kmathern » Tue Jun 17, 2014 4:48 pm

I usually just run the `m-a prepare` command. It will install build-essential & the compiler related stuff, and the kernel headers all at once.

Code: Select all

su -c 'apt-get install module-assistant' #module-assistant should already be installed in M8.0 -- if it is this step won't do anything

Code: Select all

su -c 'm-a prepare'

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 628
Joined: Sun May 03, 2009 2:34 pm

Re: Compiz and ATI x1270 in M8

#13

Post by TenderFoot » Tue Jun 17, 2014 5:22 pm

Emergency - do I choose

Code: Select all

1 Install Driver 8.582 on Xorg 7.1 7.2 7.3 64bit
or
2 Generate Distribution Specific Driver Package
Which is not the promised 9.2 and retrograde to the 8.7 in repo?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9590
Joined: Wed Jul 12, 2006 2:26 pm

Re: Compiz and ATI x1270 in M8

#14

Post by kmathern » Tue Jun 17, 2014 5:29 pm

TenderFoot wrote:Emergency - do I choose

Code: Select all

1 Install Driver 8.582 on Xorg 7.1 7.2 7.3 64bit
or
2 Generate Distribution Specific Driver Package
Which is not the promised 9.2 and retrograde to the 8.7 in repo?
I think you would choose option 1.

I don't think that "8.582" in the "Install Driver 8.582 on Xorg 7.1 7.2 7.3 64bit" selection will necessarily match the 9.2 (or 9-2) of the .run installer version.

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 628
Joined: Sun May 03, 2009 2:34 pm

Re: Compiz and ATI x1270 in M8

#15

Post by TenderFoot » Tue Jun 17, 2014 7:04 pm

OK - what now?

Obviously I don't know yet whether successful but I'm now at the command prompt (as myself not root anymore)....

exit, shutdown, startx...?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9590
Joined: Wed Jul 12, 2006 2:26 pm

Re: Compiz and ATI x1270 in M8

#16

Post by kmathern » Tue Jun 17, 2014 7:20 pm

Was /etc/X11/xorg.conf created or modified during the install process and set to use the fglrx driver? You can take a look at it with:

Code: Select all

nano /etc/X11/xorg.conf
If it's been set to use the fglrx driver, I think all you should need to do is restart the computer.


If /etc/X11/xorg.conf hasn't been set to use the fglrx driver, I think you can run the following:

Code: Select all

su -c 'aticonfig --initial'
and then restart the computer.

Mepis 8.0 doesn't have the KMS drivers, so you shouldn't need to blacklist anything, or run the install a 2nd time like you need to do with newer Mepis/Debian releases.

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 628
Joined: Sun May 03, 2009 2:34 pm

Re: Compiz and ATI x1270 in M8

#17

Post by TenderFoot » Tue Jun 17, 2014 7:35 pm

Sorry but I paniced. Managed to exit, logon as root then shutdown.

However, on reboot, all I get to is the login which is just a few unreadable blocks with a big square mouse pointer - which is modified behaviour as it should be autologin.

Anyway, when reboot and get back to grub menu, how do I get to cli - to try your above suggestions - as is not a menu option?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9590
Joined: Wed Jul 12, 2006 2:26 pm

Re: Compiz and ATI x1270 in M8

#18

Post by kmathern » Tue Jun 17, 2014 7:45 pm

TenderFoot wrote:Sorry but I paniced. Managed to exit, logon as root then shutdown.

However, on reboot, all I get to is the login which is just a few unreadable blocks with a big square mouse pointer - which is modified behaviour as it should be autologin.

Anyway, when reboot and get back to grub menu, cli - to try your above suggestions - is not an option?
I'm not exactly sure what you're saying.

Can you boot to init level 3, login as root, and run what I mentioned in my last post?

Adding a "3" (without the quotes) to the kernel options line should cause it to stop the boot at init level 3 and present you with a login prompt.

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 628
Joined: Sun May 03, 2009 2:34 pm

Re: Compiz and ATI x1270 in M8

#19

Post by TenderFoot » Tue Jun 17, 2014 7:58 pm

Yes, I'd tried that but the splash still loads, the progress bar stops at about 40% and no key combination will get me out of it - but the boot process was flakey anyway.

Oh, well, back to the drawing board - reburn, reinstall and try again...!

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9590
Joined: Wed Jul 12, 2006 2:26 pm

Re: Compiz and ATI x1270 in M8

#20

Post by kmathern » Tue Jun 17, 2014 8:00 pm

TenderFoot wrote:Yes, I'd tried that but the splash still loads, the progress bar stops at about 40% and no key combination will get me out of it - but the boot process was flakey anyway.

Oh, well, back to the drawing board - reburn, reinstall and try again...!
disable the splash (remove the word "splash" from the kernel options line)


edit: when I say "kernel options line" I mean the editable line at the bottom of the grub screen when it's displaying the menu

Post Reply

Return to “Software / Configuration”