Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Compiz and ATI x1270 in M8

Message
Author
User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 605
Joined: Sun May 03, 2009 2:34 pm

Compiz and ATI x1270 in M8

#1 Post by TenderFoot » Mon Jun 16, 2014 7:35 pm

Have just pampered my laptop and notebook with shiny new 1Tb hdd's and so comes the challenge of reinstalling M8 (still like it for itself and kde3).

All is well on the Tosh (having frequently referred back to many earlier posts!) and almost there on the notebook.

The X1270 has been discussed in earlier threads but not in the context of Compiz. The Radeon(xorg) driver is installed but launching Compiz results in

Code: Select all

Chris@Notebook:~$ compiz --replace
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:05.0 0300: 1002:791f (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1366x768) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz.real (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
/usr/bin/compiz.real (core) - Error: Failed to manage screen: 0
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0
/usr/bin/compiz: line 393: /usr/bin/metacity: No such file or directory
/usr/bin/compiz: line 393: exec: /usr/bin/metacity: cannot execute: No such file or directory
Chris@Notebook:~$
At one point, I did also try the fglrx(official 3d) option but that was not satisfactory resulting in a shimmerring display so abandoned that without even trying Compiz!

Is the situation hopeless for this one last hurdle?

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4481
Joined: Wed Jul 12, 2006 4:05 pm

Re: Compiz and ATI x1270 in M8

#2 Post by timkb4cq » Mon Jun 16, 2014 8:35 pm

The X1200 series cards didn't work well with the radeon driver until the version in Wheezy, so you can run compbiz with MX-14 but not with M8. I did have an X1250 running well with the ati Catalyst driver in M8 but I don't think it was the 9-3 version currently on the AMD site. IIRC, the sparkling was a reversion from 9-1 and I had to downgrade to eliminate it. Maybe you can find that version somewhere.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9398
Joined: Wed Jul 12, 2006 2:26 pm

Re: Compiz and ATI x1270 in M8

#3 Post by kmathern » Mon Jun 16, 2014 9:03 pm

timkb4cq wrote:The X1200 series cards didn't work well with the radeon driver until the version in Wheezy, so you can run compbiz with MX-14 but not with M8. I did have an X1250 running well with the ati Catalyst driver in M8 but I don't think it was the 9-3 version currently on the AMD site. IIRC, the sparkling was a reversion from 9-1 and I had to downgrade to eliminate it. Maybe you can find that version somewhere.
It looks like Warren had 8-7 in his Mepis 8.0 repo: ftp://ftp.mepis.com/mepis/dists/mepis-8 ... 6/Packages (search for "Package: fglrx"), I think the Mepis X Windows Assistant will install it.

The regular Lenny repos have 8-12 (http://archive.debian.net/source/lenny/fglrx-driver), and the Lenny-backports repos have 10-4 (http://archive.debian.net/source/lenny- ... lrx-driver). It might be harder to install them though (I don't think Warren's X Windows Assistant will install them).

And there's other versions from snapshot.debian.org (http://snapshot.debian.org/package/fglrx-driver/)

And it looks like sgfxi goes back to a 11-1 version.

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 605
Joined: Sun May 03, 2009 2:34 pm

Re: Compiz and ATI x1270 in M8

#4 Post by TenderFoot » Tue Jun 17, 2014 10:37 am

Thanks for your replies.

Unfortunately I don't know where I'm going here, especially as you mention so many different versions - and am unfamiliar with the ati card and driver numbering conventions! (In a recent thread (http://forum.mepiscommunity.org/viewtop ... 17&t=35452 which ran to 5 pages!), I had similar difficulties with nvidia 6200 card yet am not clear on the resolution as it was a combination of guidance by you guys and fumbling about followed by "magical" success!).

Anyway, you mention 9.1 and 9.3 drivers (timkb4cq) then 8.7, 8.12, 10.4 and 11.1 drivers (kmathern). Seeking fglrx in Synaptic, I observe that it offers 8.7 and assume that is what was installed when trying the "official 3d" option in MXWA with the result described in OP.

So, what is the consensus on which driver to try and how should it be installed. I've looked at the links but not sure what to pick or what to do with it/them?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9398
Joined: Wed Jul 12, 2006 2:26 pm

Re: Compiz and ATI x1270 in M8

#5 Post by kmathern » Tue Jun 17, 2014 10:44 am

What are the fglrx-* packages that are currently installed?

Code: Select all

dpkg -l | grep fglrx

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 605
Joined: Sun May 03, 2009 2:34 pm

Re: Compiz and ATI x1270 in M8

#6 Post by TenderFoot » Tue Jun 17, 2014 12:01 pm

None - I should have made that clear in last post (though implicly suggested so as Synaptic indicates not so and "radeon 3d" in MXWA not used because it causes the shimmering problem in OP).

Confirmed by your command returning nothing at all.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4481
Joined: Wed Jul 12, 2006 4:05 pm

Re: Compiz and ATI x1270 in M8

#7 Post by timkb4cq » Tue Jun 17, 2014 1:18 pm

10-4 and 11-1 will not work. ATI dropped X1200 series support after 9-3.
In fact there's no Catalyst driver for the X1200 series that will work even with the squeeze repos. I had to change my "daily driver" computer because of that when I needed to run M8.5

I seldom toss anything away, though - I'm a digital pack-rat - and I've located the ati 9-2 driver file that sgfxi downloaded in 2009 and installed. (Use Right Click & Save Link As or the browser will open it as text.) http://teharris.net/misc/ati-driver-ins ... x86_64.run
It can be installed manually. open a Console Terminal with <ctrl><alt>F2, log in as root, run

Code: Select all

/etc/init.d/kdm stop
Navigate to where you saved the file and run

Code: Select all

sh ati-driver-installer-9.2-x86.x86_64.run
You'll need to have your kernel headers and build-essential installed before you start.
If it finishes succesfully you should reboot.
You may want to download sgfxi first (to /usr/local/bin) so you can use it to revert easily to the Xorg driver if things go sideways.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9398
Joined: Wed Jul 12, 2006 2:26 pm

Re: Compiz and ATI x1270 in M8

#8 Post by kmathern » Tue Jun 17, 2014 1:38 pm

timkb4cq wrote:10-4 and 11-1 will not work. ATI dropped X1200 series support after 9-3. ...
I was kind of wondering if that might be the case. I'm having a hard time matching the versions of the ATi driver to the hardware they support, Nvidia is a lot easier to figure out.

Does the ati .run installer create a suitable /etc/X11/xorg.conf file ?

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4481
Joined: Wed Jul 12, 2006 4:05 pm

Re: Compiz and ATI x1270 in M8

#9 Post by timkb4cq » Tue Jun 17, 2014 1:51 pm

IIRC, it's supposed to. I haven't used the bare .run file method since the MEPIS 7 days so I can't be very sure.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 605
Joined: Sun May 03, 2009 2:34 pm

Re: Compiz and ATI x1270 in M8

#10 Post by TenderFoot » Tue Jun 17, 2014 4:23 pm

Thank you both again.

Have downloaded sgfxi as advised by kmathern and am currently downloading the driver from timkb4cq's link.

However, before proceding need to install build-essential via synaptic but don't understand the bit about kernel headers?

Post Reply

Return to “Software / Configuration”