Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Meltdown & Spectre [resolved]

Message
Author
bigbenaugust
Forum Novice
Forum  Novice
Posts: 50
Joined: Wed Dec 20, 2017 10:41 am

Re: Meltdown & Spectre [resolved]

#11 Post by bigbenaugust » Wed Jan 10, 2018 11:48 am

Is it me, or does the new 4.14.12 in the 4.14-0 package sit for a while, spit out a "gave up waiting for suspend/resume device" and then boot normally? Maybe I just didn't notice it with the 4.13...
--Ben

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10085
Joined: Sun Dec 16, 2007 1:17 pm

Re: Meltdown & Spectre [resolved]

#12 Post by dolphin_oracle » Wed Jan 10, 2018 11:58 am

its you. :happy:

seriously though

it could be but its probably not the kernel, but it might be related to other things. I'm running 4.14.12 with no issues like that.

have you reformatted your swap partition lately? if you would like to diagnose the resume issue, please start another thread.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
richb
Administrator
Posts: 17507
Joined: Wed Jul 12, 2006 2:17 pm

Re: Meltdown & Spectre [resolved]

#13 Post by richb » Wed Jan 10, 2018 12:03 pm

I am not seeing that either.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

bigbenaugust
Forum Novice
Forum  Novice
Posts: 50
Joined: Wed Dec 20, 2017 10:41 am

Re: Meltdown & Spectre [resolved]

#14 Post by bigbenaugust » Wed Jan 10, 2018 12:07 pm

Sure thing, and sorry for the faux-pas.
Might be related to the encrypted swap, but I will check when I am back in front of the machine when I get home.
--Ben

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10085
Joined: Sun Dec 16, 2007 1:17 pm

Re: Meltdown & Spectre [resolved]

#15 Post by dolphin_oracle » Wed Jan 10, 2018 12:24 pm

bigbenaugust wrote:Sure thing, and sorry for the faux-pas.
Might be related to the encrypted swap, but I will check when I am back in front of the machine when I get home.

no worries dude!
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 3636
Joined: Sun May 27, 2007 5:37 am

Re: Meltdown & Spectre [resolved]

#16 Post by asqwerth » Wed Jan 10, 2018 1:03 pm

Just reporting that Liquorix 4.14-12 from MX Test Repo works fine with Virtualbox on my PC.

Oops, on MX15/16.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

dr-kart
Forum Regular
Forum Regular
Posts: 129
Joined: Sun Oct 22, 2017 8:12 pm

Re: Meltdown & Spectre [resolved]

#17 Post by dr-kart » Wed Jan 10, 2018 4:12 pm

Good news. intel-microcode updated to 20171215 version.
...after reboot I have:

Code: Select all

 dmesg | grep "microcode updated early to"
[    0.000000] microcode: microcode updated early to revision 0x1c, date = 2015-02-26
is it ok?
Edit: I guess my cpu just didn't get new microcode. Anyhow v.20180108 is on the way and in debian sid repo already https://packages.debian.org/search?keyw ... -microcode

User avatar
Mauser
Forum Regular
Forum Regular
Posts: 754
Joined: Mon Jun 27, 2016 7:32 pm

Re: Meltdown & Spectre [resolved]

#18 Post by Mauser » Fri Jan 12, 2018 1:02 pm

bigbenaugust wrote:Is it me, or does the new 4.14.12 in the 4.14-0 package sit for a while, spit out a "gave up waiting for suspend/resume device" and then boot normally? Maybe I just didn't notice it with the 4.13...
In my experience the Liquorix 64 bit kernel from the test repo causes a very long pause while booting and one time it froze and then unfroze after a while pushing keyboard keys and the mouse. Changing it to the MX-17 kernel 4.14.0-12.1-liquorix-amd64 x86_64 corrected that issue. Now it boots great.

bigbenaugust
Forum Novice
Forum  Novice
Posts: 50
Joined: Wed Dec 20, 2017 10:41 am

Re: Meltdown & Spectre [resolved]

#19 Post by bigbenaugust » Fri Jan 12, 2018 2:22 pm

In the end, I just disabled system suspend with the noresume flag in grub. Problem solved.
--Ben

Post Reply

Return to “General”