Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Install Programs?

Those new to MEPIS or not very experienced can post their questions here.
Message
Author
Stephenw4tol
Forum Novice
Forum  Novice
Posts: 4
Joined: Fri Jun 17, 2016 11:28 am

Install Programs?

#1 Post by Stephenw4tol » Fri Jun 17, 2016 10:51 pm

Hi, name here is Stephen. I have been a Linux user for going on two years now. I use Linux Lite on one of my laptops. I am fairly new to MX. My question is: when I down load a program from Synaptic Package Manager, it will download just fine, but, when I try to run the program from the Menu, it doesn't show up there. What am I doing wrong? I can pull up File Manager and see the program files there but don't know how to make it run? Thanks for all help.

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 1985
Joined: Mon Nov 21, 2011 5:50 pm

Re: Install Programs?

#2 Post by Gordon Cooper » Fri Jun 17, 2016 10:55 pm

Hi Stephen, welcome to MX ! Is it any particular program that that will not run, or all of them?
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9275
Joined: Sun Dec 16, 2007 1:17 pm

Re: Install Programs?

#3 Post by dolphin_oracle » Fri Jun 17, 2016 10:55 pm

it depends on the app. for some reason sometimes the panel needs to restart for new items to show up. try running

xfce4-panel -r

and see if the app shows up.

what app in particular?
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

Stephenw4tol
Forum Novice
Forum  Novice
Posts: 4
Joined: Fri Jun 17, 2016 11:28 am

Re: Install Programs?

#4 Post by Stephenw4tol » Fri Jun 17, 2016 11:38 pm

I was trying one of the Amateur Radio apps, being a ham. The one in particular was called Aldo - a Morse Code program. I've noticed that other programs I've downloaded won't run either. I know I'm not doing something right, just don't know what it is.

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 1985
Joined: Mon Nov 21, 2011 5:50 pm

Re: Install Programs?

#5 Post by Gordon Cooper » Sat Jun 18, 2016 12:02 am

Odd, I downloaded aldo and it will not run for me either, So, tried another CWE tutor xcwcp this time, downloaded and worked for me, though I could not find it in the
Whisker menu, so selected Run a program, entered xcwcp into the box and away it went. If you are using the menu, a left click on the appropriate icon should start the
selected program for you, A left click gives you the option of placing it on the desktop, in the panel, or removing it. Remember that if you are typing the application name
that Mx is case sensitive. It sees aldo, Aldo and ALDO as three different names. if things still not working for you, give us the steps you are using. Will take another look at
also to see if anything is missing.
73,
Gordon ZL1KL
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 1985
Joined: Mon Nov 21, 2011 5:50 pm

Re: Install Programs?

#6 Post by Gordon Cooper » Sat Jun 18, 2016 12:11 am

Aldo is there. Have just run it from the terminal, no problems. The download is very small, so probably it does not have a GUI and is meant to be run from the command line.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

Stephenw4tol
Forum Novice
Forum  Novice
Posts: 4
Joined: Fri Jun 17, 2016 11:28 am

Re: Install Programs?

#7 Post by Stephenw4tol » Sat Jun 18, 2016 1:09 am

Thanks for all the help! I will try your suggestions. Going to look at the xcwcp program too. I can do morse code, just want to brush up my skills a little. Thanks again.

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1414
Joined: Sun Dec 16, 2007 6:29 pm

Re: Install Programs?

#8 Post by GuiGuy » Sat Jun 18, 2016 9:20 am

Do hams still use Morse?
I was a G3... in the nineteen-fifties. Long lapsed but cannot forget the Morse code!
--... ...--

Stephenw4tol
Forum Novice
Forum  Novice
Posts: 4
Joined: Fri Jun 17, 2016 11:28 am

Re: Install Programs?

#9 Post by Stephenw4tol » Sat Jun 18, 2016 9:49 am

Morse code? Absolutely! I think CW will always be around even in this digital world we live in. There are many digital modes in ham radio today and most are a form of high speed morse code. I love morse code, it will get thru when voice can't. And, besides, its fun.
Thanks everyone again for all your help. I need to get more versed on using the terminal.

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Joined: Wed Aug 02, 2006 12:12 pm

Re: Install Programs?

#10 Post by eemaestro » Sat Jun 18, 2016 1:59 pm

I used Code Quick by Jerry Wheeler to learn Morse code. I highly recommend it. It's a set of audio tapes or CD's and flash cards, not a program. It is scaleable.

Post Reply

Return to “Newbies”