Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

test of new site

Forum for discussion and implementation of project work to enhance mepis.org and other MEPIS Websites
Message
Author
User avatar
peregrine
Forum Regular
Forum Regular
Posts: 956
Joined: Wed Jul 12, 2006 7:39 am

Re: test of new site

#21 Post by peregrine » Sun Oct 16, 2016 9:34 am

On this forum you do not see a favicon? I see one, but it is the old mepis one. Will look for where you change that.
Asus A78M - AMD A10-6800K - 8GB Ram - 120GB SSD - Samsung SyncMaster 2243SWX LCD MX14.2 & MX15 ------ Asus X550LA intel i5 4200 / MX16 | MX17B2

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 8188
Joined: Wed Jul 12, 2006 1:42 am

Re: test of new site

#22 Post by Adrian » Sun Oct 16, 2016 10:10 am

Yeah, I don't see it in tab and in my saved bookmark, usually in Chrome when I load a site the favicon updates on the bookmark too. I do see the old mepis favicon in Firefox.

User avatar
rokytnji.1
Forum Regular
Forum Regular
Posts: 668
Joined: Sun Apr 13, 2014 9:06 pm

Re: test of new site

#23 Post by rokytnji.1 » Sun Oct 16, 2016 10:51 am

Testing. :needcoffee:

Code: Select all

System:    Host: biker Kernel: 4.8.1-antix.1-686-smp-pae i686 (32 bit) Desktop: IceWM 1.3.8
           Distro: antiX-15-V_386-full Killah P 30 June 2015
Please read this
Mow the lawn
Image

antiX-Dave
Forum Regular
Forum Regular
Posts: 363
Joined: Mon Apr 16, 2012 4:51 pm

Re: test of new site

#24 Post by antiX-Dave » Sun Oct 16, 2016 10:59 am

Peregrine is it possible to build a set of apache mod_rewrite rules to rewrite mepiscommunity.org to mxlinux.org rather than a redirect. I am assuming that the underlying url structure is the same just the domain is changed?

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 1842
Joined: Mon Nov 21, 2011 5:50 pm

Re: test of new site

#25 Post by Gordon Cooper » Sun Oct 16, 2016 3:16 pm

Several hours behind the rest of the world, glad to say that new site working is well
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Toshiba Portege Tablet MX16, WinXP.

User avatar
BitJam
Forum Guide
Forum Guide
Posts: 2472
Joined: Sat Aug 22, 2009 11:36 pm

Re: test of new site

#26 Post by BitJam » Sun Oct 16, 2016 3:35 pm

peregrine wrote:Just added a wildcard redirect for http://forum.mepiscommunity.org/
it works now
Maybe we should have it redirect to a landing page to let people know about the change so the can change their bookmarks, and so on. Also, if you have ready access to the logs of the original site then we can use the referer (sic) to find out which sites are still linking to the original site.
Will I cry when it's all over?
When I die will I see Heaven?

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 8188
Joined: Wed Jul 12, 2006 1:42 am

Re: test of new site

#27 Post by Adrian » Sun Oct 16, 2016 4:04 pm

I see now the favicon. Thanks!

antiX-Dave
Forum Regular
Forum Regular
Posts: 363
Joined: Mon Apr 16, 2012 4:51 pm

Re: test of new site

#28 Post by antiX-Dave » Sun Oct 16, 2016 4:34 pm

BitJam wrote:
peregrine wrote:Just added a wildcard redirect for http://forum.mepiscommunity.org/
it works now
Maybe we should have it redirect to a landing page to let people know about the change so the can change their bookmarks, and so on. Also, if you have ready access to the logs of the original site then we can use the referer (sic) to find out which sites are still linking to the original site.
+1 on the log file idea

User avatar
richb
Administrator
Posts: 16604
Joined: Wed Jul 12, 2006 2:17 pm

Re: test of new site

#29 Post by richb » Sun Oct 16, 2016 4:57 pm

But if it redirects to the new site why do we need a landing page? All redirects work for me
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
BitJam
Forum Guide
Forum Guide
Posts: 2472
Joined: Sat Aug 22, 2009 11:36 pm

Re: test of new site

#30 Post by BitJam » Sun Oct 16, 2016 5:24 pm

richb wrote:But if it redirects to the new site why do we need a landing page? All redirects work for me
It is the polite thing to do. It lets people know there has been a change and they aren't getting hijacked nor is their memory faulty. It also lets them know in case they want to update their bookmarks.

Direct redirects are fine for now by relying on redirects from the old site going forward is crufty and is bound to cause additional problems down the road. For example, if people rely on redirects and aren't aware of the switch and the old site is down then they won't be able to get through even though the new site is working fine. We don't have to do this instantly but I think it would be good to do it in the next few days.

The landing page can use the referer (sic) field to create a link to the equivalent page on the new site.
Will I cry when it's all over?
When I die will I see Heaven?

Post Reply

Return to “Website”