Welcome!

Please read this important information about Spectre and Meltdown vulnerabilities.
Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 Final release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

"Startup Application"

Here is where all questions and discussions about KDE should go.
Message
Author
User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Age: 2017
Joined: Wed Aug 02, 2006 12:12 pm

"Startup Application"

#1 Postby eemaestro » Sun Jan 04, 2015 2:47 pm

A poster at another forum claims to use this "Startup Application" under Ubuntu 14.04.1.
http://i.imgur.com/1uOKxor.png

Regarding this script he writes,
"The script contents I posted above are simply in a file named backup. It's located in /usr/local/bin and owned by root:root with 755 permissions, so it has executable permissions for anybody, her
[ user ] included, but cannot be edited by anyone except root."

Anybody know how to do this (automate an application to start up at login) under KDE 4.84? Am running MEPIS 12.

Anybody thing automating backup is a good idea? I understand it won't work unless the media are properly installed as mount points on the system before the script runs.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4028
Joined: Wed Jul 12, 2006 4:05 pm

Re: "Startup Application"

#2 Postby timkb4cq » Sun Jan 04, 2015 2:52 pm

Make your script executable. You don't need to have it owned by root.
copy it to the ~/.kde/Autostart/ folder and it will launch on login.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Gaer Boy
Forum Guide
Forum Guide
Posts: 2097
Age: 82
Joined: Sat Jun 06, 2009 6:06 am

Re: "Startup Application"

#3 Postby Gaer Boy » Sun Jan 04, 2015 3:28 pm

eemaestro wrote:Anybody thing automating backup is a good idea? I understand it won't work unless the media are properly installed as mount points on the system before the script runs.

How can it not be a good idea? My backup runs at 19:00 each day (while I'm having dinner). It backs up my 3 data partitions to a corresponding set on a USB HDD. LuckyBackup mounts the backup partitions, carries out the backups and unmounts the partitions. All I have to do is switch the HDD on before and off afterwards.

Phil

AsRock FM2A88X-ITX+, A8-6500, 8GB, 120GB Samsung SSD (GPT), 1TB HDD (MBR), MX-16
Lenovo Thinkpad X220, dual-core i5, 3MB, 320GB Hitachi HDD, Win7, MX-16.1

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Age: 2017
Joined: Wed Aug 02, 2006 12:12 pm

Re: "Startup Application"

#4 Postby eemaestro » Sun Jan 04, 2015 5:27 pm

Any idea why this didn't run when I logged back in?

Code: Select all

$ cd .kde/Autostart
jon@mepis1:~/.kde/Autostart$ ls
loginscript
jon@mepis1:~/.kde/Autostart$ ls -Fdltr loginscript
-rwxr-xr-x 1 jon users 146 Jan  4 16:21 loginscript*
jon@mepis1:~/.kde/Autostart$ cat loginscript
#Startup script
#!/bin/bash
echo "If you see this message, success is yours."
date -d today '+%a %b %e, %Y %I:%M %p'
echo "'nuff said."

User avatar
DBeckett
Forum Guide
Forum Guide
Posts: 2779
Joined: Sat May 16, 2009 3:59 pm

Re: "Startup Application"

#5 Postby DBeckett » Sun Jan 04, 2015 6:06 pm

 
Maybe it did run—you just didn't see anything. It needs to run inside a terminal to be seen.

Or you could have it output to a file that you can read after you log in to confirm.

Code: Select all

 #Startup script
#!/bin/bash
echo "If you see this message, success is yours."  >> /home/jon/loginoutput
date -d today '+%a %b %e, %Y %I:%M %p' >> /home/jon/loginoutput
echo "'nuff said." >> /home/jon/loginoutput
Gigabyte 990FXA-UD3, AMD FX-6100 hex-core, 3.3GHz, 8G, Radeon HD6570

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Age: 2017
Joined: Wed Aug 02, 2006 12:12 pm

Re: "Startup Application"

#6 Postby eemaestro » Sun Jan 04, 2015 7:10 pm

DBeckett,
I modified my script as per your suggestion. However, file loginoutput was never created.
Furthermore, KDE became disabled until I removed all scripts from ~/.kde/Autostart/
By "became disabled", I mean no icon popped up when I moused over the MEPIS button
and no menu popped up when I clicked on it.
Plus, no dialog box pops up when I click on MEPIS button....Leave.....Log out.
How can I restore KDE ?

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Age: 2017
Joined: Wed Aug 02, 2006 12:12 pm

Re: "Startup Application"

#7 Postby eemaestro » Sun Jan 04, 2015 7:18 pm

Okay, I restored KDE by removing all files from .kde/Autostart and
then typing <Alt><Print scrn>REISUB,
and then logging back in.


Return to “KDE”

Who is online

Users browsing this forum: No registered users and 1 guest