Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

UPDATE: Poedit v2.2.1 (wxWidgets 3.0.4)

For developer discussion on package requests
app4soft
Forum Regular
Forum Regular
Posts: 103
Joined: Tue Mar 20, 2018 1:45 pm

UPDATE: Poedit v2.2.1 (wxWidgets 3.0.4)

#1

Post by app4soft » Tue Apr 03, 2018 10:10 pm

Last edited by app4soft on Sun May 05, 2019 10:50 pm, edited 5 times in total.

User avatar
Stevo
Developer
Posts: 19884
Joined: Fri Dec 15, 2006 8:07 pm

Re: Update: Poedit v2.0.6 (poedit, poedit2)

#2

Post by Stevo » Tue Apr 03, 2018 10:31 pm

This one should be easier because it's in upstream Debian already.

User avatar
Stevo
Developer
Posts: 19884
Joined: Fri Dec 15, 2006 8:07 pm

Re: Update: Poedit v2.0.6 (poedit, poedit2)

#3

Post by Stevo » Tue Apr 03, 2018 11:10 pm

Well, not that easy, since the configure step fails with a message that it needs at least wXwidgets 3.0.3, and we have just 3.0.2. Debian didn't list that as a minimum build-depend. Backporting wxwidgets has not been difficult in the past, just a bigger build.

User avatar
Stevo
Developer
Posts: 19884
Joined: Fri Dec 15, 2006 8:07 pm

Re: Update: Poedit v2.0.6 (poedit, poedit2)

#4

Post by Stevo » Wed Apr 04, 2018 2:46 pm

Wxwidgets 3 backport and poedit 2.0.6 are on the way to the test repo.

app4soft
Forum Regular
Forum Regular
Posts: 103
Joined: Tue Mar 20, 2018 1:45 pm

Re: Update: Poedit v2.0.6 (poedit, poedit2)

#5

Post by app4soft » Fri Apr 06, 2018 8:59 pm

Stevo wrote:Wxwidgets 3 backport and poedit 2.0.6 are on the way to the test repo.
I see that Poedit 2.0.6 and wxWidgets 3.0.4 now available in testing repo, so should I mark this request as "SOLVED" now?

User avatar
Stevo
Developer
Posts: 19884
Joined: Fri Dec 15, 2006 8:07 pm

Re: Update: Poedit v2.0.6 (poedit, poedit2)

#6

Post by Stevo » Fri Apr 06, 2018 10:03 pm

If you have installed and tested the new version, yes, please mark it.

app4soft
Forum Regular
Forum Regular
Posts: 103
Joined: Tue Mar 20, 2018 1:45 pm

Re: Update: Poedit v2.1.1 (wxWidgets 3.0.4)

#7

Post by app4soft » Sat Sep 08, 2018 7:12 pm

Please, update Poedit to version 2.1.1

P.S.: Info in the topic header updated.

User avatar
Stevo
Developer
Posts: 19884
Joined: Fri Dec 15, 2006 8:07 pm

Re: Update: Poedit v2.1.1 (wxWidgets 3.0.4)

#8

Post by Stevo » Sun Sep 09, 2018 6:42 pm

Working on it, it needed a couple additional backports first for build-depends.

app4soft
Forum Regular
Forum Regular
Posts: 103
Joined: Tue Mar 20, 2018 1:45 pm

Re: Update: Poedit v2.2 (wxWidgets 3.0.4)

#9

Post by app4soft » Wed Nov 14, 2018 11:52 am

Update Poedit to v2.2.

(info in topic header updated)

User avatar
Stevo
Developer
Posts: 19884
Joined: Fri Dec 15, 2006 8:07 pm

Re: Update: Poedit v2.2 (wxWidgets 3.0.4)

#10

Post by Stevo » Wed Nov 14, 2018 6:54 pm

Building for MX 17 now...

Post Reply

Return to “Package Requests / Status”