The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

How I got a bricked Fairphone 2 back to life, using MX-16.1

Here you can post about what you did to get MX to work right with your computer or if hardware worked right out of the box for you. This is for the computers and/or hardware that is normally hard to get working right in Linux or MX.
Post Reply
User avatar
Forum Guide
Forum Guide
Posts: 1048
Joined: Mon Feb 13, 2017 12:09 pm

How I got a bricked Fairphone 2 back to life, using MX-16.1


Post by MX-16_fan » Sat Nov 11, 2017 4:23 pm

I am documenting here how I got a bricked Fairphone 2 back to life. In Fairphone's official forum, documentation and discussion relating to this smartphone is only available on a rather unstructured and half-qualified level, and their forum software is a disaster (just press Ctrl+f on any page in the forum and you'll know what I mean), so maybe some of you will enjoy having this report here.

I just had the chance of testing a new Fairphone 2 (https://www.fairphone.com/en/) (the latest version that ships with the improved main camera).

Out-of-the-box, Fairphone offers two operating systems for this device: One pretty much standard Android, and one without the Google stuff (similar to the former CyanogenMod) (https://support.fairphone.com/hc/en-us/ ... -2-run-on-).

Both versions feature a built-in updater, so you can do major updates over the air (OTA), and change the OS from "Open" to non-open and back (theoretically).

Now I had some big problem with the "Open" version after some official update. So I tried to switch to the "Googled" version in order to have a clean installation (I intended to go back afterwards).

Unfortunately the phone didn't like that update at all: It got bricked. The screen was all black, and the LED didn't work as it should. I couldn't even get to the rescue menu. (So I guess you'd better not rely on this phone's update function yet when using it for productivity!)

This was my journey into fixing it:

* Downloaded the "Googled" OS image from https://storage.googleapis.com/fairphon ... manual.zip.

* Extracted the ZIP file to a new folder.

* Extracted the battery and pressed the power button for approximately five seconds (in order to make sure that there is no current left anywhere).

* Re-inserted the battery.

* Pressed the "Volume down" and then the "Power" button until the phone vibrated, plus another five seconds.

* Connected the phone to an MX-16.1 machine (USB cable).

* Ran "sh flash-for-unix.sh".

* When the script told me so, pressed "Enter" on the MX-16.1 machine's terminal window in order to reboot the Fairphone 2.

However, this didn't do the job. I got an Android start screen but I couldn't move the slider.

So I downloaded the preferred "Fairphone Open" Version, which I happened to find here: storage.googleapis.com/fairphone-updates/27d01841-4cbd-4b0c-92af-f72f72fffbff/fp2-sibon-17.11.2-manual-userdebug.zip)). (You can see a versions' overview here: https://code.fairphone.com/projects/fp- ... loads.html).

While downloading, I rebooted the phone using the "Volume Down" + then "Power" trick which is sometimes being mentioned, and pressed, I think, "Volume Up" upon reboot, and then I got a symbol of an Android on its back, with an exclamation mark on it. Really bad damage apparently. No bootloader options, nothing.

"Fairphone Open" seemed to install fine. However, after reboot, I got Android boot loops, so this wasn't the solution either.

So I had a look at this official how-to titled "How to return to Factory settings on my Fairphone 2": https://support.fairphone.com/hc/en-us/ ... 5001610926, performed the hardware key combination magic described there and finally managed to get into the "TeamWin - TWRP" recovery manager (cf. https://twrp.me/about/).

There was an optioned named "Fix Contexts", but that didn't do any good.

So removed the battery again, reinserted it, pressed "Power" and then "Volume up" until the device switched on, and on the "TRWP recovery manager", I went to the "ADB Sideload" option and chose the wiping of both caches (I remember from past days that this can be of some importance sometimes).

Confirming this action led TWRP to "Starting ADB sideload feature". I didn't want to sideload anything so I rebooted.

Fairphone Open seemed to boot up o.k. but after much more than 10 minutes it seemed to me as if there was yet another loop.

So then I aborted by extracting the battery once more, went back into the TWRP and used the "WIPE" feature, using default options.

This did the job. A new and clean "Fairphone Open 17.11.2"2 showed up
(booting took a little longer than usually, but only few minutes).

All data lost unfortunately.

Admittedly this report isn't particularly well-structured because my efforts weren't. This is due to the fact that I never quite understood the logic behind fastboot, adb and TWRP, and what will always be available in a ROM and what won't, and where the bootloader is, etc. etc.

In case any one of you has ever fully understood these, and how they are connected, I'd be grateful for a short overview "for Dummies".

At last what I did understand as for now is that

power + volume up = recovery
power + volume down = fastboot

(https://forum.fairphone.com/t/i-think-i ... -2/15842/4

My next step will be trying to get Ubuntu Touch to this device, which for a number of technical reasons I like a lot more. If this of any interest to you, please have a look at viewtopic.php?f=121&p=425976#p425976.

Greetings, and a nice weekend to all of you, Joe

Post Reply

Return to “Success Stories”