Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

(SOLVED) Can't mount sd card in Antix 17.4.1

User avatar
Moltke
Forum Regular
Forum Regular
Posts: 201
Joined: Tue Dec 19, 2017 6:07 pm

(SOLVED) Can't mount sd card in Antix 17.4.1

#1

Post by Moltke » Mon Jul 15, 2019 12:16 pm

Hi everyone! Hope you're all having a nice life! :)

I just tried Antix 17.4.1 both, base and full .iso and can't mount a sd card, it doesn't even show, while it works just fine in 17.2.
It's on hp 2000 notebook, Dual Core AMD E-300 APU with Radeon HD Graphics. The sd card is a Trascend 32gb.
Last edited by Moltke on Sat Jul 27, 2019 6:42 pm, edited 1 time in total.
Without each other's help there ain't no hope for us :happy:

User avatar
manyroads
Forum Regular
Forum Regular
Posts: 1873
Joined: Sat Jun 30, 2018 6:33 pm

Re: Can't mount sd card in Antix 17.4.1

#2

Post by manyroads » Mon Jul 15, 2019 1:11 pm

Moltke wrote:
Mon Jul 15, 2019 12:16 pm
Hi everyone! Hope you're all having a nice life! :)

I just tried Antix 17.4.1 both, base and full .iso and can't mount a sd card, it doesn't even show, while it works just fine in 17.2.
It's on hp 2000 notebook, Dual Core AMD E-300 APU with Radeon HD Graphics. The sd card is a Trascend 32gb.
Do you have a viable mount point for the card(s)? I have found with CDs etc that I needed to create a mount point like /media/sr0. But I only have experience with antiX19....
Pax vobiscum,
Mark Rabideau - http://many-roads.com
bspwm MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
"For every complex problem there is an answer that is clear, simple, and wrong." H. L. Mencken
Testing: antiX19

User avatar
mxer
Forum Regular
Forum Regular
Posts: 205
Joined: Fri Sep 21, 2018 9:09 am

Re: Can't mount sd card in Antix 17.4.1

#3

Post by mxer » Mon Jul 15, 2019 1:46 pm

Does it show up in your dmesg output, has it been assigned a drive designation(?).

(Perhaps it is mounted under /media)
(FOSS, Linux, & BSD since 1999)

User avatar
Moltke
Forum Regular
Forum Regular
Posts: 201
Joined: Tue Dec 19, 2017 6:07 pm

Re: Can't mount sd card in Antix 17.4.1

#4

Post by Moltke » Mon Jul 15, 2019 4:04 pm

mxer wrote:
Mon Jul 15, 2019 1:46 pm
Does it show up in your dmesg output, has it been assigned a drive designation(?).

(Perhaps it is mounted under /media)
No, it doesn't. I checked /media and there was nothing there. Also, I tried the usb maker and the resulting usb live didn't boot properly. Maybe some bugs no one else has spotted? It happened in both, base and full .iso, I tried the demo, live session only. Not sure whether a full install, update & upgrade would do the trick but...that was my experience.
Without each other's help there ain't no hope for us :happy:

User avatar
Moltke
Forum Regular
Forum Regular
Posts: 201
Joined: Tue Dec 19, 2017 6:07 pm

Re: Can't mount sd card in Antix 17.4.1

#5

Post by Moltke » Fri Jul 19, 2019 8:05 pm

Well, I can confirm that Antix sees the card reader.

Code: Select all

lspci -v
shows

Code: Select all

08:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
        Subsystem: Hewlett-Packard Company RTS5229 PCI Express Card Reader
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at 90100000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
However, it doesn't seem to be able to mount the sd card or even see it at all :(
Without each other's help there ain't no hope for us :happy:

User avatar
JayM
Qualified MX Guide
Posts: 2147
Joined: Tue Jan 08, 2019 4:47 am

Re: Can't mount sd card in Antix 17.4.1

#6

Post by JayM » Fri Jul 19, 2019 8:55 pm

Moltke wrote:
Mon Jul 15, 2019 4:04 pm
mxer wrote:
Mon Jul 15, 2019 1:46 pm
Does it show up in your dmesg output, has it been assigned a drive designation(?).

(Perhaps it is mounted under /media)
No, it doesn't. I checked /media and there was nothing there. Also, I tried the usb maker and the resulting usb live didn't boot properly. Maybe some bugs no one else has spotted? It happened in both, base and full .iso, I tried the demo, live session only. Not sure whether a full install, update & upgrade would do the trick but...that was my experience.
Are you using Live USB Maker to burn the antiX iso to the SD card, or to a USB stick? If it's a USB stick then either the iso you downloaded is corrupt or the USB stick is either bad or incompatible with the antiX live system. If you're burning the iso to an SD card and trying to boot with it, someone else will have to step in and help as I don't even have a card reader on my system.
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

User avatar
Moltke
Forum Regular
Forum Regular
Posts: 201
Joined: Tue Dec 19, 2017 6:07 pm

Re: Can't mount sd card in Antix 17.4.1

#7

Post by Moltke » Sat Jul 20, 2019 12:35 am

JayM wrote:
Fri Jul 19, 2019 8:55 pm
Moltke wrote:
Mon Jul 15, 2019 4:04 pm
mxer wrote:
Mon Jul 15, 2019 1:46 pm
Does it show up in your dmesg output, has it been assigned a drive designation(?).

(Perhaps it is mounted under /media)
No, it doesn't. I checked /media and there was nothing there. Also, I tried the usb maker and the resulting usb live didn't boot properly. Maybe some bugs no one else has spotted? It happened in both, base and full .iso, I tried the demo, live session only. Not sure whether a full install, update & upgrade would do the trick but...that was my experience.
Are you using Live USB Maker to burn the antiX iso to the SD card, or to a USB stick? If it's a USB stick then either the iso you downloaded is corrupt or the USB stick is either bad or incompatible with the antiX live system. If you're burning the iso to an SD card and trying to boot with it, someone else will have to step in and help as I don't even have a card reader on my system.
No, I'm not trying to burn/write the Antix 17.4.1.iso into the sd card, that'd be easier. Antix 17.2 does see, recognize and automatically mount the sd card. It just happens with 17.4, I tried with the full.iso, base.iso and core.iso, none of them sees it let alone mount it. I haven't tried with Antix 19. The thing with the usb maker is just another one which didn't work either. Funny thing is 17.2 does not auto-mount my usb hdd while 17.4 does. The sub stick is just fine, the card reader and the sd card are too, the problem is inside, within Antix, some obvious missing package or packages are needed for it to find and mount the sd card.
Without each other's help there ain't no hope for us :happy:

User avatar
JayM
Qualified MX Guide
Posts: 2147
Joined: Tue Jan 08, 2019 4:47 am

Re: Can't mount sd card in Antix 17.4.1

#8

Post by JayM » Sat Jul 20, 2019 12:49 am

Also, I tried the usb maker and the resulting usb live didn't boot properly.
Did you check the iso file's md5 sum after downloading it? How didn't it boot properly? There may be more going on than just not mounting the SD card if you're also having a boot issue.
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

User avatar
Moltke
Forum Regular
Forum Regular
Posts: 201
Joined: Tue Dec 19, 2017 6:07 pm

Re: Can't mount sd card in Antix 17.4.1

#9

Post by Moltke » Sat Jul 20, 2019 2:39 am

JayM wrote:
Sat Jul 20, 2019 12:49 am
Also, I tried the usb maker and the resulting usb live didn't boot properly.
Did you check the iso file's md5 sum after downloading it? How didn't it boot properly? There may be more going on than just not mounting the SD card if you're also having a boot issue.
Maybe I didn't explain myself good the first time. From Antix 17.2 I created a live usb containing Antix 17.4.1, which booted just fine, no problems at all. Once in the desktop, in the 17.4.1, I open spacefm and noticed that my sd card wasn't mounted, it didn't even show. After some inspection I found out that Antix 17.4.1 didn't see my sd card althought it did see the card reader. From that live usb, containing Antix 17.4.1, I tried the live usb maker and create one with antix 17.2, which didn't boot properly, so I guess something is missing there. Like I said, I tried with 3 different versions; full.iso, base.iso and core.iso. I only tried the usb maker with the full.iso, though.
Without each other's help there ain't no hope for us :happy:

User avatar
JayM
Qualified MX Guide
Posts: 2147
Joined: Tue Jan 08, 2019 4:47 am

Re: Can't mount sd card in Antix 17.4.1

#10

Post by JayM » Sat Jul 20, 2019 4:29 am

What does lsblk show?

If the SD card is there, try manually mounting it from the command line:

Code: Select all

sudo mkdir /mnt/sdcard
sudo mount /dev/sdX /mnt/sdcard
where sdX is the drive designation of the SD card as shown in lsblk (i.e. /dev/sdb, /dev/sdc1)
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

Post Reply

Return to “antiX”