Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Fixed with new install - AxtiX 17.1 can't sign in as user -

Post Reply
Message
Author
User avatar
namida12
Forum Guide
Forum Guide
Posts: 1798
Joined: Sun Apr 01, 2007 4:54 pm

Fixed with new install - AxtiX 17.1 can't sign in as user -

#1 Post by namida12 » Wed Aug 08, 2018 5:37 pm

Dell product: Inspiron 14-3452 v: 4.0.7

Was running sweet, but now I can not sign into the system. Have machine name and passwords User and root scotched taped to right side of touchpad...
Always opened previously but not any longer.

Can't boot system except using a flash drive:
Can I change the password with live live media?

Check users name: when I shut down it gives me a User name as last item on closing dialog, and that matches what i have always used, and have written on paper taped to system.

Have never booted with root password. Can I reset user password booting as Root in AntiX? How as using root password does not let me boot?

JR
Last edited by namida12 on Sun Aug 12, 2018 9:52 am, edited 1 time in total.

User avatar
Richard
Posts: 2075
Joined: Fri Dec 12, 2008 10:31 am

Re: AxtiX 17.1 can't sign in as user -

#2 Post by Richard » Wed Aug 08, 2018 7:01 pm

While you are waiting, I would suggest that you boot up with flash drive,
and back up anything you wish to save. Also look in ~/.config to see if there is anything
that you might wish to save.
Just in case.

These are the steps:
DEBIAN / UBUNTU root PASSWORD RECOVERY
second answer from:
https://serverfault.com/questions/48207 ... -user-mode

1. First screen - grub - press e
Image
2. Modify kernel line: add single between ro quiet and at the end of this line add init=/bin/bash
Image

3. Press F10
4. When the prompt is root@(none):/# you have to remount the / partition to have read-write access:mount / -rw -o remount

5. Now you are ready to modify the root password: type passwd and change it!

Good luck
See the pictures here & the above is the second answer.
https://serverfault.com/questions/48207 ... -user-mode
MX171: Lenovo T430: Intel DualCore i5-3320M, 8GB RAM, 4.18.7-antix.1-amd64-smp, 119GB SSD
MX171: AA1/EeePC: DualCore N270, 1GB RAM, 4.9.126-antix.1-686-smp-pae, 150GB HDD
DoubleCmd84, LibO61, Dropbox, PaleMoon, CherryTree, Vbox. LinuxCounter #208633

User avatar
namida12
Forum Guide
Forum Guide
Posts: 1798
Joined: Sun Apr 01, 2007 4:54 pm

Re: AxtiX 17.1 can't sign in as user -

#3 Post by namida12 » Sat Aug 11, 2018 1:04 am

Was a new install, have only done updates and several google hangout chats with family in Japan & UK...

I have nothing to lose re-installing Antix, that takes about 15 minutes including updates on this 32 Gig hard drive Dell Laptop.

I just thought someone would explain how to boot into root so I could change the users password. I will need the system on Saturday evening for my weekly video chat... Will do that in the morning, does not take many minutes and I will use fehlix suggestion to use home and root as one partition because there is not much room on the small eMMC-h
https://forum.mxlinux.org/viewtopic.php ... 20#p455649

I find it very strange that the user password was working for 2 weeks, and now does not work... First time for me, to have a User password fail/change...


JR

Justinian
Forum Novice
Forum  Novice
Posts: 19
Joined: Wed Jan 11, 2017 3:14 am

Re: AxtiX 17.1 can't sign in as user -

#4 Post by Justinian » Sat Aug 11, 2018 2:14 am

Over a year ago I might have unchecked save session on the logout screen of MX16 prior to shutdown. After that I could not go back in automatically and it would only let me in as root. I failed to re-enable the user by trying passwd so I figured it might be easier to reinstall MX on the Core 2 Duo desktop which, the last time I saw it, was blissfully flying on MX17.1. But it's the Pentium M laptop running AntiX17 Base fully installed on flash USB I'm using and its logout does not have save. Maybe I'll be able to check my suspicion after there is an August or September snapshot I can put on the desktop if autologin should happen to break.

User avatar
KoO
Forum Regular
Forum Regular
Posts: 280
Joined: Fri Feb 10, 2017 1:21 am

Re: AxtiX 17.1 can't sign in as user -

#5 Post by KoO » Sat Aug 11, 2018 10:49 pm

@ namida12
Sorry to hear about your log in trouble I for one know how you feel this happened to me as well a month or so ago.But I could log in as root but my user password was gone forever and their was no way Antix would let me make a new user or change the password. Was painful after running for months just fine.

If you get to the login screen type (root) then your password you can do the same from the command line login as well.
Da Main Box .Antix 17.2 (4.18.7) i3 ,Windows8.1 , Intel Xeon E3-1241 v3 , 16gb HyperX , Samsung EVO 860 500 GB , Samsung EVO 860 500 GB , GTX 970
Lappy .Lenovo T430 AntiX17.2 (4.18.7) i3 ,Windows8.1 , i5 +4000 , 8gb , Samsung EVO 860 500 GB , 1TB HGST

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5713
Joined: Sat Jul 15, 2006 10:40 am

Re: AxtiX 17.1 can't sign in as user -

#6 Post by anticapitalista » Sun Aug 12, 2018 5:08 am

Is your home full?
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
namida12
Forum Guide
Forum Guide
Posts: 1798
Joined: Sun Apr 01, 2007 4:54 pm

Re: AxtiX 17.1 can't sign in as user -

#7 Post by namida12 » Sun Aug 12, 2018 9:50 am

anticapitalista wrote:
Sun Aug 12, 2018 5:08 am
Is your home full?
Anticapitalista,

No there was nothing saved but I had used the system for hangout video chats with family in Japan and the UK...

I have formatted the drive and installed Antix again as I needed the system for Video Chat last evening. I followed Fehlix suggestion for the new install on the small eMMC hard drive. My first time using only a root partition for root and home partition.
https://forum.mxlinux.org/viewtopic.php ... 20#p455649

Started it several times afterwards appears to work well as it did previously.
Thanks to everyone for their suggestions.

JR

Post Reply

Return to “antiX”